1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Humax HDR Fox T2 has sound but no picture?

Discussion in 'HDR-FOX T2 Freeview Recorder' started by Eddy_J1, Dec 15, 2012.

  1. Eddy_J1

    Eddy_J1 New Member

    I received my grade A Humax box the other day and setup went fine but when I try watch a channel I hear sound but theres no picture. I have tried changing hdmi cables and ports and it still doesn't work.

    Do I have a faulty unit or am I doing something wrong?

    My TV is a Hannspree 32 inch LED HD.

    Thanks in advance.
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    To narrow down the problem you could try using a scart connection rather than the HDMI, if your TV has a scart input. If the scart works O.K. it maybe worth trying the different video modes using the Remote Control V-Format button
     
  3. Eddy_J1

    Eddy_J1 New Member

    Thanks for the reply, unforfunately my tv has no scart, ive tried the v format and nothing happens, ive read something abouy maybe needing something else aswell as the hdmi lead going from the box to tv, is this right?

    All I have currently is aerial into box, hdmi out box into tv.

    Cheers
     
  4. Ezra Pound

    Ezra Pound Well-Known Member

    No, HDMI carries both Video and Audio over the same 3 pairs of wires, the Audio and Video is combined in the Humax and separated in the TV (they don't use different wires for Audio and Video) so it can't be, for example, that some wires are not making contact. You don't need any other cables to the TV
     
  5. Black Hole

    Black Hole Felonius Gru

    I don't think you are doing anything wrong, but at the moment you don't know whether you have a faulty TV or a faulty Humax. Can you try another HDMI source on the TV (a DVD player for example, or a computer if you have a notebook with an HDMI output), and try the Humax on another TV (even if you have to take it to a friend's house)?
     
  6. Eddy_J1

    Eddy_J1 New Member

    Tested another source, PS3 to TV on all hdmi ports works fine with no issues, also tried the humax on another tv(which works with another humax freesat box) and it does exactly the same, no picture but has sound.
     
  7. Black Hole

    Black Hole Felonius Gru

    That's conclusive then.
     
  8. Eddy_J1

    Eddy_J1 New Member

    Do you think I should just ask Humax for a replacement box, another thing I noticed is when you view the menu it occasionally flickers up and down.
     
  9. Ezra Pound

    Ezra Pound Well-Known Member

    I think you have done enough testing to justify a replacement, I would tell Humax the steps you took
     
  10. xyz321

    xyz321 Well-Known Member

    If you can see the menu this suggests that there may be a problem with tuning the channels. Do you see the list of channels when pressing the list button?