Humax HDR-T2 not recording, deleting, copying files to USB and no sound on some recordings

St Claus

New Member
My mum's humax HDR-T2 has developed a major problem. It will not record, delete, copy files to Flash Drive and the no sound when playing back some recordings.

She has been using the PVR for several months without a single problem.

The software version is the original version that was pre-installed on the box when it arrived.

I have tried a power cycle and restoring to factory defaults but no luck.

Is there any way to fix this?

Thank you in advance for your help and suggestions!

PS She has some recordings that she would like to keep, so hopefully we will not have to reformat the disc. The system will not allow me to copy files to an external drive and she does not have internet access to FTP the files over. Can I simply attach my laptop by cable and backup the files using Windows Explorer?
First thing is why do you think it has not had firmware updated? Firmware updates occur automatically via the TV aerial (as long as you have the HiDef channels tuned in) unless you take specific action to ensure it doesn't happen (like turning the power off at the mains overnight).

To be sure, Menu >> Settings >> System >> System Information >> Software Version - report what it says.

If the firmware really is old (pre-1.02.20), recordings of HiDef programmes will not play sound. For more information see Things Every HDR-FOX Owner Should Know (click) section 1.

I think it is likely the hard drive has gone "read only". This is a file system error, and we have tools to fix it without losing anything (or not much - anything you do lose would have been lost anyway). You will need to install the custom firmware and set up an Ethernet link to your PC - for further information see HERE (click).
Bizarrely my Mother's T2 started having the same problem around that time. Unfortunately I don't live near her and even though most of her problems I can solve over the phone it seems this one I can't. Did you manage to fix it?

Seems odd that both of these boxes started with these problems around the same date. I wonder if an OTA update has caused issues?
This was a brain melter but we finally got it working. Here is how we did it:

The Humax HDR-T2 got into a delete loop/permanent delete loop. This was presumably triggered when we deleted a large HD file. To stop the delete loop, we installed Version 1..01.09 of the software. This stopped the delete loop. We then upgraded the software to the latest version: 1.02.32 but the delete loop returned. We reinstalled 1.01.09 and the system worked fine for a few days. Then it jumped into a read only mode for some unknown reason and we could not record, copy files to external drive or delete. This is how we eventually fixed it:

Version Currently installed 1.01.09 - Problem Read only mode - Desired action: to remove read only mode
1. Update to Version: 1.02.32.
*Download Version 1.02.32 from
http : / / wiki . hummy . tv / wiki / Firmware_Downloads (remove spaces to get link - I cannot post link directly because I am a newbie!)
* Copy update to a flash drive (file must be on the root of the drive - NOT in a folder)
* Switch off Humax box using switch at rear of machine
* Plug in the flash drive to an available USB port
* Switch on Humax box using switch at rear of machine
* Upgrade will take approx. 5 mins.

Version Currently installed 1.02.32 - Problem Delete Loop reappears/cannot copy files to external drive - Desired action: to remove Delete Loop + back up existing recordings

2. Downgrade to Version: 1..01.09 using steps outlined above!

Version Currently installed 1.01.09 - Now Delete Loop and Read only mode have been removed and ready to proceed with backup of important recordings

3. Backup important recordings to an external hard drive or flash drive using the COPY function (see manual for more details)

Version Currently installed 1.01.09 - Files now backed up and ready to reformat disk

4. Note down any scheduled recording on a piece of paper, as they will be lost

5. In the menus, navigate to "Restore Factory Defaults and select Format HDD"; click OK

This will result in the device being restored to a 'just out of the box' state

Copy the important recording back onto the hard disc from the external drive.

Reschedule the programme recordings on your list.

Finally, upgrade to version 1.02.32, so that the software is up-to-date
PS thank you Black Hole for all your help and advice. This definitely pointed us in the right direction!!
PS @Shaune Fradley - The customised software appears to be amazing but do not install if if your mum's box is still under guarantee as it can invalidate the warranty!!!
You can remove the CF and set it to ==RMA== mode. This removes the traces of the CF so the box can be returned. It's unlikely that Humax will check anyway!.

Of course, this assumes that the fault you have with the box, allows you to do this!
It would have been sooooo much easier just to cure the delete loop and/or read-only fault using the custom firmware disk utilities (non-destructive), and then remove the CF afterwards (if desired).
Thanks St Claus for the detailed answer, pleased you got it fixed. I'll give everything a try on my next visit.

I'll also look into the custom firmware, thanks Black Hole.