I can't see beta packages on the main machine any more

everthewatcher

Forum Supporter
Posted this in another thread and was told I probably need to re-enable the opkg-beta package from the command line.

A bit of hand-holding please - how do I do re-enable it?

FWIW if I try to uninstall opkg-beta I get:
Code:
>>> opkg remove opkg-beta
umount: can't umount /etc/opkg: Invalid argument
Removing package opkg-beta from root...
You can force removal of packages with failed prerm scripts with the option:
    --force-remove
No packages removed.
Collected errors:
* pkg_run_script: package "opkg-beta" prerm script returned status 1.
* opkg_remove_pkg: not removing package "opkg-beta", prerm script failed

Done.
 
Last edited:

af123

Administrator
Staff member
From the command line, (via telnet menu or webshell):

Code:
opkg remove --force-remove opkg-beta
opkg install opkg-beta
 
OP
everthewatcher

everthewatcher

Forum Supporter
Hmm. Looks like there's something more to it than that:
Code:
Humax1# opkg remove --force-remove opkg-beta                                                                                  
Removing package opkg-beta from root...
umount: can't umount /etc/opkg: Invalid argument
Collected errors:
* pkg_run_script: package "opkg-beta" prerm script returned status 1.                                                        
Humax1#
 
OP
everthewatcher

everthewatcher

Forum Supporter
But on running it again I got:
Code:
Humax1# opkg remove --force-remove opkg-beta                                                                                   
No packages removed.                                                                                                           
Humax1#
So I tried the next line and got:
Code:
Humax1# opkg install opkg-beta                                                                                                 
Installing opkg-beta (1.1) to root...                                                                                           
Downloading http://hpkg.tv/hdrfoxt2/base/opkg-beta_1.1_mipsel.opk.                                                             
Configuring opkg-beta.                                                                                                         
Humax1#
 
OP
everthewatcher

everthewatcher

Forum Supporter
And now I can see the Beta packages again.

Looks like I was reading too much into the "umount: can't umount /etc/opkg: Invalid argument" line - I'm not a Linux person.
 
Top