IR package not controlling HD fox t2 with some browsers

paulj_

New Member
I had an older custom firmware pack installed on a HD FOX T2, ir module (mongoose server) had worked fine to control T2 remotely via opera browser a year ago.
Re-starting to use HD FOX t2 (after a year with foxsat hdr and custom fw) I found that using remote from either
- IE explorer 11 (windows 8 metro touch or desktop, also windows 7) or
- Firefox (30)
IR was unresponsive (button presses on web page gave no reaction on t2) and ir only seemed to work with firefox (40).
I updated firmware (dowloaded latest complete fw package and re-flashed) hoping that latest IR module
Using lighttpd server would fix issues, but the problems remain with IE11 and FF30 .
Is there a known compatibility issue ?

I then tried to debug the IR module. - this failed
1. Enabling /var/log/humaxtv.log via telnet 'touch /var/lib/humaxtv/mod/debugtv'
2. enable diagnostic
' ir3/debugon = Enable remote control input to be logged in the humaxtv.log'
however humaxtv.log did not get created after trying several IR remote buttons

I also noticed other parts of the IR plugin not working, I had previously set some customized channel
Shortcuts, however trying to add further channels to quick-list '192.168.1.2/plugin/ir/settings.jim'
This mechanism failed on selecting channels from list and presssing 'left arrow' button to move to
Quick-list, I had message 'Settings saved successfully' but returning to IR they had not been added.

Should I remove all custom software (or RMA mode) and then re-install in hope this might resolve problems ?

Paul
 

af123

Administrator
Staff member
There isn't a known compatibility issue.
I would try running the 'fix-webif' diagnostic first to force a fresh installation of that component.
Then see if there is anything in the webif-error log.

humaxtv.log won't appear until after a restart, that's normal.
 
OP
P

paulj_

New Member
af123 Thanks, I tried the 'fix-webif' diagnostic
Running: fix-webif
Removing package webif from root...
Not deleting modified conffile /mod/webif/html/favicon.ico.
Collected errors:
* file_md5sum_alloc: Failed to open file /mod/webif/html/favicon.ico No such file or directory.
Downloading hpkg.tv /hdrfoxt2/base/Packages.gz.
Inflating hpkg.tv /hdrfoxt2/base/Packages.gz.
Updated list of available packages in /mod/var/opkg/base.
Installing webif (1.2.5-6) to root...
Downloading hpkg.tv /hdrfoxt2/base/webif_1.2.5-6_mipsel.opk.
Configuring webif​

I then rebooted the T2.
The webif ir page was now not available (
404 - Not Found)
192.168.1.2/plugin/ir/remote.jim

although the ir package was still listed as installed.
'1.02-2 A web-based remote control plugin for the Web Interface. Allows you to send remote control commands to your Humax from a web browser.'
how do I re-enable it ? (re-install all cfw from usb?)

[In original message I had failed to say that system originally had CFW2.xx and that via usb stick I had
installed HD_FOX_T2_1.03.02_mod_3.03.zip]

Thanks, Paul
 
OP
P

paulj_

New Member
Modulators : as a newbie I cannot post links 'hpkg.tv /hdrfoxt2/base/Packages.gz.' without the space after tv
is characterised as a link ( I spent 10 minutes trying to obfuscate links)
 

af123

Administrator
Staff member
Run a force-reinstall of the ir package from the web interface diagnostic page.
 
OP
P

paulj_

New Member
OK,
after the fix_webif, I noticed an upgrade was avilable for ir package from 1.02-2 and after updating to 1.12
interface now seems to work with IE11 browser.
I guess that HD_FOX_T2_1.03.02_mod_3.03.zip did not have this version of ir, or that fix_webif installed
an older version.

upload_2015-11-17_14-32-7.png

the only remaining problem I have is that within Ir custom channels favourite list whilst populated with
text name of channel in mobile interface, has just a blank space in the full desktop IR, as though the
icons associated with the channels were not available.
I cannot see any further packages I might upgrade though.

*update* I forcible re-installed ir as well, like you suggested, but favourite channel icons
are still absent

Paul
 
OP
P

paulj_

New Member
within mobile interface, favourites I see

upload_2015-11-17_14-44-49.png(no option to shrink bitmap!)
in std interface on firfeox 40
upload_2015-11-17_14-44-17.png
and IE 11
upload_2015-11-17_14-45-49.png

ok ... I did a force install of webif-channelicons and problem is fixed.
 
Top