[ir] Web-based Remote Control

prpr

Well-Known Member
You never needed the git folder anyway. That was just a bit of laxness in the previous postings. You should have used /tmp instead.
 

MymsMan

Ad detector
Sorry for any confusion, humax /mnt/hd2/mod/git # is my command prompt (and a different colour) and mod/git is just my default working directory and included in the prompt so I don't get too confused about where I am.
 

/df

Active Member
...I've removed the 1.20 version from the repository - it isn't crashing any of my three boxes though so I don't know what's going on yet.
With beta packages enabled, diag fix-flash-packages removes and then fails to re-install ir.
Code:
...
Re-installing ir
Removing package ir from root...
Installing ir (1.20) to root...
Downloading http://hpkg.tv/hdrfoxt2/beta/ir_1.20_mipsel.opk.
Collected errors:
 * opkg_download: Failed to download http://hpkg.tv/hdrfoxt2/beta/ir_1.20_mipsel.opk, wget returned 8.
 * opkg_install_pkg: Failed to download ir. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package ir.
...
The package can be re-installed directly after downloading it; installing directly from its URL, as commenters above suggested, didn't work, as opkg ignored the package version in the URL and went directly for what it thought was most recent, as above:
Code:
wget -U '' http://hpkg.tv/hdrfoxt2/beta/ir_1.19_mipsel.opk
opkg install ir_1.19_mipsel.opk
# or, reverting beta,
wget -U '' http://hpkg.tv/hdrfoxt2/base/ir_1.17_mipsel.opk
opkg install ir_1.17_mipsel.opk
 
Last edited:

prpr

Well-Known Member
With beta packages enabled, diag fix-flash-packages removes and then fails to re-install ir.
Because /mod/var/opkg/beta still refers to 1.20 even though it's been removed. The file needs to be rebuilt when packages are removed, but it hasn't been.
I guess we can hope for 1.21 sometime, as alluded to back in July.
 

MymsMan

Ad detector
Because /mod/var/opkg/beta still refers to 1.20 even though it's been removed. The file needs to be rebuilt when packages are removed, but it hasn't been.
I guess we can hope for 1.21 sometime, as alluded to back in July.
Unfortunately we are dependent on @af123 for updates and he has been largely out of action since July
 

prpr

Well-Known Member
I've made my own extra repository, with just the old ir_1.19 package and a couple of my private/test packages in it, and added it like opkg-beta does on the Humax.
Works nicely. :)
 

Black Hole

May contain traces of nut
With beta packages enabled, diag fix-flash-packages removes and then fails to re-install ir.
Oh shit. I thought I would see what happens if I remove the opkg-beta package and then run fix-flash-packages... bad move. It stripped out my beta WebIF and didn't reinstall.

I think the fix-flash-packages diagnostic needs some safeguards!
 
Top