Kaspersky doesn't like Browse Media Files or Scheduled Events.

Strange... I run Kaspersky Internet Security and have no problems with those pages via Firefox, IE or Chrome.
I don't believe that I have any special settings anywhere to accommodate the Humax.
OK, I finally got so bored with this that I worked out how to fix it.

In case anyone else has the same problem, in Kaspersky Pre 3.0 go to SETTINGS - WEB ANTI-VIRUS - EXCLUSIONS and add the appropriate URL to the list of exclusions.