Linking Two HDR-FOX T2's by Foxlink

Hi all

Just powered up both boxes.

On HDR2 (Server) there are 3 HD files and all have the green DLNA symbol but none have the green Dec symbol.

The Recursive Auto-decrypt symbol is still showing against the My Video directory (and has been set 'automatically' in the HDR1 against the HDRtwo Directory).

HDR1 (where Decryption is working fine) is using HDR_FOX_T2_1.02.32_mod_2.21. and HDR2 is on HDR_FOX_T2_1.03.06_mod_2.21.

Just a thought but is anyone using 1.03.06/1.03.11 having similar Decryption problems?

EDIT auto.log is empty.
OK, the DLNA server is working fine then. To confirm, none of the files still have the orange 'enc' flag when viewed in Web-If? Can you manually decrypt a file through Web-If?
I think that the recursive auto-decrypt flag needs to be set from within the server (HDR2) Web-If page, but once this is done the open padlock/ arrow symbol will also be seen when exploring the client (HDR1) Web-If. Try unsetting the recursive auto-decrypt and then setting it again.
It is almost certainly not an issue with the software version, but I have not tried the 1.02.32/ cf 2.21 combination myself as I was already on 1.03.06 when cf 2.21 became available.
Hope you get it to work, if it still does not there might be problems with running processes etc. and this is above my pay grade to troubleshoot. You may need help from af123 or one of the other 'gurus' to fix it.
Hi Monty

No orange 'enc' flag.

Tried disabling Recursive Auto-decrypt and then enabling it again many times and again today.

Tried Manual Decrypt and it works fine but if I need to do this Manually for every file on HDR2 so I can play etc. via HDR1 it will be much quicker/easier to just play them 'direct' on HDR2.

So appears to be down to getting Recursive Auto-decrypt working.

Any suggestions?
It sounds like the automatic processing is not running. Normally, when a HDR is on with recursive auto-decrypt enabled, it checks for DLNA indexed, encrypted files every 10 mins. If it finds one it runs the decryption, posting the results in the auto.log file. I don't have a deep enough knowledge of how it works to debug this process, but others do, and should be able to help. The only thing I can suggest is to update to a later version (1.03.06 or 1.03.11/ cf 2.22) and see if that fixes the problem.
Up the auto processing log level in the WebIF >> Settings >> General Settings, see if there is more info about this problem.
Hi Black Hole

Tried both auto processing log levels but nothing so far under auto.log (am I looking in the right place?).

Also 'upgraded' to HDR_FOX_T2_1.03.11_mod_2.22_b1905 but no joy so far.

Are there certain packages that need to be running to support Recursive Auto-decrypt?
auto.log is the right place. If you've set the processing level to 'Debugging information' and you still aren't seeing anything in there after ten minutes then the next thing I'd check is what happens if you run the diagnostic called auto. Go into the web interface diagnostics screen, enter auto in the box and click 'Run Diagnostic'.
If everything's working as it should, there will be no output (that will change with the next webif version but for now, expect nothing apart from errors). If there is still nothing in the auto.log then we'll have to look at running it from the command line to see what's wrong. It's also worth checking to see if your cron file has the auto line in it. Go to Diagnostics->File Editor and click on the file that ends with .../crontabs/root in the box at the bottom of the page. When the file loads, check for a line like:

*/10 * * * * /mod/webif/lib/bin/auto >/dev/null 2>&1
Only what it said in my previous link to decryption info.

Maybe af123 can suggest something.

Edit: he just did.
Hi af123

Run auto for a few minuets then clicked on auto.log and got

>> Contents of /mod/tmp/auto.log 284.00 bytes
27/01/2014 16:08 - -------------------------------------------------------
27/01/2014 16:08 - Media scan starting, DLNA server status: 1
27/01/2014 16:08 - DECRYPT: /media/My Video/_original/Unstoppable_20140126_2058
27/01/2014 16:08 - DLNA:

Run auto again and got

>>> Beginning diagnostic auto
Running: auto
Cannot acquire exclusive lock, terminating.

>>> Ending diagnostic auto

Clicked on auto. log again and now

>>> Contents of /mod/tmp/auto.log 546.00 bytes
27/01/2014 16:08 - -------------------------------------------------------
27/01/2014 16:08 - Media scan starting, DLNA server status: 1
27/01/2014 16:08 - DECRYPT: /media/My Video/_original/Unstoppable_20140126_2058
27/01/2014 16:08 - DLNA:
27/01/2014 16:26 - Removing/binning old copy.
27/01/2014 16:26 - Done... 8.42 GiB in 1058.454 seconds - 8.14 MiB/s
27/01/2014 16:26 - DECRYPT: /media/My Video/_original/Sportsday_20140126_1828
27/01/2014 16:26 - DLNA:
Do a force-reinstall of your webif package, again via the webif diagnostics screen, and check the crontab again.
>>> opkg install --force-reinstall webif
Removing package webif from root...
Not deleting modified conffile /mod/var/mongoose/html/favicon.ico.
Installing webif (1.0.7-12) to root...
Postinstall configure
realloc: 0
spinretry: 0
pending: 0
offline: 0
Resetting unwatched count on /media/My Video...
Resetting unwatched count on /media/My Video/[Deleted Items]...
Resetting unwatched count on /media/My Video/[Deleted Items]/webif_autodecrypt...
Resetting unwatched count on /media/My Video/[Deleted Items]/webif_autodecrypt/_original...
Resetting unwatched count on /media/My Video/[Deleted Items]/webif_autodecrypt/The Musketeers...
Resetting unwatched count on /media/My Video/_original...
Resetting unwatched count on /media/My Video/The Musketeers...
Configuring webif.
Collected errors:
* file_md5sum_alloc: Failed to open file /mod/var/mongoose/html/favicon.ico: No such file or directory.

crontab now

0 2 * * * /mod/sbin/anacron -s -d
* * * * * /mod/monitor/run
*/10 * * * * /mod/webif/lib/bin/auto >/dev/null 2>&1
I manually decrypted 2 files and the third now has the green Dec so appears to be working now.

Was it something I did or just a 'bad' install?
It might be related to that error about the favicon.. Have you removed that by hand by any chance? It's fixed now anyway.
I haven't removed anything and not sure what favicon is.

EDIT is favicon part of auto-schedule-restore?

If so it's in my 'available' not 'installed' list.

All appears fine now so thanks again for you help.