Loading of the CFW software did not complete.....help please


After a long and very pleasing time using the CFW on my HD-Fox T2, I decided to splash-out on a HDR-Fox, with a view to being able to stream to the HD-Fox using the the HDR's media server capabilities, etc.

Spent a short time proving the HDR's setup and capabilities in 'native mode' (streaming to the HD-Fox IS good!) before proceeding to load the CFW to the HDR (1.02.32/2.16). Having been through many upgrades to the HD (from around the beginning of development of the CFW actually) I was no stranger to the process.

However, when in the process of loading the software via the 'initiate loading button' and as I was monitoring all the loading messages.....it then just stopped. I cannot access the Webif page when I type the HDR's IP address - what I get is a web page showing 'Index of /' and 'img/' being a directory with name/modified/size headings. I can access the HDR box using telnet and see the 'telnet menu' and can access it using FTP.

Could someone please tell me how I can resume the software loading and/or reset the process? I assume that having the telnet access is going to be useful?............

Many thanks in anticipation of a reply.
Flush it out and start again. You can try reloading standard firmware and then adding custom firmware, but it will probably be confused by the remnants of the previous aborted install sitting on the hard drive.

As you stand now, you can access the Telnet menu and select the "RMA" option - this will clear things out better and you can start again. See Wiki HERE (click).

For info: Contrary to common misunderstanding, "RMA" stands for "Return of Materials Authorisation" - the docket used to authorise the Goods Inwards department to receive a warranty return, not "Return to MAnufacturer". As an acronym (or for the pedantic: initialism) it's in wide circulation but should never have got into the wild, being an internal administrative process and not something to trouble the customer with. Typically, when you negotiate a warranty return with a company, the Customer Service people will log an RMA and issue you with a reference number to enclose with the item. Goods Inwards (where deliveries are received) have to check everything received: eg items ordered against a purchase order; or in this case the RMA reference against the form that Customer Services registered. Goods received without any accompanying paperwork will get rejected (or at the very least will go into limbo).*

Perhaps the CF should use a more self-explanatory term, eg "flush".

* Now added to the Glossary.
Thank you for the swift reply BH

I thought that was the best option, but when running the SETRMA diagnostic via the telnet menu, I got the 'confirm running prompt (Y/N)' chose Y of course and then nothing seems to have happened. I could still access the telnet menu? Tried running several times.

What should I do now? Try reloading the CFW 2.16 and run the risk of previous remnants confusing the next attempt?

I await guidance. Thanks.
Never having done it myself, I think (and the Wiki says) you need to reboot. The front panel should then show "RMA" and loading an official firmware will complete the process.
Tried a reboot (several times) and didn't see 'RMA' on the front panel. It still shows 'Cust FW 2.16' on reboot.

Any ideas?
OK, well in the absence of the likes of af123 or xyz321 we'll have a go at doing it manually. I might be a little off the mark, but we can't make things worse!

Telnet in and from the menu select the "cli" option to get to a command prompt. Then:

cd /mod
rm -r *

Now install standard firmware.

I think you should now be able to start again.
OK seems to make sense to me - but what do I know ! Have used the 'cli' option to look 'round already.......so here goes !
Hurray...........it all worked !!

There was - worryingly - an unusually long pause during standard firmware programming at 79% !!! Took ages to proceed !!!

Anyway 'all's well that ends well' !

Thank you very much BH for your rapid response and all your help.

Best regards.
Very long pauses during firmware install are not unusual - but a bit worrying to the uninitiated. Glad it's sorted.
I have seen these pauses before, but this one seemed very long in duration - probably heightened by my sense of anxiety !

Thanks again.
The setrma diagnostic only works with recent versions of the CFW but should have worked for you. The diagnostic you probably wanted was remove_mod_yes_i_am_sure which does a full reset - it's the equivalent of using the Remove all custom firmware packages and settings button in the web interface diagnostics page.