Looking for help installing custom firmware


New Member

I've spent the last 4 or 5 hours trying to installing the latest custom firmware but I can't seem to complete the installation. I have a Humax HDR Fox T2 with the latest 1.03.12 firmware and I've installed the current custom firmware for that version. My Humax displays "Cust FW 3.03" when it boots. I've confirmed this by entering the IP into a browser and the confirmation page is displayed. The problem is I cannot get the web interface to install. It stops at various points and then I have to reboot the Humax to clear a file locking problem. I've run the general diags from Telnet and all passed and I've also run the full disk check from Telnet and that also passed. I've also tried reseting back to the factory firmware and reinstalling but that didn't help (I've now noticed that performing a reset from Telnet no longer clears the custom firmware even though I am following the instructions on how to reset).

What usually happens is the page in the browser just hangs while it is trying to load a package but the last time I ran it, it came back with the following error:

Connection to online repository at [link-removed-so-I-can-post-it]...hpkg.tv successful!

Updating package list...

Downloading [link-removed-so-I-can-post-it].../hdrfoxt2/base/Packages.gz.
Inflating [link-removed-so-I-can-post-it].../hdrfoxt2/base/Packages.gz.
Updated list of available packages in /mod/var/opkg/base.
Installing webif (1.2.4-2) to root...
Downloading [link-removed-so-I-can-post-it].../hdrfoxt2/base/webif_1.2.4-2_mipsel.opk.
Collected errors:
* opkg_download: Failed to download [link-removed-so-I-can-post-it].../hdrfoxt2/base/webif_1.2.4-2_mipsel.opk, wget returned 1.
* opkg_install_pkg: Failed to download webif. Perhaps you need to run 'opkg update'?
* opkg_install_cmd: Cannot install package webif.

Error installing packages. Please try again.

I've no idea what "Perhaps you need to run 'opkg update'?" means and I couldn't find any reference to it in relation to this issue.

Note that "mipsel.opk" is as far as I've got. It's never got further than that.

Any suggestions?


Black Hole

May contain traces of nut
Are you running the full RMA option from the Telnet menu to clear the CF, and then re-flashing standard firmware? You could also try running the System Flush Update file (runs from a UPD).

Normally the installation runs sweet (flash the latest CF, run the supplementary installation from the browser panel).
Last edited:


Well-Known Member
* opkg_download: Failed to download [link-removed-so-I-can-post-it].../hdrfoxt2/base/webif_1.2.4-2_mipsel.opk, wget returned 1.

Any suggestions?
The server seems to do odd things at times - it just stopped part way through downloading webif this week on one of my boxes.
Telnet to the box and run the install manually i.e. "opkg install webif"


For what it's worth, these are my notes from when I had a similar problem (it might not be the best method but it worked for me):

Problem when installing WebIf on 2nd Humax HDR:

The installation hung on:
Downloading http://hpkg.tv/hdrfoxt2/base/tmenu_1.12_mipsel.opk.

Action taken:
Re installed CF 1.03.12 mod 3.03
Started Humax
Put into Standby with the remote control
Switched off Humax using the rear switch
Switched on Humax using the rear switch
Started the Humax using the remote control
Went into Telnet (via putty)
humax# opkg install webif --force-reinstall

everything worked OK

Connecting to Humax from browser still showed the WebIf installation screen

Switched Humax off and on

Web Browser now working OK


New Member

Thanks for the help everyone. The thing that helped most was from johnb. It took a couple of attempts but I finally managed to install the web interface using "humax# opkg install webif --force-reinstall"

For those monitoring these forums and wanting to improve the install procedure, I think it would be extremely useful to add the following lines (maybe to [fullurl]/wiki/Install_Full_Web_Interface)...

If you encounter problems installing via the web interface, try a manual install as follows:

1. Run a telnet application such as Microsoft's Telnet application or Simon Tatham's putty application
2. Enter "o <ip address of your humax>"
3. Enter you 4 digit pin that you would normally use for your humax box (default: 0000)
4. Select "cli"
5. Enter "opkg install webif --force-reinstall" at the "humax#" prompt
6. If the install hangs at any point for more than a few minutes, type Ctrl+C and repeat step 5
7. When the install script has completed, turn off your humax via the front button, wait for all activity to stop and then power on again
8. Enter "<ip address of your humax>" into your browser and you should see the web interface

Hopefully the above is written in a way that most people will understand even if it is not technically correct. It worked for me when numerous resets, reloads and re-attempts to install via a browser failed.

Cheers and thanks again for your help,


For what it's worth, I had the same problem today, hanging at the same place initially, and then hanging only a few lines into the installation on several further attempts.

Problem solved first time without using telnet as follows (could be a coincidence!):

Disconnect from LAN
Reinstall CF, and "Restart Humax with new firmware", ends up eventually in Standby.
Out of Standby (front button).
Into Standby.
Power down (rear switch).
Power up.
Out of Standby.
Connect LAN.
Browser installation worked.