1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

losing HDMI output since installing Modified Software

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by jerrytaff, Oct 31, 2011.

  1. jerrytaff

    jerrytaff New Member

    Help!!

    Has anyone else come across this problem? I have had my unit for over a year, and never had any problems with it.I certainly have never had any problems with the HDMI sync to my Samsung LE37R8 TV.

    Today I installed the modified firmware, (1.02.20_mod_1.12) and installed the web interface which I then used to install: mediatomb, samba, virtual disk,auto-unprotect and remote services. Everything seemed fine, but using the HDR tonight, it kept on losing HDMI comms with the TV. At least I think that was the problem - sound continued to be output via optical to my AV amp, but the TV picture disappeared, and the TV displayed the message "no input".

    This happened half a dozen times or so watching Downton Abbey first on chase play and then live (ITV HD) and then later watching a film on BBC1 HD. On each occasion, I could not recover the TV signal by changing channel, or cycling input on the TV, but had to turn the HDR off at the back and then switch back on before it would work. The machine itself was not frozen; I could change channels on the remote and the sound would change.

    If this behaviour persists the machine is as good as unusable. Has anyone got any ideas about what could have caused this behaviour?
     
  2. Black Hole

    Black Hole Felonius Gru

    The obvious thing is to restore to official firmware (reflash 1.02.20) and see what happens. I very much doubt the custom code is the cause of the problem though, just a coincidence.
     
  3. ChrisDaniels

    ChrisDaniels Well-Known Member

    The custom firmware does not touch anything related to HDMI. Check your cables have not come loose.
     
  4. jerrytaff

    jerrytaff New Member

    Thanks Black Hole. Certainly, I only mod-ed the box because I was secure in the knowledge that I could revert to the official firmware. However, see that as a last resort. In the meantime, I was trying to find out if anyone else had a similar problem. I could understand it if the box was freezing or stuttering due to insufficient memory or overloaded processor, but this is an unexepected a byproduct of the mod as far as I am concerned. Tonight I am going to avoid going anywhere near the PC while it is playing. If it still plays up, I shall start uninstalling, starting with mediatomb and samba.
     
  5. jerrytaff

    jerrytaff New Member

    Thanks Chris,
    and neither would I have expected it to, but I'm not sure that its comforting to know. The first thing I did was to check the cables.

    So, should I presume that I am the only person to have had this problem. Perhaps its a coincidence. It sounds to me more like a hardware issue. I wonder if perhaps I worked the machine harder than usual yesterday,causing it to run hotter than normal. I shall keep you posted.
     
  6. ChrisDaniels

    ChrisDaniels Well-Known Member

    It could of course be the tv at fault rather than the box.

    Suggestions for you: Try a different HDMI port, check for updated firmware for the TV, try unplugging the cable at both ends , give it a blow and re-seat it, make sure there are no powerful electrical items near the cable that could cause interference (as HDMI is a digital cable, its an "all or nothing" setup unlike the old RF cables which would result in a snowy picture), finally, try a different cable.

    The HDMI connection is setup & negotiated by the humaxtv process, so there is nothing that we can alter in this regard.
     
  7. jerrytaff

    jerrytaff New Member

    Thanks Chris, but let me reiterate that :
    I have had the machine for over a year. I have never had this or any other problem until I updated the firmware and installed the additional software packages. The first HDMI problem occured within about 30 minutes of installing the software. I have not disturbed the cabling which is the same as has always worked previously, neither has the firmware on my TV changed. One heck of a coincidence - I think you'll have to agree , even if there is no logical reason for the software to be the cause of the problem.

    It does not appear to be the normal HDMI negotiation issue. It negotiates successfully on switch-on, only to lose the picture at random in the middle of playing something back. It occurred once today (12 minutes into watching a recording of today's Eastenders) in about 4 hours of use. Once the picture is lost, changing channels on the HDR, or cycling inputs on the TV does not restore it - only a switch-off at the back and reboot cures it. Has anyone ever reported a similar problem? (Black Hole, you seem to be the fount of all knowledge on such issues - could you comment?)

    My background is in defence electronics and I have plenty of painful experience of finding non-obvious causes to seemingly inexplicable and unrepeatable/unrelated failures.
    So, in my opinion, there are a number of possible, but seemingly unlikely causes including: a) software timing on HDMI being disrupted by transient processor load, b) Nascent hardware failure, possibly accelerated by need to power down as part of the upgrade process, c) machine working harder, therefore running hotter, and not liking it? d) Dodgy RAM only exercised now that additional software is running, e) Corrupted firmware.

    a) seems unlikely if no-one else has had similar issues.
    c) seems unlikely given that it was probably running hotter all summer

    I wouldn't care to comment on the others

    Does anyone know how the machine uses RAM? is it possible that I am now using storage locations that would not have been used previously? Incidentally, I just telnetted to the machine and ran "top". It reports that /usr/bin/humaxtv is using 305% of the RAM and 12% CPU, and that there are 10 separate instances of the mediatomb process running. Does this sound right? Does the 305% include virtual memory, perhaps part of the record buffer, or does it simply not understand how much memory it has?
     
  8. jerrytaff

    jerrytaff New Member

    Oh , and it lost the picture again while I was composing the last response.
     
  9. ChrisDaniels

    ChrisDaniels Well-Known Member

    10 instances of mediatomb does not sound right.
    One of the other guys with more experience with this should be able to confirm this for you.
     
  10. Sam Widges

    Sam Widges Active Member

    There are indeed 10 instances of mediatomb running on my system and this has always been the case since I first installed webif/mediatomb.

    Top on my box also reports the humaxtv process using up 298% of the memory and 8-12% of the CPU.
     
  11. Black Hole

    Black Hole Felonius Gru

    My career was also defence electronics, and I agree with your analysis. I'm only a "fount of all knowledge" because I read everything that gets posted with the analytical eye that comes with the job.

    No, as far as I can remember nobody else has reported similar.

    Faults are a bugger to track down if they are not reproducible (like my portal problem). You have the mods installed and you started to get mysterious HDMI problems coincident with that. From what you say, it sounds like the fault is almost guaranteed to manifest when you play back, so I suggest you pick a particular recording as your test and play it back a few times, noting how many times you needed a restart to complete the playbacks. Then restore factory firmware and repeat the test. Evidence sir, evidence.
     
  12. jerrytaff

    jerrytaff New Member

    10 processes identified as mediatomb. I've been looking around the filesystem. Only one startup entry in /mod/etc/modservices and nothing in /mod/mediatomb would seem to run multiple instances. Perhaps it multithreads and runs as multiple processes?
     
  13. jerrytaff

    jerrytaff New Member

    Not guaranteed Black Hole. last night I also watched an old episode of New tricks and a recording of frozen planet without any problems. Coincidentally, there was no significant activity on the PC or computer network at the time. I think that I shall reduce the functionality - disable mediatomb and samba, see how it goes, and revert to stock firmware if I'm still seeing the problem.
     
  14. Black Hole

    Black Hole Felonius Gru

    It is true I am not running mediatomb and samba, but I'm sure others must be.
     
  15. jerrytaff

    jerrytaff New Member

    Last night the machine was in heavy use. I had disabled samba and mediatomb. At one point I was copying one file to my network storage (via the webif), while streaming HighDef content to vlc on a PC, while my better half was watching a 3rd recorded HighDef recording on the TV, and running a telnet session to monitor activity. No problems whatsoever all evening.

    Job done or so I thought. I powered the PC down, and sat down to watch a recording on the TV, and after 15 minutes or so I got the dreaded black TV screen. Once I'd powered down and back up again it was OK until I went to bed a couple of hours later.

    A couple of times the problem has occured while watching live, not recorded, material. So, the problem seems to be random, independent of load on the box or the network, or the particular task being undertaken at the time.

    It would be a shame to have to revert to the standard firmware. The new functionality is so much better. Thanks to everyone who has contributed. However......

    Before taking that step, I might have a look to see whether switching HDMI ports in the TV makes a difference. I doubt it, and it will be a real pain in the backside, because each input has carefully optimised custom display settings to match the characteristics of the input stream. The HD content allows me to set a sharper higher contrast, higher dynamic range image than standard freeview, and my DVD uses different settings again.
     
  16. Black Hole

    Black Hole Felonius Gru

    You won't be "reverting", just proving what we all believe - that the MSP is not responsible. Once you get blackouts with standard firmware you will be able to move forward.