Maintenace boot goes to standby


On boot, my HDR FOX T2 displays the following. That is on every boot, I end up back in standby.
Sometimes the final display is the clock rather than "WAIT - 51". Needless to say, I cannot telnet into the box.

Start System
Custom FW 2.21
WAIT - 59
WAIT - 58
WAIT - 57
WAIT - 56
<briefly blank>
WAIT - 55
WAIT - 54
WAIT - 53
clock <dim>
WAIT - 52 <dim>
clock <dim>
WAIT - 51 <dim>
<machine is in standby>

My machine is about a year old and had been running 1.02.32/2.16. I noticed 197 + 198 errors on the web interface disk diagnostics, so tried a fix-disk. Didn't solve the problem so I updated to 2.21 and tried again. Still didn't cure the 197 + 198 errors. From memory, LBA2016 was first error, and fix-disk was complaining that one of the partitions (sda2?) was an unrecognised partition type. So, tried searching the forum and following some threads (sorry, cannot remember which) ending up with a point where I powered down the box via the remote expecting it to re-boot into maintenance mode. On boot, the above symptoms appeared.

Things have tried to solve the problem :
(1) Install official firmware. Box boots fine and works fine (including recordings + playback) apart from the humax disk check says "error 8".
(2) Reformated hard disk (via Humax's menu). Yes, I lost all my recordings (divorce pending!). No, it didn't solve the problem.
(3) Installing various different official firmware version to try force a "full re-write" of the internal flash.
(4) Re-install custom firmware. Each time, symptoms re-appear.

Is my box destined to never run the custom firmware again?:eek:
Is the file causing the problem(?) on the hard disk? (I could remove disk and re-format in a PC?).


Is my box destined to never run the custom firmware again?:eek:
Is the file causing the problem(?) on the hard disk? (I could remove disk and re-format in a PC?).

I'm sure you'll get to the bottom of this one.
It will be a corrupt file used by the custom firmware which is not being re-created or deleted, I'd say (no expert). So your right you must be able to remove this file/folder and then it would install fine. Best wait of someone who can identify all the folders and files created by the customer firmware before trying to remove them. Best of luck.
I have no idea why maintenance mode is failing halfway through but you need a special custom firmware build to recover from this.
I'll send you a link.
That's got me going again :). Thanks af123, very much appreciated.
(Still got disk problems which fix-disk doesn't seem to want to fix, but I'll create another thread r.e. that).
So, once you'd put the special firmware on and got it back and running, did you load a standard CFW and is maintenance mode now working?
Yes thanks af123, maintenance mode is now working again.
(I've re-installed 1.02.32 / 2.21, since 1.03.11 seemed to slow down EPG navigation?).
Versions 1.03.06 and 1.03.11 have both been reported to slow down EPG navigation, so it's not just your unit. You can reduce (but not remove), the slow down by deleting any unwanted schedule entries with -- ~ -- ~ -- against them, bearing in mind that you might want to keep some of them, if you decide to go back to 1.03.xx
...also available at the foot of the WebIF "Scheduled Events" page as a button "Cleanup old recordings".
Earlier today I plugged in a Vestel. (A Vestel is a Turkish make that manufactures boxes that owners of brands can slap on their own choice of brand. There probably is a Vestel freeview box near you. (Vestels have been branded Bush, Digihome, Hitachi, Sharp, Tecnika, Techwood, Wharfedale and many others))

Scrolling right on the epg reminded me of the 1.03.xx epg response.
If Vestel can get away with selling boxes with slow to navigate epgs then why not Humax?

Obviously there is a difference . The Vestel image is cheap and cheerful and IT WORKS (FOR MOST). Humax used to market from a different angle. With the introduction of the HDR-2000T I’m not sure what Humax is aiming for its image in the UK. But perhaps the slow down of the epg navigation gives a clue?
Sorry to resurrect this thread but I can't put it any better than the OP. I started getting the dreaded *deleting the other night so logged in via telnet and started maintenance mode. Now the box is stuck exactly like the original post. Earlier I noticed the webif was acting strange too, with all of the packages showing as not loading and a warning about the webif update not going away. Any help would be most appreciated.
Cromel's box is now back up and running - the filesystem had gone read-only so just needed a dose of fix-disk. The additional problem was the failure to enter maintenance mode. I still don't understand why this happens but a few people have experienced it recently. In all cases maintenance mode worked fine once the box had been through another full boot.

The next version of the CFW will automatically recover from maintenance mode failures such as these, eliminating the need for special firmware builds. After a couple of failed attempts to enter maintenance mode, the next boot will be a full one again. Re-selecting maintenance mode at this point should get things back on track.