1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Media > Storage > Network causes reboot

Discussion in 'HDR-FOX T2 Freeview Recorder' started by rich2013, Dec 8, 2012.

  1. rich2013

    rich2013 New Member

    I've got a brand new T2 just plugged in, connected to my network, and all channels found etc.

    When I try to connect to my DLNA server (Serviio accessible by several other things around the house) by going to Media > Storage > Network - I get the "Connecting..." message and then the screen goes briefly green and then everything reboots everytime I try it.

    I gather I'm supposed to see the media server list at that point ?

    Tried complete restart and ensured that Iplayer etc are working. My Panasonic tv and Sony BDP can both pickup Serviio and stream things so I'm pretty sure that's not the problem.

    I'd call Humax support but they're not open today - any thoughts on why this would happen or if anyone has seen it before ?

    I'm on the standard FHTCP 1.02.29 (05/07/12) firmware

    I'm also connected via cable to my router.

    Thanks
     
  2. Black Hole

    Black Hole Felinos Guru

    Certain versions of Twonky are known to cause problems. I would hesitate to blame the Humax at this point (other than to say there may be an unresolved bug which is common to all).
     
  3. rich2013

    rich2013 New Member

    well after changing the V-FORMAT settings around it seems to be working now. Strange thing is that it now works on every V-FORMAT setting so I'm not sure why it did it in the first place. Odd!
     
  4. rich2013

    rich2013 New Member

    seems I was a bit soon to put it down to V-FORMAT as it's started doing it again, and no amount of messing around with the format will make it work. Have also now tried two other DLNA servers and the same thing happens - even before you've selected the server itself, it reboots. Will call Humax on Monday but I'm suspecting I've got a duff one.
     
  5. Brian

    Brian Administrator Staff Member

    Have you tried turning "Content Share" off? I seem to recall reading about a corrupt DLNA index causing a rebooting problem.
     
  6. rich2013

    rich2013 New Member

    I didn't have it turned on yet, but I tried turning it on and off and then trying again (while both on and off) but still the same. Another point is that if I disable all DLNA servers, then it still does the same even though there's nothing to find.

    I also tried using SCART instead of HDMI last night after reading some apparent green-screen handshake issues on the net re HDMI, but it does the same thing on SCART too.
     
  7. Black Hole

    Black Hole Felinos Guru

    Does it still reboot with the network cable out?
     
  8. rich2013

    rich2013 New Member

    No I tried that yesterday, but it doesn't let you select Network - it only reboots when you select Network. Taking the cable out doesn't give you the option unfortunately.
     
  9. Black Hole

    Black Hole Felinos Guru

    Hmm. That's true, silly of me. You said the TV Portal works, but I still think there is something funny about your network that trips the Humax up when it sends out the DLNA resource request. Does your router have server capability?
     
  10. rich2013

    rich2013 New Member

    It's a DD-WRT flashed router. The HP server that my DLNA is running on is serving fine for any other device while connected to the router (everything is ethernet cabled, by the way) so I'm not sure what other capabilities it would need ?
     
  11. Black Hole

    Black Hole Felinos Guru

    I'm not suggesting your network lacks anything in particular, only that there might be an incompatibility problem between the Humax and something else. As I mentioned earlier, a particular version of Twonky caused an undesirable interaction which was resolved by installing an earlier version. As you say you get the same with the servers turned off, I presume that means when the only other device on the network is your router.

    I am trying to work out where the problem might be. It seems very unlikely there is a hardware problem in the Humax - in order to reach the TV Portal all the networking stuff must be intact, and I find it hard to believe there is some part of the hardware which DLNA needs but is not exercised by getting an iPlayer programme up and running. Consequently I am left considering a firmware fault - either present in the code as a bug or present only in yours as a corruption.

    As a bug, we have many examples of the DLNA system working fine, so that would point to an interaction with your setup in particular. It would also mean that you might go to all the trouble of getting a replacement only to find it is exactly the same.

    af123 will be able to comment I'm sure, but I don't know how much self-protection there is against firmware corruption. When I used to design hardware containing firmware, I put a checksum into the power-on self test. If there is no such self-test, or write verification during programming, the corruption could be a bad write during programming or a faulty storage location. If it is a faulty storage location then there is some mileage in seeking a replacement (but only if).

    I suggest installing 1.02.20, even if only temporarily (see the firmware downloads page on the Wiki). The DLNA client in .20 is only able to stream as far as 4GB in any file, so we know the is some difference in that area of code. If .20 resolves the rebooting then try putting .29 back - it may have flushed the corruption.
     
  12. rich2013

    rich2013 New Member

    ok I see what you mean, and thanks for helping me this far! I will try what you suggest and see what happens.

    thanks again
     
  13. rich2013

    rich2013 New Member

    Just an additional note that I tried as you suggested. Went back to 1.02.20, connected to network. Tried Storage > Network option but still reboots the same way when selecting it. Upgraded to .29 again, retry but the same thing happens unfortunately.

    I've also tried a factory default reset and reconfigure, but the same again.

    I've now emailed Humax support with everything I've tried and all the details from above, so hopefully someone will have a suggestion about what to do next.

    Thanks
     
  14. Black Hole

    Black Hole Felinos Guru

    It's a toughie.
     
  15. rich2013

    rich2013 New Member

    No response from Humax unfortunately, so I returned unit and got replacement. Plugged in and amazingly everything worked - streamed videos from server, photo's, music etc. Thought I'd better test it completely, switched off (via remote) then switched back on and once again it started rebooting as soon as I go to Network option. Tried unplugging the unit, turning off the DLNA server, turning off router and then all back on again, but still the same.

    Very frustrating.

    Any other thoughts before I send it back ? I would prefer to work out what's going wrong than go Samsung/Panasonic route if possible.

    Thanks
     
  16. Black Hole

    Black Hole Felinos Guru

    So it was fine until you turned off and on again?

    Can you replicate that by going to standby, waiting for the drive to click off, then powering off at the back for a while?
     
  17. rich2013

    rich2013 New Member

    ok now I'm getting closer. I tried as you suggested but it did the same thing.

    Then I googled for other Humax network issues and noticed a few posts where people were saying that Humax devices are sometimes picky about other devices on the network.

    On my network, other than the Humax, I have a HP server (WHS2011), a desktop PC (Windows7), Panasonic TV, Toshiba BDP, Sony BDP, Sky box, Iphone. I disabled everything apart from the server and everything worked on the Humax perfectly. I've been round everything one-by-one by testing while on, and I can replicate the issue everytime my desktop PC is turned on. Putting it into sleep lets the streaming work again.

    So I now know the source, but I've got nothing in particular that might cause an issue. No DLNA server, windows sharing is off. I will have to dig deeper but at least now I know the source!
     
  18. Black Hole

    Black Hole Felinos Guru

    Win7 shows its presence on the network regardless of having no DLNA server and no file sharing. I also have a Win7 notebook on the network, but I probably haven't had it turned on at the same time as running a DLNA seek.
     
  19. rich2013

    rich2013 New Member

    Just to close this off - it was Cyberlink PowerDVD 11 Service on the desktop PC - disabling this let's my Humax work perfectly! I don't use that service at all so it's no problem. Very pleased!

    Thanks
     
  20. Black Hole

    Black Hole Felinos Guru

    That's great. I'll add it to the list with Twonky.