1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mounting a network share on the HDR Fox T2

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by ntm1275, Jan 1, 2012.

  1. ntm1275

    ntm1275 Member

    As the built in T2 DNLA client does not seem to play many formats of video, even though copying the same video files to the My Video folder and then playing them works OK, I want to be able to mount a shared folder on my Synology DS1010+ NAS in to the T2's My Video folder, so that I don't have to copy the video files from the Synology to the T2 (the 100Mbit connections is just too slow - shame the T2 doesn't have a Gigabit connection)

    I have already created the Synology folder in the My Video folder

    Does anyone know the command line so that I can do this?

    I have tried the following, but both say "File system autodetection requires /proc be mounted"
    I've never used /proc, so I don't know what to do with it

    mount -t smbfs -o username=synologyusername,password=synologypassword //192.168.0.2/video /media/My Video/Synology

    mount -t cifs -o username=synologyusername,password=synologypassword //192.168.0.2/video /media/My Video/Synology

    The Synology uses Linux as it's OS

    any help is much appreciated
     
  2. xyz321

    xyz321 Well-Known Member

    That's odd, /proc should be mounted by default. Try posting the output from 'mount -t proc'.

    This should work providing you have the cifs package installed, however you will need quotes around the mount point because of the space in 'My Video'.
    Code:
    mount -t cifs -o username=synologyusername,password=synologypassword //192.168.0.2/video "/media/My Video/Synology"
    
     
  3. ntm1275

    ntm1275 Member

    Thanks @xyz321 for your reply

    I ran the 'mount -t proc', and it came back with 'proc on /proc type proc (rw)'

    I then re-entered the command with the quotes because of the spaces
    mount -t cifs -o username=synologyusername,password=synologypassword //192.168.0.2/video "/media/My Video/Synology"

    It has now mounted and is working exactly how I wanted it to

    Many thanks for your help
     
  4. Johnboy123

    Johnboy123 New Member

    Interesting thread! By doing this, can you copy local content over to the Synology NAS using the T2's move/copy option on the remote? Also, are other T2 functions maintained such as being able to playback from where you left off and mark as read/unread? Thanks.
     
  5. xyz321

    xyz321 Well-Known Member

    Yes, you get the same featues as if the file(s) were stored on the local disk. This includes FF/REW and slow play for the TS files created by the HDR. However, to be able to do this you need to do one of the following:
    1. Keep a USB drive connected and mount the NAS directly under /media (e.g. /media/Synology) or,
    2. Mount the NAS twice under /media/Synology and /media/My Video/Synology
    The first of these options is preferable since the NAS just looks like another USB disk to the application but it does tie up a USB port (and a drive).

    The second option will work provided you remember to use the OPT+ option to copy direct to the Synology (this will decrypt during the copy). You can then playback using the mount under "/media/My Video/Synology". If you attempt to copy between directories under "My Video" it will actually try to move and will fail if moving to/from the Synology. This is because the application thinks the files are local and on the same disk.
     
  6. rpb424

    rpb424 Member

    I had a network share mounted on my HDR until very recently, but have just removed it due to problems. Although everything played perfectly (I used AV2HDR to generate the sidecar files) the box then started to produce some failed recordings of zero file size.

    I'd noticed that the disk capacity pie chart in the recordings list was showing odd settings. I have a 1TB HDR and a 500GB NAS mounted, which should therefore have given a maximum capacity of no more than 1.5TB, however the box very often got confused and showed over 3TB free. The other day it showed as completely full (0MB free) and a couple of new recordings appeared in the list but failed to play claiming that the disk was full, despite there actually being 820MB free in the box itself. Having disabled the NAS mount everything is showing correctly again.

    I may revisit this again at some point, but having the NAS mounted is not crucial to me, and was more f a proof of concept. I can always get to it via DLNA anyway, despite the lack of extra FF/Rew functionality etc.
     
  7. xyz321

    xyz321 Well-Known Member

    Did you have it mounted as /media/<dir> or as "/media/My Video/<dir>" (or both)?

    I always assumed that the disk space indication is unreliable. At the moment it is showing 23GB free with or without CIFS mounts. The actual free space is 36GB.
     
  8. Black Hole

    Black Hole Felonius Gru

    I think you may have found an Achilles Heel for mounting remote drives. If the native Humax firmware gets confused about available drive space and then aborts recordings unnecessarily it's not going to be very popular. Fortunately I want to go the other way: mount the HDR- drive to be accessible on the HD-.
     
  9. rpb424

    rpb424 Member

    I had the entire shared NAS folder ("media") mounted as /mod/nas and then used mount --bind to mount a specific subfolder of this (called 'Humax') under 'My Video' as a folder called NAS. This all ran from a script called S99mountnas in /mod/etc/init.d at startup.

    mkdir /mod/nas
    mkdir "/media/My Video/NAS"
    mount -t cifs //192.168.1.99/media /mod/nas -o username=Humax,password=humax
    mount --bind /mod/nas/Humax "/media/My Video/NAS"
     
  10. xyz321

    xyz321 Well-Known Member

    I don't think we should write off file sharing on the basis of one unconfirmed error report.
     
  11. xyz321

    xyz321 Well-Known Member

    If you can reliably cause it to fail by mounting it in this way then perhaps you could try it without the bind mount. Attaching a USB drive (HDD or flash) shoukd still give full access to the network share (as a "virtual" USB drive).
     
  12. Black Hole

    Black Hole Felonius Gru

    Merely an observation.
     
  13. ratx

    ratx New Member

    I've had a cifs share from a linux server mounted on mine exactly as described above for months and months without any issues. I don't really pay attention to the reported utilisation in the Humax UI however so don't know how bonkers that goes.
     
  14. ntm1275

    ntm1275 Member

    As an update to my original/previous posts:-

    I have mounted my NAS using the command
    mount -t cifs -o username=synologyusername,password=synologypassword //192.168.0.2/video "/media/My Video/Synology"

    This appeared to work OK and I could access my video files from my NAS, but after 10 minutes the T2 then locks up, with no response from the remote control or buttons on the front of the T2
    I can however still access through the Webif and directly through the IP address or FTP

    I thought it was to do with the fact that my NAS is set to hibernate after 10 minutes of inactivity, but if I keep the NAS 'alive', the T2 still locks up

    I'm now stumped on what may be causing it
     
  15. batnas

    batnas New Member

    Wouldn't it be possible to use (sym)links??

    \\Batnas
     
  16. xyz321

    xyz321 Well-Known Member

    New symbolic links are ignored by the Humax application. Hard links can not be created because the source and destination are on different filesystems.