Multiple updates of same version

Is this normal:

30/03/2016 03:32:42 - Automatically upgraded package lighttpd from to 1.4.39-1
30/03/2016 03:32:47 - Automatically upgraded package lighttpd from to 1.4.39-1
31/03/2016 01:47:27 - Automatically upgraded package lighttpd from to 1.4.39-1
31/03/2016 01:47:30 - Automatically upgraded package lighttpd from to 1.4.39-1
 
OP
J

JoeBloggs911

Member
Not normal.

I'm guessing but try running fixpkg from the Diagnostics menu

I did. It finished almost instantly with no informative message. Just

>>> Beginning diagnostic fixpkg
Running: fixpkg
>>> Ending diagnostic fixpkg


in well under a second.


It's still happening on both my T2s:

01/04/2016 03:22:25 - Automatically upgraded package lighttpd from to 1.4.39-1
01/04/2016 03:22:30 - Automatically upgraded package lighttpd from to 1.4.39-1


Is it significant that the times of the supposed upgrades are identical on both machines.?
 

prpr

Well-Known Member
Try these from a Webshell or other Telnet-like command line shell of your choice:
Code:
humax# opkg update
humax# opkg info lighttpd
humax# opkg list-installed lighttpd
humax# opkg list-upgradable
humax# opkg upgrade lighttpd
and report what the output is.
 
OP
J

JoeBloggs911

Member
Try these from a Webshell or other Telnet-like command line shell of your choice:
Code:
humax# opkg update
humax# opkg info lighttpd
humax# opkg list-installed lighttpd
humax# opkg list-upgradable
humax# opkg upgrade lighttpd
and report what the output is.

Code:
humax1# opkg update                                                                                                                             
Downloading http://hpkg.tv/hdrfoxt2/base/Packages.gz.                                                                                           
Inflating http://hpkg.tv/hdrfoxt2/base/Packages.gz.                                                                                             
Updated list of available packages in /mod/var/opkg/base.                                                                                       
humax1# opkg info lighttpd                                                                                                                       
Package: lighttpd                                                                                                                               
Version: 1.4.39-1                                                                                                                               
Depends: swapper, service-control (>= 2.0), libpcre (>= 8.37-1)                                                                                 
Provides:                                                                                                                                       
Status: install ok installed                                                                                                                     
Section: web                                                                                                                                     
Architecture: mipsel                                                                                                                             
Maintainer: af123@hummypkg.org.uk                                                                                                               
MD5Sum: 9e90df9992ea8e7642c1a0aadfda302f                                                                                                         
Size: 245516                                                                                                                                     
Filename: lighttpd_1.4.39-1_mipsel.opk                                                                                                           
Conffiles:                                                                                                                                       
/mod/etc/lighttpd/extra.conf 41252aa0a4d43cd9131da349bb46d1b9                                                                                   
Description: Lightweight web server                                                                                                             
Installed-Time: 1454997173                                                                                                                       
                                                                                                                                                 
Package: lighttpd                                                                                                                               
Version: 1.4.37                                                                                                                                 
Depends: swapper, service-control (>= 2.0), libpcre                                                                                             
Provides:                                                                                                                                       
Status: install ok installed                                                                                                                     
Architecture: mipsel                                                                                                                             
Conffiles:                                                                                                                                       
/mod/etc/lighttpd/extra.conf 7bfa62271212309f1568ac2a03a2532e                                                                                   
Installed-Time: 1445562786                                                                                                                       
                                                                                                                                                 
humax1# opkg list-installed lighttpd                                                                                                             
lighttpd - 1.4.37                                                                                                                               
lighttpd - 1.4.39-1                                                                                                                             
humax1# opkg list-upgradable                                                                                                                     
lighttpd - 1.4.37 - 1.4.39-1                                                                                                                     
humax1# opkg upgrade lighttpd                                                                                                                   
humax1#
 

Ezra Pound

Well-Known Member
You appear to have two versions of lighttpd installed, you have both the latest 1.4.39-1 AND 1.4.37, I think your problem will go away if you can 'remove' (uninstall) the earlier version, however I would wait for confirmation of this before proceeding
 

af123

Administrator
Staff member
It looks like fixpkg has been a little over zealous and needs an update. Leave it with me!
 
OP
J

JoeBloggs911

Member
It looks like fixpkg has been a little over zealous and needs an update. Leave it with me!

The repeats stopped for a few days but have just started again:

10/04/2016 04:53:02 - Automatically upgraded package epg from 1.2.1-1 to 1.2.1-1
10/04/2016 04:53:02 - Automatically upgraded package jim from 0.76-1 to 0.76-1


Ditto on second machine:


10/04/2016 03:35:41 - Automatically upgraded package epg from 1.2.1-1 to 1.2.1-1
10/04/2016 03:35:41 - Automatically upgraded package jim from 0.76-1 to 0.76-1
 
OP
J

JoeBloggs911

Member
See post #6, substituting the appropriate package names for lighttpd.

Here's the output for epg. That for jim was similar:

Code:
humax1# opkg update                                                                                                                             
Downloading http://hpkg.tv/hdrfoxt2/base/Packages.gz.                                                                                           
Inflating http://hpkg.tv/hdrfoxt2/base/Packages.gz.                                                                                             
Updated list of available packages in /mod/var/opkg/base.                                                                                       
humax1# opkg info epg                                                                                                                           
Package: epg                                                                                                                                     
Version: 1.2.1-1                                                                                                                                 
Provides:                                                                                                                                       
Status: install ok installed                                                                                                                     
Section: misc                                                                                                                                   
Architecture: mipsel                                                                                                                             
Maintainer: af123@hummypkg.org.uk                                                                                                               
MD5Sum: b549f62f0af8dc0078225568c3761018                                                                                                         
Size: 36636                                                                                                                                     
Filename: epg_1.2.1-1_mipsel.opk                                                                                                                 
Description: Command line EPG utility.                                                                                                           
Installed-Time: 1460263973                                                                                                                       
                                                                                                                                                 
humax1# opkg list-installed epg                                                                                                                 
epg - 1.2.1-1                                                                                                                                   
humax1# opkg list-upgradable                                                                                                                     
webif - 1.2.8-15 - 1.2.8-16                                                                                                                     
humax1# opkg upgrade epg                                                                                                                         
humax1#
 

MymsMan

Ad detector
There was a bug in the locking changes in webif - 1.2.8-15 that is fixed in webif - 1.2.8-16
(I got the same pair of message after the update to -15)

I don't know if that caused the problem but it is worth waiting until after the next webif update to -16 is applied to see if it is an isolated incident
 
Last edited:
OP
J

JoeBloggs911

Member
There was a bug in the locking changes in webif - 1.2.8-15 that is fixed in webif - 1.2.8-16
(I got the same pair of message after the update to -15)

I don't know if that caused the problem but it is worth waiting until after the next webif update to -16 is applied to see if it is an isolated incident

It seems that fixed it.
 

af123

Administrator
Staff member
The repeats stopped for a few days but have just started again:
10/04/2016 04:53:02 - Automatically upgraded package epg from 1.2.1-1 to 1.2.1-1
10/04/2016 04:53:02 - Automatically upgraded package jim from 0.76-1 to 0.76-1

That's because webif was also upgraded in that batch and that listed the new version of epg and jim as dependencies so by the time it got around to upgrading those packages, they were already up-to-date. This is not the same problem as the repeated lighttpd updates.

I have a fix to auto-update for this which I'm currently testing and it will be available soon.
 
Last edited:
Top