1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help to Cripple DLNA (Yes you read it right!)

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Placemat, Jul 10, 2012.

  1. Placemat

    Placemat New Member

    Hi Chaps,

    I have an issue with my newly fixed (8 weeks to replace the hard drive :( ) Humax HDR Fox T2. Before it left my care, my hummy was working perfectly with the custom firmware. I had content sharing on 24/7 plus unencrypt, rsync etc.

    When my Hummy was finally delivered last week, loaded with 1.02.27, I promptly upgrade it to .28 and wacked on the 28_mod. All seemed fine at first, however once I enabled Content Sharing the trouble began.Whenever I start the device from a complete standby state, the box boots up with picture and sound and within the space of 1-5 minutes, promptly freezes (audio still playing) and restarts. Once the restart is completed, it works perfectly.

    Through my own testing I have found the follow:
    • The problem only occurs when the network connection is active
    • Switching the Content Sharing option to ON when it is off also causes the device to crash instantly
    • The issue does not effect the device when it is in standby or recording in semi-active mode
    • I have removed other DLNA devices from the network
    There is obviously something broken with the Content Sharing system, that occurs when it first makes connection within my home network. There are at max, 4 files on the box, and I have reset the DLNA database several times but the problem persists.

    The thing is, I don't even want to use Content Sharing! I only ever use the network connection to enable unencrypt, stream videos from my NAS or file share with my pc (via samba.) Note that the latter two items work without Content Sharing.

    What exactly does unencrypt use from the Conent Sharing function? I disconnected my Humax last night from the network but left Content Sharing on, and all files were decrypted today. So obviously unencrypt (and possible other functions) do not require Content Sharing with an active network connection. Is there a way that I could modify the Content Sharing setting via telnet so that it would operate as if no network connection existed? Thus running but not actively attempting to share videos, operating in a crippled state!
     
  2. af123

    af123 Administrator Staff Member

    Ouch, that's nasty. Do you know what version you had on before and if you had the same set of packages?

    Decryption depends on the content sharing service because that is how it gets access to the decrypted version of the file.

    It's peculiar that you don't get crashes if you unplug the network cable. That seems to rule out the crashes being caused by anything on the disk being indexed. Have you tried turning content sharing off and on again while the network is disconnected? If that works then I think it rules out the disk contents completely.

    I don't know of a way to get content sharing running without participating on the network unfortunately, but I'll have a think about it. It would probably be possible to do something.
     
  3. Placemat

    Placemat New Member

    Hey af123, thanks for your response.

    I was running on the 1.02.20_mod_2.00_upgrade (I think) so if it's necessary I might try rolling back to that (is that possible?). The packages are the same, in fact I think I have installed less this time round.

    I just tried switching Content Sharing Off/On with no network connection and it seems stable.
     
  4. Black Hole

    Black Hole Felinos Guru

    I recommend restoring 1.02.20, the only significant advantage of 1.02.28 being the resolved 4GB streaming bug (and the disadvantage of retunes). It might cure your problem.

    You will need to prevent an OTA update to 1.2.28 thereafter (either using disable-ota or setting an 0420-0440 reminder).
     
  5. Placemat

    Placemat New Member

    OK thanks Black Hole, I rolled the firmware back to 1.02.20 vanilla and the problems persists! So I have no idea what is wrong with the box.

    Does anyone have any ideas on how I could modify the content sharing function?
     
  6. Black Hole

    Black Hole Felinos Guru

    I think you are down to formatting the drive.
     
  7. Placemat

    Placemat New Member

    I don't think that will help, I have only just received my Humax back from the shoddy repair centre with new a hard drive (or at least a replacement.)

    Is there any possibility that a hard change could have caused this problem?
     
  8. Black Hole

    Black Hole Felinos Guru

    No harm in trying it surely?
     
    Mike0001 likes this.
  9. Placemat

    Placemat New Member

    Roger, I will give it a go.
     
  10. Placemat

    Placemat New Member

    I just attempted a format (well several attempts) and got this:

    "Cannot Format the Hard Disk. The capacity is too large"

    So perhaps my issues is actually another dodgy hard drive. I've also just noticed that the warranty void sticker on my box is broken (from the repair obviously) but isn't it normal that this would be replaced?
     
  11. Black Hole

    Black Hole Felinos Guru

    How big is it supposed to be?
     
  12. Placemat

    Placemat New Member

    Well I had the 500GB model before it went for repair. The menu reports that it is a 500GB drive. Webif reports 447.6GB as the total capacity of the drive.
     
  13. Black Hole

    Black Hole Felinos Guru

    No way should that be too large to format.
     
  14. Placemat

    Placemat New Member

    I rolled back to vanilla firmware and it formatted. Problem still persists though :(
     
  15. Black Hole

    Black Hole Felinos Guru

    Eh? Wouldn't format with CF installed but would without?

    Sorry to hear it hasn't resolved the problem though.
     
  16. Ezra Pound

    Ezra Pound Well-Known Member

    I can't remember where, but, I'm sure i've seen another report saying a user couldn't format his HDD while using the CF, I wonder why
     
  17. Black Hole

    Black Hole Felinos Guru

    Perhaps the OS has some kind of interlock on the location of running executables?
     
  18. ChrisDaniels

    ChrisDaniels Well-Known Member

    I can only think the OPs problem is related to the network settings in some way as af123 mentioned previously.
    Could it be your router causing the issue? I would check to see if there are some upnp settings or something that's upsetting it.
    Did you change anything to do with your network while the box was in for repair?
     
  19. Placemat

    Placemat New Member

    Yeah I thought it was strange, I've never had problems with CF before.

    Thanks Chris, i'm going to try some further troubleshooting today to see if I can isolate what could be creating the issue on the network.
     
  20. Placemat

    Placemat New Member

    OK so after some time spent testing I isolated the device that was causing the problem. It was a twonkymedia server (kirkwood-special-7.0.8) running on my Synology NAS. I have since removed the server from the network and my Hummy is happy again.

    Thanks for the help chaps.