Network connection failing intermittently

Hi All
For quite sometime my hummy has been hooked up to my network with no problems, ftp has been working, webif working from both pc and my mobile.

Been decorating recently and have moved things about a bit, but seemed to be working fine last night when I transferred several files across to the hummy from the pc.

Just tried to log into webif on my phone and just got a page not found message.

So I have now tried on my pc and again nothing.

Tried FTP and initially it connected then I got a message saying:
ECONNABORTED - Connection aborted

And I couldn't get reconnected to the Hummy.

I've swapped out a network lead, with one I know to be working. which seems to be ok. However once again I can initially connect via ftp then it fails.

I've tried webif and for a short while it semed ok but then I got page not found messages again.
It seems to be completely intermittent, if I leave it for a bit it'll connect/webif willl load but moments later it fails again.

Has anyone else ever experienced this problem?

Any thoughts as to what the problem might be?
I'm really hoping it's not that the network socket on the hummy has been damaged as that would pretty much ruin the hummy's usefulness for me...

Could it have anything to do with the files I transfered earlier???

Any help very much appreciated!!
It's unlikely to be the file you transferred, If you've been unplugging / plugging your Humax from the network, it is possible it has picked up a new IP address from your router, maybe some IP addresses are being used by multiple devices, is your Humax's IP address set up manually or is the Humax set to DHCP?
After a good bit of investigating I managed to get it sorted last night. It did indeed end up as being an IP address problem..though not the fault of the Humax...

I have the hummy setup as DCHP with the router set to always give it the same address so my ftp settings etc all stay the same for ease.

However for some reason at some point yesterday my phone, which is setup as DCHP must have requested a new IP address and for some reason the router gave it the same one which is used for the Hummy.
I switched off wifi on my phone, removed it from the device list on the router, then switched the wifi back on. The router gave it a new ip and everything started working properly again!!! :)