Network share automount problem

#21
Good news that you've had it working in one form at least :)

Could the problem be that only "HDD" is shared? Sharing with smb only shares a specific folder, and you can only attach the mountpoint to this, not any folder below it (unless it too is explicitly shared). So I wouldn't expect mount -t cifs //192.168.0.104/HDD/movie to work (it is trying to mount a share called "movie" on a computer called"192.168.0.104/HDD"), and mount -t cifs //192.168.0.104/movie would only work if "movie" is explicitly shared (not just by merit of being below "HDD").

Is the "movie" folder explicitly shared?

Could you look at the debug log from the failed network auto mount attempt at mounting HDD? It should be creating a command that is much the same as what you entered manually (ie mount -t cifs //192.168.0.104/HDD /media/share...)
Hi again Steve

Firstly i could not find the debug log so i could not check it, can you point me it the right direction in case i need it again in the future.

I have got there in the end it all seems very silly now but this is the result.

Yes you were right the files below HDD are not explicitly shared so i have for now just stuck with HDD the only problem with this is i want to eventually make three shares one for movies one for music and one for photo, what im trying to find out is within Putty/Telnet is there any way of (from XP machine) can i tell the Sumvision Media player to share a specific file e.g. Movie or Music or Photo. Is there anyone out there in Hummy land who knows about this PLEASE.

As far as sharing a folder/file/HDD with network share automount is simply the length of the word to discribe the share eg Sumvision is one letter to long, remove any one letter eg umvision or sumision or sumvsion and it works every time LOL:frantic:;)

The odd thing is a full name of Sumvision will generate a new file to be mounted (sometimes you can see it for several seconds), it then dissapears when the files are trying to be mounted in it.

Lastly how do you delete unwanted/test autoshares that are now not required ive tried several times but they just come back straight away.:mad:

Thanks for all your help Steve and thanks again for this wonderful addition to the hummy
All the best

Andy
 

Drutt

Active Member
#22
Sorry for the delay getting back to you - I have a quick look at this, but couldn't recreate your problems. Tested with share names of >8 characters and it worked fine. Maybe you already had a share with that name running from experimenting with the command line? (a reboot should clear it). Also deleted share settings folders successfully (may take a reboot to actually remove the share).

The debug log can be view from the command line with "cat /tmp/scanmounts.log" or you can view it from the webif (diagnostics. scanmounts.log)

Steve
 
Top