network shares.

The members of this forum very kindly sorted out my installation of Network Shares previously. I now find that although my HD Fox can see the files on both of the other HDR Fox machines (1tb and 500mb) they cannot see each others file. I am able to see and use files from each machine via the Network option but do not have the full function offered by Network Shares. I do not think I have changed anything (intentionally!!) but the access has gone. By selecting USB from the storage options I can see the contents of the machine I am using but not the other machine.

As always your guidance is much appreciated.
 

Black Hole

May contain traces of nut
I take it from your comments this has worked previously.

You do still have real USB devices plugged into the HDRs? I take it that's what you mean by the "contents of the machine" (although strictly speaking those are contents external to the machine).
 
OP
M

Mike Somers

Member
My apologies for the delay in responding.
Yes there are usb devices plugged in(flash drives) and when I select menu, video, blue button and then usb I get # "usb disk 2.0" then "virtual-usb" and finaly "foxy" (my name for the 1tb HDR) listed from top to bottom. I am able to see the other HDR 's files via network and media server but not as a usb drive. The same applies to the other HDR machine. The files on both HDR machines are visible as usb drives on the HD machine.
 

MontysEvilTwin

Well-Known Member
Check that the IP address of neither HDR-FOX has changed: I doubt that this is the case based on your first post. Check that the share settings are still OK for each (>media>My Video>[ModSettings]>NFS). If all is OK, but the shares are still not working, try doing forced reinstalls (WebIf>Diagnostics) of the nfs-utils and network shares automount packages on each unit and then reboot.

Edited for clarity and error correction.
 

MontysEvilTwin

Well-Known Member
@Black Hole. I looked back at the OP's posts in the Network Shares Automount thread and I think he was using NFS shares. This could have changed, of course.

@Mike Somers. My instructions assume NFS shares. If you are using samba, see the following post.

Edited for clarity.
 

MontysEvilTwin

Well-Known Member
Drutt has summarised which packages to uninstall/ reinstall when troubleshooting samba shares here.

Comment. In post #4, I recommended forced reinistalls of packages. In the above link, package uninstalls/ reinstalls are recommended. I am not sure which is the best approach.
 
OP
M

Mike Somers

Member
The shares are working as I can see and operate them from the HD Fox T2 so they must be mounted and accessible. The scanmount log says so. The problem is neither of the HDR Fox T2's can see each others "mount" as a usb drive. The files you say to reinstall are those which perform the mounting function ?
 

Black Hole

May contain traces of nut
Does this problem persist after a reboot? I have found that sometimes mounts are missing and a reboot cures it.
 
Top