No TV Portal with 2.18


New Member
Web interface version: 1.0.4
Custom firmware version: 2.18 (build 1707)
Humax Version: 1.02.29

I don't use the TV portal much - so didn't notice the problem in the last few days. My Humax is definitely connected to my home network and I can FTP files from my PC. Just to eliminate powerline plugs from the equation, I have connected the Humax to the router with a long wire. Still getting the below message:

An error occurred whilst launching the application h-t-t-p-:-//localhost/portal/index.html
[put bogus hyphens to allow me to post this message]

I have seen a similar message before when it suffered from Internet/network connection issues but don't think I saw "localhost" in the message! Is it just an address resolution problem? Are there any diagnostics I can run to troubleshoot?

Thanks BH for your prompt reply.
(a) Yes - I do have an aerial plugged in. The signal is very good btw.
(b) No - I haven't installed portal-xtra1. Should I install it?
That looks like your custom firmware web interface (the mongoose web server) isn't running.
If that's the case, then the easiest way to fix it is to connect to the Humax via telnet (see, enter the Humax PIN when prompted (default is 0000) and choose web - Reinstate web interface service from the menu - that is, type web and press return at the prompt.
That message definitely indicates that you have some sort of custom portal package on that box...
OK - I am sending two JPEG images to show what I got on my Humax. I am going to try the telnet command now..


  • MyPackages.JPG
    164.2 KB · Views: 11
  • MyServices.JPG
    30.1 KB · Views: 11
The fact that you can get those screenshots rules out the web server being broken/disabled, so you won't see the web option on the telnet menu.

The Humax is trying to load a custom portal but you don't have one installed. Did you have one installed and recently remove it?

I suspect you somehow have part of a custom portal on your Humax (in flash rather than on disk). Try running the remove_portals diagnostic from the Diagnostics page in the web interface, then reboot and see if that solves it.
Got this:

Humax HD-Fox T2 (humax) 1.02.29/2.18
humax# web
-/bin/sh: web: not found
Ah, you must have expert mode turned on for the telnet server. Don't worry though as the web server looks fine from your earlier posts.
Thanks very much for your help. I didn’t understand the importance of the custom portal package, portal-xtra1. I was under the impression that the standard portal could/should work with 2.18.
I think most users are of the opinion that when running the Custom Firmware, you don't need to install the Custom TV Portal (Portal-Xtra1) in order to get the standard Humax TV Portal working, It maybe that the standard Humax TV Portal started working for some other reason, possibly a re-boot or some other action
I have installed the custom portal [portal-xtra1] and it works now!
Thanks very much for your help. I didn’t understand the importance of the custom portal package, portal-xtra1. I was under the impression that the standard portal could/should work with 2.18.
You should not need the custom portal, unless you want the custom portal. The error message you quoted in post 1 is similar to the message we get if the Humax loses time sync (ie the aerial is disconnected), but the "locslhost" bit pointed at something else - like the custom portal had been installed but the support files subsequently removed without resetting the pointers.

af123's remove_portals diagnostic should have reset the native TV portal, but it does not look like you tried it. Uninstall portal-xtra1 (unless you want it), and if the TV portal does not return to native run the diagnostic (this can be done from the WebIF diagnostics page, or via Telnet: diag remove_portals.

Did you intend to set Telnet to expert mode? You miss out on the quick-access fix menu that way (type "tmenu" to get it up from the command line). There is a setting on the WebIF settings page.
I was thinking about what happened and now I can give a possible explanation.

My Humax used to run 1.02.20/2.15 and I was very happy with it. Then the hard disk developed some issues. The recordings had some “disruptions” in them. The signal strength in my locality is very good but I was not 100% sure if it was the hard disk or some signal related problem. I hooked up the disk with my Linux box and ran GParted. It improved the situation but the problem didn’t go away. I even moved the recordings and let Humax reformat the disk. Finally, I flashed it with 1.02.29 and supplied a new disk.

The new hard disk is brilliant and I don’t see any disruptions in my recordings anymore. I thought when I flashed my Humax with 1.02.29, the custom firmware was overwritten by the standard one. This is where I am wrong. I should have used the option from the webpage to remove the custom firmware, 2.15 explicitly. I had the custom portal installed with 2.15.

With 2.18 on 1.02.29, the standard portal didn’t work because there were dangling pointers in the flash memory. The installation of the custom portal resolved these pointers and the box is happy now.

Do you agree with my explanation?
I'm not sure. The RMA option is to remove all trace of the custom firmware from the HDD, overwriting the non-volatile storage with a standard firmware ought to have re-established the pointers to the standard TV portal. Maybe af123 or xyz321 can shed some light.
RMA would have removed all traces including the custom portal hooks, just installing standard firmware and replacing the disk would have left some of the hooks in place, so the explanation makes sense to me.