Not decrypting

danco

Member
I have the new webif, and have set it for recursive auto-decrypt.

Some of my files have decrypted fine, but they may have been done with the old web if, I'm not sure..

But I have probably set something wrong, as it seems to have been stuck for a long time. The webif log reads

Runtime Error: /mod/webif/lib/bin/auto:143: Connecting to 192.168.0.10:9000 (192.168.0.10:9000)
wget: cannot connect to remote host (192.168.0.10): Connection refused
in procedure 'scan' called at file "/mod/webif/lib/bin/auto", line 276
in procedure 'scan' called at file "/mod/webif/lib/bin/auto", line 263
in procedure 'scan' called at file "/mod/webif/lib/bin/auto", line 263
in procedure 'decrypt' called at file "/mod/webif/lib/bin/auto", line 259
in procedure 'entries' called at file "/mod/webif/lib/bin/auto", line 236
in procedure 'do_decrypt' called at file "/mod/webif/lib/bin/auto", line 225
at file "/mod/webif/lib/bin/auto", line 143
DECRYPT: [/media/My Video/Watched]
DECRYPT: [/media/My Video/Watched/Music]
DECRYPT: [/media/My Video/Watched/Music/paul simon]
DECRYPT: [/media/My Video/Watched/World cinema]
DECRYPT: [/media/My Video/Watched/The Singing Detective]
DECRYPT: [/media/My Video/Watched/Features]
DECRYPT: /media/My Video/Watched/Features/Andy Hamilton's Search for Satan_20111215_2253
DLNA: http://192.168.0.10:9000/web/media/251.TS


and after a while these lines get repeated.
 

Ezra Pound

Well-Known Member
The recursive auto-decrypt function is new to the Web-if, so it might be worth temporarily removing the recursive auto-decrypt option from the /media/My Video/Watched folder and trying a manual decrypt on the Andy Hamilton's Search for Satan_20111215_2253 file to see if that works, looking for the DEC3.jpg symbol as an indication that decrypt has worked
 
OP
D

danco

Member
I'll try the auto-decrypt on an individual folder, as that was had worked in the past, and there are several other files in the folder to decrypt.

I had thought that probably it was an error on my part. But you are suggesting there may be an issue with the recursive auto-decrypt. If there is further information I can provide,please let me know what is needed, the log entries were all that I could find that was obvious.

(Later) Auto-decrypt on the folder still didn't work. I tried decryption on the individual file, and at first got the error message

The Humax media server is not running, cannot decrypt. Have you enabled Content Sharing in the Humax menus? It can sometimes turn itself off so it's worth double checking. If it is on then try turning sharing off and on again.



In fact Content Sharing was on. I followed the advice to turn it off and on again, and decryption is currently working.

So my current issue is solved. But can you explain why there is this issue of needing to turn Content Sharing off and on again?
 

emdubya77

Member
I had a similar issue with the regular auto-decrypt yesterday. When I then tried a manual decrypt on an individual recording it asked me to check Content Sharing was enabled via the Humax menus - changing that solved the problem straight away!
 

Ezra Pound

Well-Known Member
can you explain why there is this issue of needing to turn Content Sharing off and on again?

A lot of packages including all the decrypt ones need the file to have a DNLA symbol e.g. DLNA-small.jpg against it, this is done by the standard Humax Firmware periodically, sometimes the routine that does this stops (not sure why) and toggling Content Share kicks it back into life
 
Top