1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

not displaying properly

Discussion in 'FOXSAT-HD Freesat Receiver' started by john simpson, Mar 30, 2012.

  1. john simpson

    john simpson New Member

    I can move my channels up and down ie 1 to 2 to 3 to 4 ect but the display stays on 10 .Then when i go 21 22 23 24 ect it stays on 20, so i dont know what channel im on any ideas thanks
     
  2. grahamlthompson

    grahamlthompson Well-Known Member

    Baffled, Freesat channel numbers start at 101. If you happen to be using non-freesat they start at 5000. If you press list what channel numbers does it say are there. ?
     
  3. john simpson

    john simpson New Member

    yes sorry they do but the display still says 10
     
  4. grahamlthompson

    grahamlthompson Well-Known Member

    If you type in say 115 what does the display say ?. Never heard of this before. Have you tried carrying out a factory reset ?
     
  5. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    What box do you have and exactly what are you doing when this happens?
     
  6. oijonesey

    oijonesey Hummy.tv SEO Guru

    Haven't heard of this before but The Hummy Arms is a place for general chit chat (and sometimes buffoonery!!) - try posting your problem on one of the dedicated foums for either the HD/HDR T2 or the FoxSat HDR (or whatever flavour of Hummy you have).

    Also clarify are you re-ordering the channels? Or setting up favourites? Is the display you refer to the one on the front of the box or the channel numbers on screen? etc etc. Hopefully we can sort you out :)

    [Edit - yeah OK what he said!! :D]
     
  7. john simpson

    john simpson New Member

    done factory reset, type 115 display goes to 10 type 225 goes to 20 ?
     
  8. john simpson

    john simpson New Member

    sorry put my thread on the wrong forum (hummy arms)
    Its a Humax Foxsat-HD Freesat Digital Receiver
    I can get the channels just the display on the front off the box is on 10 then when you go in the 200 its 20
     
  9. grahamlthompson

    grahamlthompson Well-Known Member

    Sounds like a display board failure. Long shot Foxsat-Hd's are known to suffer from failed capacitors in the power supply so may be related to incorrect power rail voltages. Is it more than 2 yrs old ?
     
  10. grahamlthompson

    grahamlthompson Well-Known Member

    Display boards for older models like the 9200 are available from Humax and pretty easy to replace, so if not under warranty give customer support a ring.