1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

.NTS .HMT .THM Files Missing on Transfer

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by WhileyD, Apr 28, 2012.

  1. WhileyD

    WhileyD New Member

    Hi All,

    New to these forums but really hoping someone can help.
    I recently upgraded to the hummy custome firmware for a HDR-FOX T2 and think its brilliant. One problem though as i recently went to play a movie i'd copied across from my Humax to my NAS drive to free up space and it said it didnt recognise the file. To cuta long story short, some of the movies i've copied across have lost the .nts .hmt and .thm files and hence wont play. They wont even play in Windows media player on my pc.

    Strangely some of the movies copied across have copied these files. Seems to be no pattern as to what has kept them and what hasnt. Has anyone got any idea how i find these missing files? or create new ones? or stop them getting lost in the first place?

    I read somewhere else that you can import non humax files using Raydons AV2HDR-t2 software so i downloaded that. However when i try and put one of the .ts files through that it says "Index was outside the bounds of the array". Does anyone know what that means?

    Any help much appreciated!
    WD
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    All files both Standard Def and Hi-Def are encrypted and need to be decrypted before any other box will play them, a streight copy won't decrypt files, However if you have the CF installed, Toggle ENC followed by Decrypt in the Web-If will do the job. There are a lots of Notes on the WiKi HERE , Main WiKi at the top of this page
    BTW
    I presume your Humax is a HDR Fox T2 the Foxsat is a satelite receiver
     
  3. WhileyD

    WhileyD New Member

    Hi Ezra,

    Thanks for the reply. Not sure if i explained the issue well enough as im not trying to play the file on another device. My humax is full so i'm moving files from the HDD on that device to my Buffalo NAS drive on my home network. I've done this absolutely fine with some files from the humax but others appear not to have copied across the .nts etc files and hence wont play.

    Cf is installed and just in case i looked for remove enc, but couldnt see that option. I am clicking on the opt+ grey box and the only thing that looks like encryption is "toggle enc" but that doesnt appear to do anything other than give me an "enc" icon next to the file. Also the drcrypt option is greyed out so i cant select it.

    I'm cleary doing something wrong but baffles me as to why i didnt have to do this with the other files, they all just worked...

    WD
     
  4. Ezra Pound

    Ezra Pound Well-Known Member

    Yes, sorry I was assuming too much, I didn't cover the loss of files problem because the *.TS file should play even without the 'sidecar' files, so I thought something else was wrong. Files don't need to be decrypted if they are going to be be played on the original box that recorded them, but to play them on anything else they will need decrypting. To decrypt Hi-Def the ENC needs to be removed, If the decrypt option is 'greyed out' it may be because the file has not been allocated a DNLA URL and it's possible that could explain why not all files are being copied.
    Do the files that don't fully copy have the green symbol to the right of the DEC symbol? This is the DNLA URL symbol and it is allocated by the Humax automatically but it takes some time

    symbols.jpg
     
  5. WhileyD

    WhileyD New Member

    Wow, dont know what a DNLA URL is but pretty sure i havent come across that before.

    All of my files have neither the green dec or the orange/brown enc symbol next to them unless i click the option toggle enc on the opt+ menu, when i do that they all seems to have the brown enc symbol, but they only do this one at a time once i have selected the opt+ option to toggle enc.

    I still dont understand whats changed though. I mean i moved files over fine, most of them play fine, just not all of them when i try and move over wont play and are all missing the other non .ts files

    Confused.....
     
  6. Ezra Pound

    Ezra Pound Well-Known Member

    O.K. the Hi-Def files have extra protection, the toggle ENC allows them to be treated as Standard Def as far as decrypting goes, so the for Hi-def Remove ENC with Toggle, Then both Hi-Def and SD need a decrypt in order to get the DEC symbol, However decrypt will only work if the file has the ''3 White Dot' Symbol because the Humax is fooled into using the '3 white dot' = DNLA URL to do the decryption. I have just realised that you may need content share set to on the Humax, with Menu >> Settings >> System >> Internet Settings >> Content Share = ON. So set it to On, then remove ENC flags and wait for 30 Mins or so until the '3 White Dot' symbols appears
     
  7. Also if you have Redring installed make sure it is the latest version, earlier versions stopped the DNLA indexer from working correctly.
     
  8. Black Hole

    Black Hole Felinos Guru

    Foxsat? This is the HDR-FOX section. Foxsat is a different kettle of fish. Are you sure you mean Foxsat? If so please address your query in the appropriate section.

    Firstly, you don't need the extra files for the .ts to be playable. Secondly - how did you transfer the files to the NAS? I know nothing about the Foxsat, but if it was an HDR-FOX and you did it in the wrong way you would end up with an encrypted file and no - just because you are streaming it back to the same device doesn't mean it will get decrypted because the Humax wouldn't expect data from an external source to require decryption.
     
  9. Ezra Pound

    Ezra Pound Well-Known Member

    Already covered in #2

    Already covered in #4
     
  10. Black Hole

    Black Hole Felinos Guru

    Yeah, fine, but we don't have unambiguous answers.
     
  11. WhileyD

    WhileyD New Member

    Hi Ezra, thanks for your help. I changed the content share to "on"on my humax. That seems to have fixed things. I tried the same file i tried to move over before that change and it seems to have worked. Slightly strangely has removed the title of the movie and changed it to a number but thats ok as i can change back, just a nuisance.
    It still doesnt seem to have moved those other file types across though, wonder what they do as i thought they were the reason the other files werent playing?!?
    On another note and i know im pushing it here, but there are now several .ts movie files that were moved across before i changed the content share setting that dont play. I have deleted the file from the humax as i orginally thought they'd copied across ok. Is there any way to get these .ts movie files playing on teh humax from the NAS box or am i screwed for those?
     
  12. Ezra Pound

    Ezra Pound Well-Known Member

    The 'other files' are reffered to as sidecar files they hold information on the main file like small picture thumbnails, bookmarks, resume points etc. The Humax will play a *.TS file without them but you don't get as much control. When the file is streamed to a P.C. or another box it is given a DNLA URL and another name which is the number you refer to. If you can get the Non playing TS files back onto the Humax with their sidecar files and wait until they get the 'Three White dots' symbol, (Remove ENC flag if present) they should then transfer to the NAS box properly
     
  13. WhileyD

    WhileyD New Member

    Ezra, you have been an amazing help. Thanks so much, really appreciated!