Package Upgrade 'funny' and lost settings

Not open for further replies.


Ye Olde Bowler
Since the last webif update I have the following when I click on Check for Updates:
Capture 29-04-2022 11_08_28.jpg

I have also 'lost' lots of settings as below (though may not be all of them):
General Settings: Lost Hostname
Advanced Settings: Lost Custom encryption key
Boot Settings: Lost all settings
Fan settings: Reverted to 0% from 42%
Redring settings: Lots of settings lost - will not take 'Update'
Screensaver settings: Pressing 'Update settings' does nothing
Tunefix settings: 'Click here...' goes to blank page - tunefix.conf empty
Undelete settings: Looks okay but undelete not working (deletes immediately)

Trying to update these settings (eg, redring) does not work.

As there have been no other reports of these problems I must assume something has happened on my box.
Any ideas please ?
As there have been no other reports of these problems I must assume something has happened on my box.
Any ideas please ?
Re the screen image with the "Available" versions being earlier than the Installed versions, it looks as though you installed opkg-beta and then actioned a package update, followed by an uninstall of opkg-beta.

Have you powered fully down and then switched back on to see if the settings improve?
I have been running opkg-beta for years and have not uninstalled anything. I tried the package update because the first sign of problems was that, although I had turned off scrolling in redring,
it was back. I then checked settings and found what I listed above.
I have powered down fully with the switch for one hour but no change.
Can you provide the output of these from the command line:
opkg update
opkg list
opkg list-installed
cat /etc/opkg/opkg.conf
Unable to use CLI in diagnostics (503 service not available) so used maintenance mode.
opkg update.jpg


  • opkg list.txt
    39.1 KB · Views: 6
  • opkg list-installed.txt
    13.6 KB · Views: 4
  • cat etc.txt
    1 KB · Views: 4
opkg-beta has somehow become inactive. I would suggest removing and reinstalling it first.
No idea of root cause, but possibly indicates files in the flash either corrupted or deleted, and/or filesystem problems on the disk.
Might be interesting to see output of:
ls -lR /var/lib/humaxtv/
ls -lR /var/lib/humaxtv_backup/
Probably worth running the fix-flash-packages diagnostic and doing a fixdisk run.
I think you'll have to reinstall anything else that's broken.
@prpr - Thanks for all your work on this. Unfortunately trying to remove then reinstall opkg-beta failed. It then went from bad to worse and, in the end, I had to reset Webif and
reload 3.14a which gave me the 'raw' webif :). I am running a fixdisk at the moment so will give a full report on what I subsequently did and what happened once it has settled down.
Is it worth me still running the ls commands you asked for ?
If of interest here is what happened after @prpr 's post #6.

Remove opkg-beta did not work (2 screen shots of Remove...)
Fix-flash-packages failed
After reboot connection to Webif just gave a folder list
After power off/on the 'download & install the full web interface was displayed
Running 'download...' failed (screen shot Download failed)

Did a webif reset (no change)
Reinstalled 3.14a and back to the basic webif (hooray !) (Had retained my new password for telnet) but lost network connectivity
Rebooted and network connectivity restored
Ran fixdisk - all okay

I have now restored all the settings (a real memory tester).
Only problem I had was trying to decrypt 2 programs recorded after the problem occurred but before resetting the whole Webif.
Neither would decrypt using the new key I had set or the original system key. Auto log showed it did try with both keys but after 1-1/2 hours I gave up and deleted the programs and removed queue.db.

Remove in Packages.jpgRemove with CLI in Maint.jpgDownload  failed.jpg

Apologies for not doing the ls commands first.
There's nothing there that wouldn't have been fixed by reinstalling opkg-beta.
The inability to remove seems rather brain-dead though. It couldn't unmount /etc/opkg because it wasn't mounted, due to whatever the previous problem was which caused the missing files.
Failure to install WebIf was because of missing Beta repository.
Reinstalling the firmware was pointless.
Actually, I knew about the problem with opkg-beta as I'd already fixed it in a derived package when I was trying things out on my own local repository.
Didn't have the capability to fix it for real then though...
Not open for further replies.