Pause Live TV not working - Can't access box over network

Meadow Knight

New Member
My box has recently started to refuse to pause live TV for no good reason that I can recall. I have custom firmware installed (I'm at work so can't give version but it is 1.02.xx) but I'm unable to access the box over the network any more. I get the top graphic box but no text.

I have power cycled and factory reset the box to no avail. The HDD is showing only about a quarter full and I am clean out of ideas except perhaps now to upgrade the firmware to 1.03.12 plus custom F/W.

Anyone have any other ideas. If I get the custom F/W on should I start looking for issues and resolutions via telnet?
 
OP
M

Meadow Knight

New Member
Thanks - I've updated the firmware (to no avail) and set up a Telnet connection but I've not got any request to enter a PIN and there is no response to the menu launch command. I'm not familiar enough with the OS to go any further. Commands and responses follows:

Humax HDR-Fox T2 (humax) 1.03.12/3.00

humax#
humax# 0000
-/bin/sh: 0000: not found
humax# touch /var/lib/humaxtv/mod/maintenance.boot
humax#

Regards
MK
 

Ezra Pound

Well-Known Member
If you are getting the humax# prompt from a Telnet session, you don't need a password, you should get a Telnet Menu displayed, if you don't get this you can enter tmenu, the default system pin = 0000 e.g.:-

Code:
humax# tmenu
Menu version 1.10
Enter system PIN: 0000
 
      /-------------------------\
      |  T E L N E T  M E N U  |
      \-------------------------/
 
  [ Humax HDR-Fox T2 (humax) 1.03.12/2.22 ]
 
    1 - Restart into maintenance mode.
    2 - Remove web interface password.
stat - Show what the box is currently doing.
    x - Exit and close connection.
rset - Reset custom firmware environment.
srma - Set return-to-manufacturer (RMA) mode.
diag - Run a diagnostic.
  cli - System command line (advanced users).
 
Please select option:
You then need option 1 and after a re-start, Telnet in again and select option 1 again
BTW
As you have sent the touch /var/lib/humaxtv/mod/maintenance.boot command, the Humax should switch to Maintenance mode after the Humax is rebooted, this is achieved by entering reboot on a new command line
 

Black Hole

May contain traces of nut
Thanks - I've updated the firmware (to no avail) and set up a Telnet connection but I've not got any request to enter a PIN and there is no response to the menu launch command. I'm not familiar enough with the OS to go any further. Commands and responses follows:

Humax HDR-Fox T2 (humax) 1.03.12/3.00

humax#
humax# 0000
-/bin/sh: 0000: not found
humax# touch /var/lib/humaxtv/mod/maintenance.boot
humax#

Regards
MK
You seem to have managed to bypass the menu system intended for novice users, CF3.00 is very new so you may have found a bug. If you have access to the web interface please check the setting in Settings >> Advanced Settings >> Expert mode telnet server?. If this is set to Yes it would explain what you found.

If in that position again, rather than muck around with touch and reboot commands, just type "tmenu" at the humax# prompt.

Please proceed as detailed here: Quick Guide to Disk Recovery (click)
 

af123

Administrator
Staff member
this is achieved by entering reboot on a new command line
You should avoid issuing reboot from the command line whenever possible. The telnet menu and web interface take steps to make sure things are shut down and data is flushed to disk first.
 

Ezra Pound

Well-Known Member
As not per the wiki.
The WiKi reflects information supplied by the forum, if the forum information is changed the WiKi will be changed to follow it.
EDIT
The WiKi page has now been changed to use the tmenu command
 

Ezra Pound

Well-Known Member
Could I suggest a new command line function called something like safe-reboot, that carries out the shut down / data flush procedures followed by a reboot
 
Top