1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Possible 4GB Limit for DLNA Streaming

Discussion in 'HD-FOX T2 Freeview Receiver' started by Black Hole, Dec 6, 2011.

  1. Black Hole

    Black Hole Felonius Gru

    I have an ongoing investigation being written up in the HDR-FOX section HERE (click), it involves streaming from the HDR-FOX (server) to the HD-FOX (client) but the evidence is stacking up against the HD-FOX being at fault.

    The suspicion is that the DLNA client in the HD-FOX (1.02.20) hits a barrier at 4GB, whether the source is HiDef or StDef. Every file I have conciously tried that is greater than 4GB stops playing when I stream it at a time index that would be around 4GB in proportion to the total recording time and the file size. It doesn't matter if you let it play from the start or you sneak up to it using the transport controls. The exact same files play properly native to the HDR-FOX, or streamed by the exact same DLNA route to XBMC running on a PC.

    The question is: what is the extent of this affliction? If anybody else has a HDR-HD set-up please try it. If anybody has a DLNA NAS or is set up to stream by DLNA from a PC please try it. Anybody using the HDR-FOX as a DLNA client might also like to try it - the software might be common.

    The server is not (at the moment) under suspicion - it is used in the back-door decryption processes, and files greater than 4GB have been successfully decrypted, so the conclusion is that the DLNA server works properly.
     
  2. Black Hole

    Black Hole Felonius Gru

    Is nobody else streaming from HDR-FOX to HD-FOX, using the standard server-client facilities? I need somebody to confirm the issue.
     
  3. oijonesey

    oijonesey Hummy.tv SEO Guru

  4. Sam Widges

    Sam Widges Active Member

    Unfortunately, I can't get 4 Homeplugs working together in this house so most of that box's connectivity will be via wireless (already waiting for a suitable dongle from eBlag) but it has already been hacked and there is fun to be had :D
     
  5. mcwildcard

    mcwildcard New Member

    For the record, I've also had this issue, my 720p files seem to stop abruptly at around the 1hr35min mark, when streaming from my NAS. I don't have the problem on my PS3 when I stream the exact same files, so its unlikely to be the media server at fault.
     
  6. Black Hole

    Black Hole Felonius Gru

    Would that correspond with the 4GB point?
     
  7. mcwildcard

    mcwildcard New Member

    I'd say so, yeah.
     
  8. Digby

    Digby New Member

    I can also confirm this problem streaming from a Buffalo Linkstation DLNA NAS to a HD-FOX T2 (1.02.20).
     
  9. royalflush1964

    royalflush1964 New Member

    Looks like a problem I am having only slightly different. Can't find an answer anywhere on any of the Hummy Forums.
    Hope someone can shed some light on it for me.
    I have a home network - downstairs is a HDR FOX T2, connected to a Buffalo NAS, a TP-Link Gigabit switch a wireless ADSL router a PC a DLNA compliant Blue Ray Player (This is only ever been in standby during the following tests) and a TP-Link Homeplug.
    Upstairs in Bedroom 1 is a HD FOX T2 which has successfully streamed everything from my NAS & HDR over a TP-Link 200Mb Homeplug with NO PROBLEMS. I have now invested in another HD FOX T2 for bedroom 2. Because this is further from the HDR & NAS I decided to purchase a TP-Link Access Point set as a Client. This is where my problems lie.
    The HD FOX T2 in bedroom 2 can "see" the NAS & the HDR. It can also play any of the files on them. However, after between 10 and 30 mins, if I am watching from the HDR the signal will dropout and only the NAS is remaining visible. If I then play from the NAS, 10 to 30 mins later, this drops out and no network connections are visible. Only a Power cycle of the HD will bring back the network into view.
    I have connected Bed2 HD to the Homeplug in Bed1 and it streams perfectly. I have connected the Access Point direct to my PC and streamed wirelessly from the HDR and NAS with no problems/dropout. I have also tried connecting Bed1 HD to the same Access Point now situated within 12" of the Wireless router and it drops out within 10 mins of starting to stream.
    Just to add more info into the mix, the Bed2 HD streamed BBC i-player flawlessly for an hour over Wi-Fi while situated in Bed2.
    It seems there is a problem with the HD/Wi-Fi AP/DLNA streaming.
    If you need any more info, please let me know.
     
  10. Black Hole

    Black Hole Felonius Gru

    Rule out the HD-FOX by swapping with the other one. I think this is down to the network, so you should find the problems remain even with the switched HD-FOXes.

    The 4GB bug will hit you at a point which depends on the type of content you are streaming - it is a solid stop as if the file has come to the end, with no loss of network connection. Its existence has been thoroughly verified (see HERE - click). The new firmware 1.02.27 cures it, but has it's own set of undesirables (see HERE - click).
     
  11. royalflush1964

    royalflush1964 New Member

    I have swapped the HD's and they both give the same problem. I thought 1.02.20 was the latest, but i will install 1.02.27 for Bed2 HD and report back.
    Doesn't sound like the 4GB issue to me, the network connections ARE lost until a power cycle of the HD. Also, I haven't seen any problems with a 'wired' connection, only Wi-Fi. Unless that'e because I haven't watched files at 4GB in size. All files on the NAS are AVI, 2GB max, all files on HDR are SD - I seem to get recording failures in HDef.
     
  12. Black Hole

    Black Hole Felonius Gru

    Right, so HD-FOX A works on the HomePlug but not on the access point, and HD-FOX B works on the HomePlug but not on the access point - doesn't that tell you anything?
     
  13. royalflush1964

    royalflush1964 New Member

    Yes, it says there is a problem with the AP. That's why I connected the PC direct to the AP and streamed a 2 1/2 hr film across the Wi Fi from the NAS with no problems. Just updated to 1.02.27 and the connection was lost after 27 mins?
    Also there is no problem using the HD connected to the AP to watch iPlayer?
     
  14. Black Hole

    Black Hole Felonius Gru

    I know it's weird, but networks sometimes do weird things (especially when there are lots of complexities and interacting kit). Mind you, everybody tried to tell me it was my network when my HD wouldn't access the TV Portal, until I proved it was because I didn't have an aerial connected and it had no time reference.

    How about buying it another HomePlug?
     
  15. royalflush1964

    royalflush1964 New Member

    That's a possibility. I will move the Homeplug in Bed1 to Bed 2 and see if it works. But then I may get other interference with 2 Homeplugs accessing the HDR / NAS at the same time. Or the distance / wiring may not be suitable. I have ordered a USB wi-fi dongle (Edimax EW-7711UAN 150Mbps Wireless 802.11n High Gain 3dBi USB Adapter) will see if that's any better. The reviews are good for the HDR - but they mainly report on accessing the Portal - a problem I don't have LOL.
     
  16. Black Hole

    Black Hole Felonius Gru

    HomePlug is designed to create a multi-point network through your mains wiring (as long as it is all on the same phase), so "interference" should not be a problem - you will be adding another node to the existing network, not setting up another independent network. It's more a question of access contention (just like Ethernet or WiFi). The bandwidth you need for a single HiDef feed is around 11mbps, so AV500 (or even AV200 which is what I use) should be plenty!
     
  17. royalflush1964

    royalflush1964 New Member

    Thanks for the help Black Hole. Just to complete this thread, the Edimax EW-7711UAN 150Mbps Wireless 802.11n High Gain 3dBi USB Adapter worked flawlessly as did the Homeplug TL-PA201 (however, this was just moved from one bedroom to the other - not 2 separate nodes). The Wi-Fi client TP-Link TL-WA701ND 150Mbps Wireless Lite N Access Point would drop out continuously even with the latest firmware installed.