1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Possible Corrupt File Issue

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by BB1, Oct 10, 2012.

  1. BB1

    BB1 New Member

    Hi there. I've been having some difficulties with my freeview and I keep running into brick walls.

    Basically, I got a delete loop issue, but it wasn't deleting anything. It wasn't deleting any recordings or anything, it just had a 'delete' caption in the top right-hand corner. It started when I tried to delete a program, which led me to believe it was a corrupt file. The program itself won't play and it has its TS extension visible. On top of all this, I also can't record anything.

    So I downgraded the freeview software to 1.01.09, and the problem went away. But it came back when I tried to delete that file. Also, whilst with 1.01.09, I couldn't get anything to record, and the sound didn't work on HD recordings. I re-upgraded the software, and ended up back where I started. No record, no delete. However, it will delete other programs.

    I'm fully aware that a format of the hard-drive may well fix everything, but there is no way I'm losing my recordings. Not to mention the fact that you can't get the recordings off onto an external hard-drive because that has never worked and would take many, many days.

    I hooked it all up to the internet and ran this custom firmware that I'd only just heard about. I'm not tech savvy and I know nothing about all of this. I'm literally clueless, but I thought I did everything okay. I put the correct firmware on my USB stick and up popped the screen that said it was installing. But everything was the same. I then discover I need to get this web interface thingamajig, whatever the heck that is. I open the browser, put in the IP address, and... does not work. I get this message:

    Collected errors:
    * make_directory: Cannot create directory `/mod/var/opkg/info': Read-only file system.
    * opkg_download: Failed to download [file], wget returned 1.
    * rm_r: Failed to open dir : No such file or directory.

    Error retrieving package list from the Internet. Please check your connection and try again.

    I tried it on several computers and devices and on several different browsers, and the internet seems to be working fine. I'm genuinely lost. I don't know anything about any of this stuff and I just don't know what to do. I don't know where the problem lies or what I'm doing wrong. I just keep running into walls. My current line of thinking is to get an alternative to this browser interface web thing, but I have no idea if I'm on to something with that.

    Can anyone help? I'm well out of my depth.
     
  2. Black Hole

    Black Hole Felonius Gru

    Don't panic, help is at hand!

    It sounds like your file system has corrupted and been marked read-only, which is why trying to install packages has failed. Never mind the web interface, to repair this you will need Telnet to open a command console. Whatever computer you are using, download and install PuTTY.

    Beyond that, I think you have installed CF 2.12 so I think you are all set. I will leave the detailed instructions to the gurus.
     
  3. BB1

    BB1 New Member

    Thanks for the quick reply.

    I have installed CF 2.12. I started to press some buttons (curiosity). I pressed the Telnet option and put my freeview IP address in (I'm like a 2-year-old with new stuff). I pressed open and I got a black command screen. Sorta looks like the Matrix. I have no idea if this was what I was supposed to do, but that's where I'm at.
     
  4. Ezra Pound

    Ezra Pound Well-Known Member

    The solution to this problem is detailed in the WiKi HERE
     
  5. Black Hole

    Black Hole Felonius Gru

    I advise using the fix disk procedure, there are read-only issues going on as well. I think the Wiki is out of date in this respect, because the fix disk procedure also fixes the delete problem.
     
  6. Ezra Pound

    Ezra Pound Well-Known Member

    The WiKi is not out of date, It's first solution is to run Fix-Disk
     
  7. BB1

    BB1 New Member

    I tried the code at the bottom of that Wiki. I switched the freeview back on and the delete was gone. I tried to delete the record that initially triggered the permanent delete and that just triggered it again. I really wish I hadn't done that. I didn't check beforehand whether or not it could record. I'm now going to try the fix-disk.
     
  8. BB1

    BB1 New Member

    Oh my word, you guys are legends. I've been at this for three days and I could not for the life of me work out what was wrong. I was on the verge of buying a new freeview, but now it works and all is well. Three days and I should've come here to start with. I'll know next time.

    Thank you all so much.

    (Do I need to close this thread or mark it as solved somehow, or should I leave it - told you I was useless).
     
  9. Black Hole

    Black Hole Felonius Gru

    Sorry, I misread it (as I expect others might - and did).
     
  10. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    For the sake of others who come looking for solutions could you say exactly what you did that finally fixed the problem (and repeat it over on myhumax).
     
  11. BB1

    BB1 New Member

    I'll try, but it won't be very technical.

    1. Hook up the freeview to the internet using an ethernet cable. I wouldn't worry about what an ethernet cable is (I just picked the first cable I found that fitted).
    2. Make sure everything is connected to the freeview as if it was normal. Scart lead connected to the freeview and to the TV, freeview plugged in, aerial connected (this is vital - it will not work without the aerial [time/clock issue, I believe]).
    3. Go to Google and type in custom firmware hummy. Click the second result and download the latest official Humax firmware and the latest customized firmware. Unzip the official firmware, drag the white file in the folder onto a USB stick and plug that into the freeview. The freeview should be completely switched off, even the on/off switch at the back. Switch it back on and the firmware will install. Do this all again but with the customized firmware.
    4. Then press 'TV Portal' on the remote control. It should be next to the zero, but if it isn't, don't worry, it'll be somewhere on your remote. Lot's of things will happen on your TV, but it's just connecting to the internet. This is all trivial, but it's just a check to see if all is dandy.
    5. Go to Google and type in PuTTY telnet, click the first link, go to the downloads page and download the correct version.
    6. Click on the download and it'll open up. Make sure the 'telnet' option is selected and put into the white box at the top your IP address for your freeview (settings > system > internet setting > configure LAN > IP address).
    7. Press open and you'll get a black box. You must switch off your freeview (but not completely, leave it switched on at the back). Click on the WIKI link above, then click on Fix-Disk and follow those instructions. Type what's in yellow and then hit enter/return. It'll do the rest.
    8. All should now work.
    For some reason, I can now record two programs and watch a third. All the time. No idea why, but I like it. Nice feature.

    (I wasn't able to post links as I'm new, in case you're wondering why I didn't post links).
     
  12. Black Hole

    Black Hole Felonius Gru

    That's a lot more complicated than it needs to be. The essence is HERE (click).

    1. No need to have a functional Internet connection to the Humax, a simple network link to a Telnet device will suffice.

    2. Presuming your Humax has firmware 1.02.27 or later, with a PC download the latest CF (currently 2.12) and unzip it onto a FAT pen drive.

    3. Perform a manual firmware update as normal, but using the CF.

    4. With the Telnet console enter the command "fix-disk", the Humax will reboot.

    5. Re-open the Telnet session and enter the command "fix-disk" again.
     
  13. BB1

    BB1 New Member

    I don't know a great deal about the ins-and-outs of this.

    I just wrote down what I did which was a bit haphazard.
     
  14. Black Hole

    Black Hole Felonius Gru

    I realise that, I'm just cleaning it up.

    A full step-by-step guide will materialise somewhere!
     
  15. Ezra Pound

    Ezra Pound Well-Known Member

    It already has, in the WiKi under Fix-Disk
     
  16. Black Hole

    Black Hole Felonius Gru

    You know what I mean - a full hand-holding one.
     
  17. If you have no idea what you are doing in relation to the custom software BB1's step by step instructions are brilliant. Once you do know a bit more about it then the WiKi is essential.
     
  18. ardent

    ardent New Member

    Hello All
    My first post so hope I am asking in correct place. Posted here as relates to "fix-disk" mentioned above.
    Have recently recieved a "need to format disk message" Thought this a bit drastic given the up till then faultless behaviour of my HDR 1TB
    Have installed CW ending 29. Fine (is a manul install different to following the instructions that come with it?)
    Have also installed putty. Fine
    Comunicates via putty fine. Hoping that the "fix-disk" would sort me, out sadly not. Other componets are working, auto decrypt, shrink etc. (can hear the box working + creating and deleting files.)
    But fix disk = no joy. Keep getting the following message, after hitting the Y
    Humax# y
    -/bin/sh: y: not found
    Have worked through things via maintence mode, cannot unmount dev/sda2 as busy.
    I am connecting via wireless does this matter? as if put in standby putty/telnet will not work.

    Great site, already learned a lot, but stuck on this one.

    All suggestionss/ideas/tips greatly appreciated.

    Jason
     
  19. af123

    af123 Administrator Staff Member

    You need to configure PuTTY to send the proper newline commands. See http://wiki.hummy.tv/wiki/Telnet

    fix-disk is definitely the way to go and hopefully it will fix the problem!
     
  20. ardent

    ardent New Member

    AF123
    Thanks for that. WAS configured incorrectly for the job in hand, even though it worked on other levels.
    Anyway. I am a step closer, responded to the Y, this time it went away for a few seconds and came back with "unrecognised partition type, aborting." Doh!

    Jason