possible ntfs related reboots and crashes with cf 2.xx


I have many problems so I'll try and keep this brief and one issue at a time:
After my previous hardware issues I now have 2 hdr-fox T2's side by side - one a grade A refurb delivered this week.

First a request - Ideally I would like to revert to fw 1.17 as this ran fine for 10 months or so with no issues at all and
I started seeing problems immediately when I upgraded it to cfw 2.0 - I see 1.17 is not online - would it be possible to get this back?

Current issue 1 - both boxes suffer repeated reboot and crashes. I have spent (full time) this week trying to isolate
the various issues that seem to cause this including testing various firmwares;

Primarily ntfs-3g seems to be key. I have repeatedly been able to cause both boxes to reboot/crash by plugging in
an external (mains powered) usb drive - the sequence is :

Clean re-install minimal packages
1 Run box (any firmware with current download packages) for 8 hours no problem
2 Plug in USB drive - usually it works but occasionally it goes into a multiple reboot cycle
3 Play off the drive for 1 hour then leave it when recording stops
4 drive does its internal power down
5 box goes into a reboot countdown (cycling immediately on restarting even if the box is switched off) - it must be left at least 1 hour to recover (suggesting current draw to me) - is the circuit diagram available anywhere ???
The drive itself is not the issue. (I have 7 here - 3 different types) I have tried another with the same result.

I am trying to clean out a drive to reformat as non-ntfs to try but thats time consuming.

I'd appreciate comments from anyone else with reboots/crashes.
I'm not sure that your problem is related to CFW 2.00 or the USB drive being NTFS, it sounds more like a hardware problem with one (or both?) USB sockets on your Humax. I have a copy of HDR_FOX_T2_1.02.20_mod_1.17_upgrade.hdf if you need it
Hi Ezra....

There are multiple issues .... And definately USB related (or possibly power issues - hence my interest in the circuit)

For example - as we speak the new (refurb) box with 1.03.11 custom firmware 2.22 download but no webif as yet is currently
cycling through reboot every 20 seconds. (I've just stopped it after 5 cycles)
This is clearly being caused by the signal quality on 618Mhz bouncing up and down from about 10% to 80% while power level is stable at around 80%
If I change channels from 85 (RT today) to 101 (BBC) it stops rebooting entirely. I've gone back and forth to prove this several times now
This box was delivered with 1.03.11 on it which is why I chose that CF level

This is not happening on the other box which I just put 1.02.32 and basic webif installed plus just fix-disk and reports
similar signal values - I wasnt expecting this new issue and am not ready to stop my current train of thinking to address it yet...

The other muxes are quite stable at 100% quality and dont cause the reboot issue on the new box.
neither box has a USB drive plugged in at the moment -

This is very suggestive of a firmware issue but has only just started happening so
I havnt had time to look into it deeper

I would appreciate the upgrade - I did try 1.15 which I have here but the repository has changed so I cant download packages with that
(or 1.17 I assume?) I'd really like to try the previous ntfs-3g bundle as I seem to remember reading that has recently been upgraded too?

Ideally I'd like to get back to where I was about last februrary with everything and start from there. (for nearly a year I ran with up to 4 USB
drives connected through a (cheap) hub with no issues at all. I'd never even seen the reboot message before upgrading to 2.0
after which I started getting random green screens and reboots. Now I also see these crash messages.

Something is not right somewhere but there are so many symptoms its tricky to spot - even with 2 boxes crashing side by side
jack616 - I returned a box a few weeks ago to Humax because the signal kept bouncing around up and down 10-80% whereas my other one was stable. The signal instability kept resulting in lock ups and picture break up. If you want to post or PM me the last few digits of your serial I can confirm whether its the same box. Either way it sounds hardware related.
Many thanks ezra - downloaded now - thats a huge help.

Also thanks BH and adgibs - I didnt know about that I will check it out soonest.
I've gone a bit quiet because I'me desperately trying to get this all worked out by
Monday and catche the programs I'd like to record in between ... I'm juggling a bit !

To echo the T1 ... I'll be back...
First thanks for the firmware ezra - my old box has now run perfectly reliably since I went back to that.
I have not as yet installed the full webif or most packages on it however -
I have put a couple of packages on via USB. we'll see how this goes as I add more.

It would be nice if we could have earlier versions of everything in an archive rather than deleting them.

My new box is clearly faulty and I will have to ask Humax for a replacement.
I don't think I can do anything else to get that working.
When I first tried the box the hard drive test built in said there were no errors. e2fsck found
literally hundreds of thousands of errors. I dont know what that test does but it certainly doesnt test
the hard drive any more than the format command formats the drive.
Really annoying that.

Anyway - onward and upward...
thanks again.