1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem connecting to Humax over network in OSX

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by ribrob, Jan 25, 2012.

  1. ribrob

    ribrob Member

    Hi there,

    Whenever i try to connect to my HDR-FOX T2 via the network using OS X Lion, i get the following error...

    "There was a problem connecting to the server “humax”. The version of the server you are trying to connect to is not supported. Please contact your system administrator to resolve the problem."

    [​IMG]

    I get the same error whether i just try and browse to it, or "Connect As".

    I currently have the samba 2.2.12-3 package installed, and you'll see that in the sidebar the box is appearing in the network items as "humax".

    I can FTP in without any problem, but it would be handy to be about to just get to it direct via the OS.

    Any ideas what the issue could be?

    Thanks in advance...

    Rob.
     
  2. Black Hole

    Black Hole Ron Glum

    I've seen this before, just trying to remember where...
     
  3. Ezra Pound

    Ezra Pound Well-Known Member

    Good comment
     
  4. xyz321

    xyz321 Well-Known Member

    Here and here or perhaps elsewhere?
     
  5. Black Hole

    Black Hole Ron Glum

  6. ribrob

    ribrob Member

    Hi there,

    Thanks for the info!

    So i need to install the following packages...
    • portmap: used with both NFS client and server
    • nfs-utils: kernel based NFS server (v3 & v2 only)
    I assume i also no longer need Samba installed?
    Rob
     
  7. xyz321

    xyz321 Well-Known Member

    Yes, if you install nfs-utils then portmap will be installed automatically since it is a dependency. You can remove samba if you wish. Note that the nfs-utils package exports /media/virtual by default so you would also need the virtual-disk package. You can change this by editing the config. file /mod/etc/exports.

    I am sure the Mac experts will be along to help with setting it up. I seem to remember that the NFS settings are somewhere not immediately obvious (under disk settings I think).
     
  8. Drutt

    Drutt Active Member

    "Disk Utility", then "File", "NFS mounts" is where it is meant to be done, however I couldn't get this to work (didn't try very long though). I just run a little shell script on the desktop when I want access. The contents are:

    Code:
    #!/bin/sh
    mkdir /Volumes/Humax
    mount -o soft -t nfs 10.0.1.5:/media/drive1 /Volumes/Humax/
    
    Obviously substitute your box's IP, and you can just type the commands in a console window to test it works.

    It appears in the finder menu as a network drive, and can be ejected from there when finished with.

    Steve
     
  9. af123

    af123 Administrator Staff Member

    Easiest way is to open finder and press Command-K, enter nfs://10.0.1.5/media/drive1 in the box. You can save it as a favourite server there too.
     
  10. ribrob

    ribrob Member

    Sorry - missed those last two messages come in - thanks i'll try it out!
     
  11. ribrob

    ribrob Member

    I get this error - You do not have permission to access this server. - it doesn't ask for a password or anything.
     
  12. ribrob

    ribrob Member


    I get "Can't mount /media/drive1 from 192.168.1.21 onto /Volumes/Humax: Permission denied"
     
  13. Drutt

    Drutt Active Member

    How does you config file look? (/mod/etc/exports). Mine looks like this, which I've just realised is not the default (default is mapped to virtual drive which I don't have - no use on the HD).

    Code:
    "/media/drive1" 10.0.1.2(rw,insecure,no_root_squash,all_squash,no_subtree_check,anonuid=0,anongid=0)
    
    The ip is the address of the accessing host (A mask I think so you can put 255.255.255.255 to allow access to all, or 192.168.1.255 to limit it to your LAN).

    Hope that helps...

    Steve
     
  14. page3

    page3 New Member

    Ok, I'm stumped!

    I keep getting "Permission Denied" error when trying to connect from Lion. Trying both manually mounting via the shell and also via Command-K.

    I noticed that I do not have a drive1 in my /media folder so am trying to share /media only. That contains "My Videos" etc.

    I have tried modifying /mod/etc/exports to use /media. I've tried setting it as read only, but the permissions look fine. I've tried creating a folder inside /media and exporting that - still same error and the folder gets deleted on reboot anyway.

    I've tried different combinations of IP address, mask (192.168.0.0/24 etc).

    I've tried different connection string from the Mac side - e.g. "sudo mount -o ro -t nfs "192.168.0.14:/media" /Volumes/Humax/"

    Example of exports config (but I've tried many combination as above):

    "/media" 192.168.0.3(ro,insecure,no_root_squash,all_squash,no_subtree_check,anonuid=0,anongid=0)

    All give me "Permission Denied"

    Any ideas?
     
  15. af123

    af123 Administrator Staff Member

    I'm getting the same, although my Humax can mount itself.

    Code:
    humax# cat /mod/etc/exports
    "/mnt/hd2"    *(rw,no_root_squash,no_subtree_check)
    humax# /mod/sbin/exportfs -a
    humax# /mod/sbin/exportfs
    /mnt/hd2          <world>
    humax# mkdir /tmp/l
    humax# mount humax:/mnt/hd2 /tmp/l
    humax# df -h /tmp/l
    Filesystem                Size      Used Available Use% Mounted on
    humax:/mnt/hd2          906.1G    398.6G    461.5G  46% /tmp/l
    
    and my Mac can see the mount as exported:

    Code:
    $ showmount -e humax
    Exports list on humax:
    /mnt/hd2                            *
    
    and I can mount it from a Linux machine...
    I'll have a play and see if I can work out what is going wrong..
     
  16. af123

    af123 Administrator Staff Member

    You need to update your /mod/etc/exports file to include the insecure option, or mount the share with the -o resvport option from the OSX client.

    The insecure option just makes the Linux server accept connections from non-privileged port numbers (port numbers above 1024). Since MacOSX 10.6, high-numbered ports have been used by default by the NFS client.

    Set your /mod/etc/exports to something like:

    Code:
    "/mnt/hd2"    *(insecure,rw,no_root_squash,no_subtree_check)
    
    and run exportfs to refresh the mount list:

    Code:
    humax# /mod/sbin/exportfs -r -v
    exporting *:/mnt/hd2
    
    and then it should work:

    Code:
    air# (30) mkdir /Volumes/humax 
    air# (31) mount humax:/mnt/hd2 /Volumes/humax
    air# (32) ls /Volumes/humax
    My Music/    My Video/    af/        mod/        thumbnail/
    My Photo/    Tsr/        dms_cds.db    ntfs.img    virtual_disk/
    
    I see you have insecure option in there already so I wonder if you were just missing the /mod/sbin/exportfs step?
     
  17. xyz321

    xyz321 Well-Known Member

    Perhaps it would be a good time to update the package with a new exports file. Is it OK for the client to connect as root in order to write files or should we use Drutt's suggested exports file (above) which maps all client users onto the Humax's root user?
     
  18. af123

    af123 Administrator Staff Member

    Yes, that sounds like it would be a good idea to update it with Drutt's settings and maybe just share /media if the symlinks don't cause a problem.
     
  19. xyz321

    xyz321 Well-Known Member

    The NFS server package has been updated to nfs-utils_1.2.3-2. A new /mod/etc/exports config file will be created if it doesn't already exist at install time but an existing one will not be overwritten. It should now include entries for /mnt/hd2 and /media/drive<n> for the HDR (and just /media/drive<n> for the HD). Unfortunately the symlinks do cause problems for nfs exports. All users on the client will be mapped to the root user on the Humax (as in Drutt's post above). This should help with some of the permission denied problems.
     
    Drutt and af123 like this.
  20. adgibs99

    adgibs99 Member

    Has anyone got NFS share working with the latest Apple OS, Mavericks? Ive installed NFS UTILS, PORTMAP and VIRTUAL DISK on the humax HDR, modified the exports file which now looks similar to the one posted by af123.
    Code:
    "/mnt/hd2"          *(rw,insecure,no_root_squash,all_squash,no_subtree_check,anonuid=0,anongid=0)
    
    I mounted the volume on the humax box using terminal with no problems but when I try to mount it in Mavericks I get permission denied or:
    Code:
    Andrews-iMac:~ Andrew$ mount livingroom:/mnt/hd2 /Volumes/humax
    mount_nfs: can't resolve host: livingroom
    mount_nfs: no usable addresses for host: livingroom
    mount_nfs: can't resolve host: livingroom
    mount_nfs: no usable addresses for host: livingroom
    mount_nfs: can't mount /mnt/hd2 from livingroom onto /Volumes/humax: No such file or directory
    
    All steps were fine up to this point. Any ideas much appreciated.