1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem reloading firmware

Discussion in 'HDR-FOX T2 Freeview Recorder' started by ejstubbs, Apr 26, 2011.

  1. ejstubbs

    ejstubbs Member

    I noticed recently that I am no longer being offered the HD option on BBC iPlayer. I decided to try re-installing the 1.02.07 firmware from a USB stick. I used the same USB stick from which that version of the firmware had originally been installed. I downloaded the firmware anew from the Humax web site. When I turned the power on to the box with the USB stick in place I got an "E-ID" error. It says I need to press the standby button to restart but that results in the same error unless I remove the USB stick.

    Any ideas? Might a factory reset help?
     
  2. af123

    af123 Administrator Staff Member

    An E-ID error indicates that the software update you're trying to apply is for a different machine. (The system ID embedded within the software update doesn't match the System ID of your box). It could be that you've downloaded the wrong firmware, or that the file is corrupt in some way, or that you didn't unzip it after download (I've seen some people just rename the .zip to HDR_FOX_T2_upgrade.hdf)
     
  3. ejstubbs

    ejstubbs Member

    Hmm... Well, I downloaded the firmware yet again and tried again. Same result. I ran a factory reset and tried again. Same result. It is 100% definitely the HDR-Fox T2 firmware that I am downloading - the release notes refer to the FTP server and the portal.

    The loader version on the box is a7.30. The system ID is 80BC7E01.

    The good news is that the HD option in iPlayer has returned. Navigating the menus in iPlayer is still dog slow though.
     
  4. af123

    af123 Administrator Staff Member

    The system ID in the firmware from the download site is 80bc.7e00 - does yours definitely have a 1 at the end?

    If so, then that's why you're getting bad ID, but I don't know why your system ID would have changed.
     
  5. ChrisDaniels

    ChrisDaniels Well-Known Member

    It states System ID 80bc.7e00 on the Humax site as af123 says above.
    Where are you downloading the firmware from?
     
  6. Hi

    I've been lurking here for awhile but want to say I've got this problem to. Without giving away too mcuh my user name gives a clue about where the firmware on my HDR atm came from. I want to go back to the last official release but I get the eid error the id on thsystem info scrn on the hummy has a 1 at the end. How can I chnage my id back to the right one?
     
  7. af123

    af123 Administrator Staff Member

    You could use the humidify tool to repackage the official HDF to work with your new system ID. That will allow you to load the official firmware back on and it should revert the system ID too.

    Code:
    $ ls
    HDR_FOX_T2_upgrade.hdf
    $ humidify -x HDR_FOX_T2_upgrade.hdf
    HDF Tool v1.0.0, by af123, 2011.
    
    Opening HDR_FOX_T2_upgrade.hdf, 17598758 bytes.
    
      Blocks:    542
      Model:      4
      System ID:  80bc.7e00
    
    x  1.hdfbin-1-000000.raw          (15736832 bytes)
    x  2.hdfbin-1-1e00000.raw        (1914272 bytes)
    
    Processed in: 0.76s
    
    $ humidify -c HDR_FOX_T2_upgrade.hdf 80bc.7e00-80bc.7e01 1.hdfbin-1-000000.raw 2.hdfbin-1-1e00000.raw
    
    Adding 1.hdfbin-1-000000.raw (15736832 bytes).............  0.36% compression
    Adding 2.hdfbin-1-1e00000.raw (1914272 bytes).............  0.14% compression
    
    Processed in: 3.57s
    
    $ humidify -t HDR_FOX_T2_upgrade.hdf
    ...
      System ID:  80bc.7e00 - 80bc.7e01
    
    
     
  8. Thanks for taht, but your link doesn't work for me. If I can download the softwear, can I run those commands on any unix system or does it have to be on the hummy?

    Edit: worked this tiem, runs on anything, cool! Will def give it a try.
     
  9. ChrisDaniels

    ChrisDaniels Well-Known Member

    If the firmware on the public beta site has been packaged up wrong by Humax, someone should tell them..
    However, if this is what they do to closed beta f/w to stop it being distributed, its crafty lol but it locks the user into using the beta until Humax gives them a f/w to change back their sys id.

    I'm presumming its the latter - they're a bit over-protective regarding f/w. I think they need to remind themselves its a settop box and not a PS3.
     
  10. af123

    af123 Administrator Staff Member

    Good stuff. Yes, it runs on most things, and on the Humax itself although on there it's a tad slower :)
     
  11. af123

    af123 Administrator Staff Member

    Yes, it's difficult to know exactly why they did it. Presumably the first beta software changed the system ID so would have itself had to apply to a standard HDR with the original system ID. After that, the beta testers are locked onto the beta software train until Humax give them a firmware that changes it back again.

    I haven't looked but it's very probable that the system ID is actually in the boot loader (which Humax have never publically released for the HDR). That could mean that the original firmware is actually incompatible with the new bootloader. In case that's true, I'd make sure you have a copy of the software you're running now (the beta) so you can re-install it if necessary.

    It will be interesting to see whatever happens!
     
  12. raydon

    raydon Well-Known Member

    Correct af123, The non-standard System ID is somehow tied into portal access to Sky player. Standard system ID does not see the Sky Player option. And reflashing 1.02.07 does not reset the system ID. Beta testers are locked into 80bc.7e01.
     
  13. Tahnks everyone for yr help. I ran humidify on the 1.02.07 firmware like af123 said and that worked fine. It installed on the hummy OK as well :) System info says firmware version is 1.02.07 but ID is still 80BC7E01. Portal still has skyplayer like raydon said :( coz I think its alot slower.
     
  14. af123

    af123 Administrator Staff Member

    Good to know it worked :) At least you're back on the stable firmware for now, apart from whatever modified the system ID.
     
  15. OK lats nite took it all the way back to 1.01.04 then back up to 07. HAd to use humidfy each tiem to get it to load. System id is was always 80BC7E01. Got ftp and portal back with 07 but portal is still skyplayer one.

    hdf info for 1.01.07:

    Blocks: 542
    Model: 4
    System ID: 80bc.7e00

    File Offset Address Type Flags Size Uncompressed Size
    ---- ------ ------- ---- ----- ---- -----------------
    1 0000014 0000000 1 0x80 15680492 15736832 (0.36%)
    2 0ef5ab8 1e00000 1 0x80 1911678 1914272 (0.14%)

    for 1st skyplyer beta:

    Blocks: 556
    Model: 4
    System ID: 80bc.7e00 - 80bc.7e01

    File Offset Address Type Flags Size Uncompressed Size
    ---- ------ ------- ---- ----- ---- -----------------
    1 0000014 0000000 2 0 4 -
    2 0000050 0000000 1 0x80 16085677 16138240 (0.33%)
    3 0f58a45 1e00000 1 0x80 1911729 1914323 (0.14%)

    2nd:

    Blocks: 625
    Model: 4
    System ID: 80bc.7e00 - 80bc.7e01

    File Offset Address Type Flags Size Uncompressed Size
    ---- ------ ------- ---- ----- ---- -----------------
    1 0000014 0000000 2 0 4 -
    2 0000050 0000000 1 0x80 16180944 16236544 (0.34%)
    3 0f6fe8c 1e00000 1 0x80 1911673 1914265 (0.14%)
    4 1142cf5 1a00000 3 0x80 750121 2097152 (64.23%)

    not sure what this all means tbh.
     
  16. raydon

    raydon Well-Known Member

    betablocker, I've PM'd you with a link to an hdf which will reset your system ID.
     
  17. cah1982

    cah1982 New Member

    im having same issue could you please fwd me the hdf file so i can then upgrade to FHTCP1.02.20
     
  18. af123

    af123 Administrator Staff Member