1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem trying to ftp files back to PVR

Discussion in 'HDR-FOX T2 Freeview Recorder' started by Bobcoa, Jan 4, 2012.

  1. Bobcoa

    Bobcoa New Member

    I need to copy some HD files prior to sending my box back to Humax for replacement (the indicator "deleting" shows continuously in the media window). I have followed Black Hole's Trail Guide and successfully connected my Windows PC to my 1TB HDR-FOX T2. However, I cannot write back the .hmt files to the PVR after using Foxy.
    All files and directories on the PVR restrict write permissions to owner only. When I try to alter them to give write permissions to group and to public it is rejected "server does not support changing file permissions". Having searched these forums and the web I can find no explanation of how to overcome this.
    Could someone advise if I am missing something obvious or is it a "feature" of Windows.
    I am loathe to try the custom firmware route as I assume it may affect my warranty.
     
  2. af123

    af123 Administrator Staff Member

    You should just be able to send the .hmt files back via FTP - don't worry about the permissions, the FTP server is able to write to any file. How are you trying to send the files back, and what's happening when you try?
     
  3. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Several people have reported that this can be fixed by downgrading the software to version 1.01.09 (before background delete was implemented) booting the box and checking that the permanent delete has gone and then reinstalling 1.02.20.
     
  4. Bobcoa

    Bobcoa New Member

    Thanks for the swift responses.
    Yes, I had seen the reversion to earlier firmware advice but I have tried it twice: once going back to 1.01.09 which did cure the deleting sign but going up to 1.02.20 merely brought it back. The second time I tried a two-stage upgrade via 1.02.07 but with the same result.

    With regard to the FTP, I have an Ethernet cable link between my PVR and laptop pc.

    When I used Windows Explorer I received “451 action aborted” if I tried either drag&drop or copy&paste.

    I tried FTP Commander but if I tried to “upload” I had crossed circle and it dropped out of the server. I tried drag&drop from Windows Explorer but action refused showing a crossed circle. Copy did not work as there is no paste option in FTP Commander.

    In Godzilla if I upload the transfer or drag&drop it fails with messages “file transfer failed” and “connection severed by server”. A similar result if I drag from Windows Explorer.
     
  5. af123

    af123 Administrator Staff Member

    The FTP server that's built into the Humax firmware is truly awful. It only supports limited parts of the FTP protocol and it is littered with bugs that cause it to crash (transfers get aborted). With the FTP clients you've tried, make sure that they are configured to use active mode only - sometimes that's achieved by turning off passive mode (sometimes shown as PASV mode).

    If you're able, try using the Firefox browser with the FireFTP plugin, again ensure that you are using active mode.
     
  6. Bobcoa

    Bobcoa New Member

    Yes, I had set connections to active mode.

    I have tried your suggestion of FireFTP but with little success. It only connects intermittently and then falls over with syntax errors if I try to access the file folders on the Humax, I do not even get to see the files listed.

    My machine is Windows XP so I borrowed a Vista machine. The only difference is that the Windows Explorer FTP will only allow me to access the Humax with the Media Player. I still cannot write files back to the Humax.

    Thanks for your suggestions. I guess I have one mixed-up Humax and shall have to be glad that the majority of my files were SD so have been copied.
     
  7. jack616

    jack616 Member

    For info I have done this repeatedly with the latest firmware (1.02.20)
    I use Filezilla for FTP set to auto - however I have noticed in the past that filezilla became confused between binary and ascii files on specific files (but not humax ones so far)
    It may be worth just manually selecting binary transfer in your FTP software if you can. and make sure encryption is off if your client does this.