1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with custom firmware

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by masai, May 13, 2012.

  1. masai

    masai New Member

    Hello,

    I cant seem to use the custom frimware on my HD-FOX T2 box and would appreciate some help please.

    I am using:

    software version KZTFT 1.02.20
    Loader version L7.26
    Custom firmware version HD_FOX_T2_1.02.20

    I have installed the custom firmware from my 1gb usb stick and that was all ok, I got the End message on the front display and Success Downloading! on the TV.

    I then followed the instructions and disconnected the usb stick and inserted my 750GB external hard drive (formated in EX2 using GParted live CD) but when I enter the box's ip in my browser nothing happens.

    What am I doing wrong? The hard drive is fine, been using it with the box for a couple of months without problem.

    Thanks in advance!
     
  2. masai

    masai New Member

    Just to add...

    I have re-flashed with the usb stick and have re-booted leaving the usb stick in and I still cannot access the box by ip on my PC. The box can access iPlayer without problem so don't think its a network issue.

    Have tried accessing using Firefox and IE9
     
  3. Black Hole

    Black Hole Felonius Gru

    Sounds like you've done everything right. Are you sure about the IP address?
     
  4. masai

    masai New Member

    i think so!... Have verified from settings on the box and it tells me its 192.168.1.4
    Ive given it a static IP and by DHCP and no difference.

    does the memory stick have to have 2gb free? The stick I used was a 1gb with nothing on it except the firmware. I got the success downloading! message on the screen. I tried with a couple of 16gb memory sticks but the box refused to load the firmware from them, they were formatted in fat32 but had other files on them, but still over 2gb free.

    In theory, once firmware is successfull using the memory stick, can I just plug in my 750GB hard drive (formatted in EX2 Of cause) and the custom firmware will still be applied?

    Thanks!
     
  5. Black Hole

    Black Hole Felonius Gru

    You load the custom firmware the same way as you load a normal firmware update. Once it has been seen to install on the TV panel - that's it.

    What you now have are the core "hooks" that are required to go on and load the full package onto whatever you are using for storage (UPD formatted Ext2 or USB HDD formatted Ext3 - typically using the Humax to format it). What you should see when you connect with a browser is the "Install" web page which downloads the rest - see the Wiki HERE (click).
     
  6. masai

    masai New Member

    Is there any way I can tell if the custom firmware is in fact loaded?
     
  7. xyz321

    xyz321 Well-Known Member

    Not with the 1.02.20 based firmware (later versions display the version number on the front panel display at startup).

    How are you connecting it to your network (cable or wireless)?
     
  8. masai

    masai New Member

  9. Andrew Benham

    Andrew Benham Member

    If the custom firmware is loaded, there'll be daemons listening on ports 23 and 80 which weren't there before.

    Try telneting to those ports, or run nmap (http://nmap.org/) on another machine on the LAN.