• The forum software that supports hummy.tv has been upgraded to XenForo 2.1!

    This upgrade brings a number of improvements including the ability to bookmark posts to come back to later. Please bear with us as we continue to tweak things and open a new thread for any questions, issues or suggestions in Site/Forum Issues.

Problem with detectads

MymsMan

Ad detector
Frankly I never use and don't understand time slip recordings and DetectAds has never been tested to be run with them,
How did you create the time slip recording and invoke detectads? It appears you are running in chaserun mode on an encrypted file.

Running in traditional mode with a complete decrypted ts file is most likely to succeed since that is the environment nicesplice was designed to run in
In chaserun mode cropping is running in parralel with decryption and there isn't a complete ts file for nicesplice to scan for the timeslip offset.
I have no idea how ad detection would actually work on a time slip recording since ffmpeg (AFAIK) and Silence have no concept of time slips

Unless there is a good reason for needing to be able support them I would rather just say timeslip recordings are not supported by DetectAds
 

Matthew

Member
On switch on today I have the following message:

11/01/2019 04:39:03 - DetectAds: Contents sharing disabled, Enable via Humax Settings menu (24 instances)
11/01/2019 09:19:10 - DetectAds /mnt/hd2/My Video/Food Unwrapped/Food Unwrapped_20190111_0334.ts Incomplete data retrieval 1223766016 bytes missing (00:27:40)
11/01/2019 09:19:10 - Retry limit exceded for /mnt/hd2/My Video/Food Unwrapped/Food Unwrapped_20190111_0334.ts cant process file
So it would appear your change has been successful in preventing the stuck file problem. :thumbsup:
Unfortunately the boot settings package has not worked properly, it seems to have just made the webif 'think' Contents sharing was back on when still off, hence the read error at 09:19 and the 'Contents sharing off' message did not appear on the file browse page either, I still had to go into the box menu and turn it back on! and then reboot before the file could be processed OK.
 

Matthew

Member
I have an odd problem, not sure when it happened as not used DetectAds 'Manual' mode for a week or so.

Running DetectAds in manual mode gives 'Internal Server Error', error log just shows mod_cgi.c.1098: aborted auto log has no entry.
Running DetectAds as a background task works fine.

I`ve tested with my modded file and the original, same error.
 

Luke

Well-Knwοn Мember
Running DetectAds in manual mode gives 'Internal Server Error', ...
Running DetectAds as a background task works fine.
Snap. On both HDR-FOX T2s I've tried. Was probably bout three weeks ago that I last tried paint drying mode and it was working.
 

MymsMan

Ad detector
Running DetectAds in manual mode gives 'Internal Server Error', error log just shows mod_cgi.c.1098: aborted auto log has no entry.
Running DetectAds as a background task works fine.
Is there anything in the webif-error.log.
 

Matthew

Member
Found a bug!

Manually running DetectAds on any file in a folder named Jamies Quick & Easy Food fails with a blank screen, error log shows

Code:
    /mod/webif/plugin/detectads/web/index.jim:17: Error: invalid command name "0"
    at file "/mod/webif/plugin/detectads/web/index.jim", line 17
Running DetectAds as a background task works fine, except the desired file is a time slip recording so that fails for a different reason.

Renaming the folder Jamies Quick Easy Food stops the error.
 

/df

Active Member
Found a bug!

Manually running DetectAds on any file in a folder named Jamies Quick & Easy Food fails with a blank screen, error log shows

Code:
    /mod/webif/plugin/detectads/web/index.jim:17: Error: invalid command name "0"
    at file "/mod/webif/plugin/detectads/web/index.jim", line 17
...
This problem was reported by @Raydon and further diagnosed in my reply to that post. I've raised the issue in the Webif 1.4 thread.
 
Last edited:
Top