Problem with latest Firmware 1.03.12


New Member
My HDR Fox T2 has been working fine using V1.2.32 firmware.
My unit updated OTA to V1.3.12 a couple of days ago and I can no longer use the TV Portal.
After selecting TV Portal it say's its loading and goes no further.

Revert back to V1.2.32 firmware and all is good again. Reloaded V1.3.12 this morning and still no TV Portal.

I have also tried a factory reset with the latest firmware but no joy, still no TV Portal.

Anyone else having this issue?

Should be OK, 1.03.xx uses a new version of the TV Portal app browser and accesses the new slick iPlayer interface.
That's nice to know but it doesn't seem to work on my unit. Back to V1.02.32 until I find out why.
As far as I know the unit is not using any custom firmware.
If you had at some point installed the custom firmware version of the TV Portal, that would be enough to stop the updated standard firmware portal working (even though the standard firmware update overwrites the custom firmware).
From 1.02.32 install CF2.23 for 1.02.32 (click), then complete the installation by connecting to the Humax's IP address from a web browser. Once properly installed connect with the web browser again and go to the Diagnostics page where you will find a "Set Return-to-manufacturer (RMA) Mode" button. Click it, and when it's done its thing install official 1.02.32 (or even 1.03.12) again.

This process is set to become a little easier next revision of the CF (but using Telnet rather than a web browser). Alternatively somebody might be along with a better suggestion.