Problem with replacing disk


New Member
I have tried to replace an internal 1Tb disk in a Humax Fox T2 that has been giving problems with a Seagate Pipeline 500GB disk (the same model is in another Humax Fox T2 I have) that had been formatted for a PC. I have tried many different ways of reformatting this disk but when it is placed in the internal disk position it is not recognised by the Humax and the Humax thinks it has no disk.

I have attempted to format it as a USB connected disk - this works to a degree but only as a USB connected media disk and is not recognised when put in the internal position

I have used mini-tool partition to delete all partitions and create an ext3 partition - still not recognised.

I have written zeros to the complete disk and repeated the ext3 creation - still not recognised.

For the moment I have given up and put the old still working 1TB disk back in - but in the long run I am determined to find out how to over come this issue - anyone offer any advice?
I'd let the Humax partition it. It expects 3 ex3 partitions to be present.
Give the disk a straight-forward NTFS format in a Windows machine, then fit it. When you power the Humax up the first time after the disk is fitted, it should recognise the existence of a new drive and pop up a message offering to format it. If it doesn't do that, try looking on the Menu >> Settings >> Data Storage >> Storage list - if it's not there either, there must be something physically wrong with the disk.
You missed the bit about not recognisng the disk - I do not get as far as being given the option to format the disk because Humax thinks none is connected.
Having it in NTFS format was the starting point - Hunax did not think it was connected. The disk intialised fine when connected via USB but only as a media disk.

PS I am using customised versions of Humax software.

Currently I am using

Web interface version: 1.3.2-10

Custom firmware version: 3.10 (build 2734)

Humax Version: 1.03.12 (kernel HDR_CFW_3.10)

Loader Version: a7.31

Would you recommend the HDR_ FOX_T2_1.03.12 - (13/03/2016) download?
I doubt if it is kernel related. The HDR-FOX will reformat an internal disk that is already formatted with three ext3 partitions (i.e. as formatted by the unit) or if the disk is unformatted. You could take the disk out of the unit, connect to a Windows PC (USB caddy or adapter) and use the disk management console to delete all partitions and change the disk space to unallocated. Then reinstall in the HDR-FOX and try again.
Or you could leave the disk in the unit, enter maintenance mode and try formatting with the 'gptf' function. If this works, this will give you a drive with a GPT partition table (not necessary for a disk below 2TB). I don't know if there is a downside to a GPT table on a smaller disk. The upside is that this function formats the recording partition for large files. This has only 1/64 of the number of inodes which makes fixdisk much quicker. If it does work you could always then reformat using the remote control handset if you don't want a disk with GPT.
I have tried deleting all partitions and that does not work. I cannot format the disk in the unit as the Humax does recognise the existence of the disk when connected internally. It only recognises the disk when connected via the USB (with the disk in a disk caddy).
You missed the bit about not recognisng the disk - I do not get as far as being given the option to format the disk because Humax thinks none is connected.
No I didn't, and because this is posted in the vanilla section of the forum I assumed you were using standard firmware.
After further testing I have come to the conclusion that the disk which is not recognised by the Humax Fox T2 has some problem with it.
I have tried installing 2 other NTFS formatted disks and both are recognised by the Humax though I did not go so far as to intialise them as they are used for other purposes.
The problem must be very deep seated in the unrecognised disk as I have intialised it repeatedly, reformatted it and placed new partitions on all to no avail.

The two extra disks that were recognised were a WD Greeen 1TB WD10EZX and a WD Blue 320GB WD3200BPVT (the latter came from a laptop that was ungraded to an SSD).

All this was without changing the firmware to the standard version.

Unless anyone has anything further to add I am happy to close this thread and use the disk for something else and note the experience for the future though that will leave hanging the question concerning the firmware.
It could well be and certainly worth trying the k release. It's rare but we have seen a couple of reports of disk initialisation problems with the custom kernel.
I would still try it. I know there have been some issues with WD disks in the past but have problems with a (non-faulty) 500 GB Seagate Pipeline ever been reported before? I had issues with a Seagate Pipeline ST2000VM003 (2 TB) but that was found to be faulty, the replacement was fine. It would be useful to know the model and firmware version of the disk in question. I think that the 500GB factory-fitted Pipeline model is ST3500312CS with firmware SC13. If the disk has an older version of firmware it may be possible to update it: see here.