PVR not working as normal


New Member
Since yesterday, the box has not been acting normally. It didn't record anything last night, the media button is continuously "deleting" a show.

So far, I've tried:
  • full power off and on via the button on the rear, still the same.
  • running the general diagnostic, all pass
  • running 'fix-flash-packages' it seems that the filesystem is read-only
I tried to update the packages through the web interface and got the following:

>>> opkg install Collected
Unknown package 'Collected'.
Collected errors:
* opkg_install_cmd: Cannot install package Collected.
* opkg_finalize_intercepts: Failed to open dir : No such file or directory.
* rm_r: Failed to open dir : No such file or directory.
* rm_r: Failed to open dir : No such file or directory.

Help!, any ideas?
Most likely your disk has gone read-only due a filesystem error.

You first need to install the custom firmware and then run the fix-disk process which involves accessing the box using telnet (http://wiki.hummy.tv/wiki/Telnet) and entering the system PIN (0000 unless you have changed it). You'll get a menu and need to choose option 1 (restart into maintenance mode). Once the system has restarted in maintenance mode you telnet in again and choose option 1 from the new menu (Check and repair hard disk (fix-disk)).

That should run a full disk check and repair any problems.
Ok, RTFM, I tried the fix on the wiki, deleting /mnt/hd1/filebglastop.dat - seems to be working as normal again,

That may not be a full fix - it's likely there is some corruption on the disk that needs fixing. Sounds like you already have custom firmware though which makes the rest easier!