1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Read/Write Permissions..?

Discussion in 'HDR-FOX T2 Freeview Recorder' started by topcat888, Jan 26, 2012.

  1. topcat888

    topcat888 New Member

    Hi,

    Could anyone help me work out a little problem I've got with the external hard drive that I have connected via the usb to the HDR FOX. The problem being is that whilst it is seen as 'drive1' I can't rename it, add a new folder or indeed upload files to it..? I have noticed that the only permissions set on the drive are 'Owner Read and Execute Permissions', no others including the all important 'Write'. I have tried, via ftp, to change the permissions on the drive but ftp just returns the error "550 Requested action not taken"... Presumably because it doesn't have permission to do that.!

    Is there a way through telnet to send the new permissions to the drive or even to take ownership..??

    Thanks
     
  2. af123

    af123 Administrator Staff Member

    Is it by any chance formatted as NTFS? The stock Humax firmware can only read NTFS and not write to it. Using FAT32 of EXT2/3 gives you read/write.
     
  3. topcat888

    topcat888 New Member

    ahh yes it is... I formatted the drive as ntfs (via windows before hand) and downloaded the ntfs-3g package hoping to be able to read/write to it....

    I also tried HDR's internal format command but it just hung, presumably because it's over 1tb..?

    I guess the only way to format it now is by using GParted..?

    Thanks
     
  4. Black Hole

    Black Hole Felonius Gru

    ntfs-3g should have done what you want. Something wrong.
     
  5. topcat888

    topcat888 New Member

    If I go down the road of formatting using GParted, what should the drive be formatted as ext2, ext3, fat32..??

    Thanks
     
  6. Black Hole

    Black Hole Felonius Gru

    Depends what you want to do. FAT32 won't accommodate big video files (>4GB). Ext3 will, but isn't directly accessible from Windows. Ext2 is specifically preferred for Flash drives. I would persist with NTFS.
     
  7. topcat888

    topcat888 New Member

    ok will persevere, thanks...
     
  8. xyz321

    xyz321 Well-Known Member

    It should appear as /media/usb-drive2 when mounted by ntfs-3g, if not it is still being mounted by the standard driver. The permissions should be wide open and can not be changed using the standard chmod command.

    If you can, try typing 'mount' in a telnet session and post the results here.
     
  9. topcat888

    topcat888 New Member

    It didn't appear as /media/usb-drive2 so something must have gone wrong...

    Anyway, I used GParted to format the drive to Ext3, then reattached the drive to fox's usb port. The drive now shows up as 'drive1' going through media/storage and is accessible/transferable to using ftp...

    Sometimes it shows up as a samba drive as well but then goes again, the disappearance seems to coincide with the use of ftp ..? Either way the drive is there for use from the unit and I can transfer, albeit not very fast, video to the drive via ftp, guess that's job done... Just out of interest is there any reason why the drive set-up as ntfs would be better than the way I did it, out of interest..?
     
  10. Black Hole

    Black Hole Felonius Gru

    Only in as much as you could connect it straight to a PC and transfer directly.