Redring Doesn't turn amber (changed by popular demand from red to amber)

Trev

The Dumb One
Sometimes when I look at my T2 first thing in the morning, the redring is dim blue but all other indications are that it's off, but not sure whether the HDD is running or not. Toggling the power always fixes it. I have Disable OTA schedule for 4:20 which is presumably what's waking it up. Any ideas? Latest Redring log for your perusal.
Code:
214 [RR] Thu Jul 2 12:58:37 2015: Standby ring dim detected.
213 [RR] Thu Jul 2 12:58:34 2015: Changing to dim blue.
212 [RR] Thu Jul 2 12:58:34 2015: Ring trying to go amber.
211 [RR] Thu Jul 2 12:58:34 2015: Standby ring dim detected.
210 [RR] Thu Jul 2 12:58:33 2015: Standby ring dim detected.
209 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
208 [RR] Thu Jul 2 12:58:33 2015: Persistent log starting, v2.17
207 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
206 [RR] Thu Jul 2 04:40:05 2015: Standby ring dim detected.
205 [RR] Thu Jul 2 04:40:03 2015: Changing to dim blue.
204 [RR] Thu Jul 2 04:40:03 2015: Ring trying to go amber.
203 [RR] Thu Jul 2 04:40:02 2015: Standby ring dim detected.
202 [RR] Thu Jul 2 04:40:02 2015: Standby ring dim detected.
201 [RR] Thu Jul 2 04:20:02 2015: Ring going blue, full boot.
200 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
199 [RR] Thu Jul 2 04:20:02 2015: Persistent log starting, v2.17
198 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
197 [RR] Wed Jul 1 23:47:50 2015: Standby ring dim detected.
196 [RR] Wed Jul 1 23:47:48 2015: Changing to dim blue.
195 [RR] Wed Jul 1 23:47:48 2015: Ring trying to go amber.
194 [RR] Wed Jul 1 23:47:48 2015: Standby ring dim detected.
193 [RR] Wed Jul 1 23:47:48 2015: Standby ring dim detected.
192 [RR] Wed Jul 1 23:46:57 2015: Play icon off.
191 [RR] Wed Jul 1 23:02:24 2015: Play icon on.
190 [RR] Wed Jul 1 23:01:53 2015: Play icon off.
189 [RR] Wed Jul 1 22:21:01 2015: Play icon on.
188 [RR] Wed Jul 1 22:14:13 2015: Play icon off.
187 [RR] Wed Jul 1 22:03:21 2015: Play icon on.
186 [RR] Wed Jul 1 21:02:17 2015: Recording end 26.
185 [RR] Wed Jul 1 21:02:17 2015: REC icon off.
184 [RR] Wed Jul 1 19:59:03 2015: REC icon on.
183 [RR] Wed Jul 1 19:59:03 2015: Recording 1
182 [RR] Wed Jul 1 19:59:03 2015: Recording start 26:'/mnt/hd2/My Video/The Auction House_20150701_1959.nts'
181 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
180 [RR] Wed Jul 1 19:59:03 2015: Persistent log starting, v2.17
179 ed Jul 1 19:59:03 2015: Ring going red.
178 [RR] Wed Jul 1 19:59:03 2015: Persistent log starting, v2.17
177 [RR] Wed Jul 1 08:32:30 2015: Standby ring dim detected.
176 [RR] Wed Jul 1 08:32:28 2015: Changing to dim blue.
175 [RR] Wed Jul 1 08:32:28 2015: Ring trying to go amber.
174 [RR] Wed Jul 1 08:32:28 2015: Standby ring dim detected.
173 [RR] Wed Jul 1 08:32:28 2015: Standby ring dim detected.
172 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
171 [RR] Wed Jul 1 08:32:28 2015: Persistent log starting, v2.17
170 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
169 [RR] Wed Jul 1 04:40:04 2015: Standby ring dim detected.
168 [RR] Wed Jul 1 04:40:03 2015: Changing to dim blue.
167 [RR] Wed Jul 1 04:40:03 2015: Ring trying to go amber.
166 [RR] Wed Jul 1 04:40:01 2015: Standby ring dim detected.
165 [RR] Wed Jul 1 04:40:01 2015: Standby ring dim detected.
 

Ezra Pound

Well-Known Member
You need to determine if the 'dim blue' is being displayed in error even though the Humax is in standy or whether it is correct and the humax is in the Half-Awake state. The former is Redring getting it wrong for some reason and the latter is due to the Humax not being able to shut down properly, the WiKi Notes HERE will help sort out whether the unit is in the Half Awake state and what might be causing it
BTW
Your thread title should read 'Redring doesn't turn Amber' rather than red, red is only used when the unit is recording
 
Last edited:

Owen Smith

Active Member
RedRing has never been 100% reliable with the colour changes for me. Blue when it should be Amber for standby is the most common fault, but I've seen others. It is much better than it used to be after af123 made a number of changes to it. I've just accepted it won't ever be 100%, at least it always shows Red or Purple when recording so I know not to do anything that would kill the power.
 
OP
Trev

Trev

The Dumb One
Thanks for the reply Ezra.
In the 'half awake' state, should I be able to access the web I/.F? Whilst I have the dim blue, I can't do that and it seems that everything is 'dead' although, as the HDD is so quiet, I can't tell if it's spinning or not.
Looks like dim red amber to me when it's properly off. But what do I know?:)
@Owen. I have also been ignoring it for some time now, as otherwise the box seems to be behaving OK.
 
Last edited:

Black Hole

May contain traces of nut
In the half-awake state there will still be power on the USB ports (amongst other things). If you have an external drive and it is on power, the box is not shut down.
 

Owen Smith

Active Member
I check the ethernet socket on the back, if the lights are on then the HDR Fox T2 is half awake. This is with wired ethernet in use, wouldn't work for wifi.
 
OP
Trev

Trev

The Dumb One
I'll check the network socket next time it does it. Thanks.
Easier still, for me, check the network switch for activity on the T2 port:)
 

Ezra Pound

Well-Known Member
Thanks for the reply Ezra.
In the 'half awake' state, should I be able to access the web I/.F? .
Here is the table that is in the WiKi :-

The Humax can be in 3 distinct powered states, they are :-
  1. Standby = hard disk not spinning, No TV output, DLNA Server inactive, LAN inactive, No USB power
  2. Half Awake = hard disk spinning, No TV output, DLNA Server inactive, LAN active, USB power on
  3. Awake = hard disk spinning, TV output, DLNA Server running, LAN active, USB power
 

MikeSh

Well-Known Member
RedRing has never been 100% reliable with the colour changes for me. Blue when it should be Amber for standby is the most common fault, but I've seen others. It is much better than it used to be after af123 made a number of changes to it. I've just accepted it won't ever be 100%, at least it always shows Red or Purple when recording so I know not to do anything that would kill the power.
Ditto.
If ours are in any kind of awakish state the light on the USB wifi devices will be flashing irregularly as it communicates.
 
OP
Trev

Trev

The Dumb One
BTW. Your thread title should read 'Redring doesn't turn Amber' rather than red, red is only used when the unit is recording
Well pardon me for my ignorance, but it sure looks dim red amber to me when it's off.:);)
 
Last edited:

Ezra Pound

Well-Known Member
Trev : Well pardon me for my ignorance, but it sure looks dim red to me when it's off.:);)
Are you sure it's not dim amber when it's off :)
Using 'Amber' just ties in with your Redring listings, e.g.
Code:
212 [RR] Thu Jul 2 12:58:34 2015: Ring trying to go amber
 
Last edited:
OP
Trev

Trev

The Dumb One
I don't know whether it's dim amber or dim red. I haven't got a colour chart handy.:D But entry 213 says:
213 [RR] Thu Jul 2 12:58:34 2015: Changing to dim blue. Which is what it was when I looked at it first thing in the morning.
I'll wait until it does it again and check out the network activity.
 

Ezra Pound

Well-Known Member
Trev : I don't know whether it's dim amber or dim red. I haven't got a colour chart handy
The point is the 'Ring' shows no colours at all when the unit is 'off'. Unless your unit is incapable of displaying amber (which is pretty unlikely), then you are mistaking amber for red, they are quite similar when you don't have both colours to compare

The 213 line is normal operation, Redring changes to dim Blue when starting the 'going into standby' routine, however, although Redring tries to log a 'changing to amber' message before the 'ring' goes to amber, this message rarely gets stored in the log because the unit has gone into standby before this can happen. In other words, your Redring log is not showing an error
EDIT
I have logs going back for quite a while and over an 8 Month period my log contains 369 'Ring trying to go amber', but only in 19 cases is this message followed by 'changing to amber', during this period I have only seen an incorrect dim blue maybe 2 or 3 times, so the absence of this second message does not indicate an error
 
Last edited:

MymsMan

Ad detector
I find the activity.log helpful when checking whether the system is stuck in half-awake state
Code:
02/07/2015 09:44:53 - System booted (Remote control handset).
496 02/07/2015 04:17:39 - System booted (Scheduled event).
The booted message will be missing if the system is already half-awake
 
OP
Trev

Trev

The Dumb One
then you are mistaking amber for red, they are quite similar when you don't have both colours to compare
Ok, Ok, then I'm mistaking amber for red, but I can't understand WTF are you making such a big deal about it. OK, it's normally dim amber, but sometimes it's dim blue. The log seems to point to the fact that it is mostly dim blue, but it isn't. It's mostly dim amber.

@ Owen. Thanks for your constructive posts @ No. 3 and No. 6. That'll do me nicely. (Unless I really do have a problem, not just redring miss-behaving, then I'll be back.)
 

Black Hole

May contain traces of nut
I think the issue is about accuracy of description so as not to cause confusion for subsequent newcomers. If you describe amber as red and then somebody who doesn't know any different assumes you really mean red, misinformation results.
 

hairy_mutley

Active Member
I had assumed that the button only had 2 LEDs; red and blue? Hence the only colours availabile are those between red and blue on the colour wheel (e.g. purple), any of which can be made dim. Amber would require an additional led to contribute some green.
 
Top