Resetting the box?


New Member
When we bought the Mocha, it came with the RM-L08 remote. It never worked. it was a fight to get it to respond when the buttons were pushed, it only worked if pushed in the upper portion of some buttons, the side on the others. We really should have returned it, but we had a new aerial and the installer brought his along, a RM-L03. It was totally responsive and we ordered one of them. All was good for a few months.

Last night,m all of a sudden the picture went. The sound was fine but the screen was black. The other Smart TV apps (like Netflix and NOW TV) worked fine, just the Humax display was dark.

Neither remote worked. On both, when pressing the on button, it lit up but nothing happened. Even pressing the button on the box, to switch it to standby, did nothing. The channel would not change, the guide would not come up, NOTHING but volume up/down.

New batteries make no difference (didn't expect they would but I had to try)

I have now unplugged it a left it unplugged to see if it will reset itself. (left it off for 20 minutes or so and no change when plugged back in again)

Any thoughts? What is the process for sorting it out? Is there a reset code of some kind?

I believe it is a style name
I had to google, but now I know "Mocha" is the colour finish. Also comes in Cappuccino. Call it an FVP-4000T and everyone will know what you are talking about.

Ref the handset, do a few checks as suggested here: Things Every... (click) section 13.
I actually called Humax. Spoke to a rather rude guy, but he did walk me thru the process, once I got him to shut up and listen to what I was describing.

Apparently "modern" TVs try to exert some control over things via the HDMI cable. He said they have their own HDMI CEC.In order to make the two things (Humax box and TV) work in sync, the TV Power Control has to be set to ON. (apparently in my LG, the default is OFF)

The process I followed was to first give the Box and Remote their own "frequency" (his words):

Press OK and 0 (zero on the number pad) for 15 seconds (he said. it took maybe 3 seconds)
A prompt to Change Remote Code comes up - he said press 3

Then to turn on the HDMI CEC in the Humax Settings:

Home/Freeview Play button > Settings > System Settings
Select TV Power Control and toggle ON
Press Exit on remote

He also said that there should never be a reason to go thru this process again and if there was, it would be a fault with the box

Sorry if this is covered elsewhere, but I figured it was worth laying out the info while it was fresh. Hope it adds the the knowledge base :)
and I did check your link. The process I describe would seem to address this bit Perhaps it is a simple fix for this:

However, there is just a possibility that CEC commands being sent down the HDMI cable from a CEC-capable TV might interfere with the Humax handset, so as a last resort see if there is any difference with the Humax connected by SCART instead (disconnect the HDMI). If this solves the problem, try connecting the Humax to a different HDMI input on the TV, and/or look for something in the TV menus to turn off CEC (which goes by a variety of proprietary names).
Changing the command set for the Humax is unlikely to have been the solution - all you have done there is prevent the FVP-4000T handset cross-controlling another Humax box by putting it on another "channel".

The rest of the instructions set out to configure CEC to work properly between the TV and the Humax - you might still find you prefer to turn it off completely.