Resolving HDR-FOX Crash/Reboot Issues


New Member
Working through the Steps for Resolving HDR-FOX Crash/Reboot Issues thread, I'm drawing a blank now so would appreciate some advice

OK - just realised I missed a step further down, will come back when I have done it, unless I can work out how to delete this post...

(edited for formatting)
Last edited:
If the crashes don't stop, even after you have got to the end of the diagnostic steps by disconnecting the hard drive, you're stuffed (with the possible exception of replacing the front panel assembly and/or PSU). There's really nothing else to offer (if there was, it would have been added to the list already).
At step 2E, it appears that FixDisc does its own thing and works through the disk.

There's a page of Telnet output after pressing Y which appears to be various processes starting and reporting completed OK
The only diagnostics seem to be: On the section of the scan it reports
hmx_int_stor: ***** FILE SYSTEM WAS MODIFIED ****
hmx_int_stor : 6979/121380864 files (5.4% non contiguous), 201498055/485492331 blocks
with similar reports for smaller numbers of files for sda3 and sda1 without the ***** FILE SYSTEM WAS MODIFIED **** comment.

Is that OK or is there some further output somewhere I need to be looking at?

Or is it simply if crashes stop its worked, if not, move to 2F...
Last edited:
Indeed, fix-disk gets on with the job and may occasionally ask for input. You do need to keep the Telnet session open all the time - that's where output appears, and fix-disk terminates if you close the session.
Thanks Black Hole.

I was editing to add the one bit of diagnostics at the same time you posted your reply, I think.

Do those diagnostics indicate anything to be concerned about? (Modifying the file system sounds reasonably major to a not particularly technical person, but maybe that's just terminology)

Yes, I kept Telnet open and it reached the end overnight, just asking if I was getting a delete loop, which I wasn't.
It looks like the filesystems are all OK, which is good. So that probably wasn't the cause of your crashes, which means it's something else, which is not so good.
Don't know if this helps at all but my HDD has also been crashing a lot the last few days. I've been away from these forums for a while so I may have missed something but my diagnosis so far is the disk seems fine and the crashes happen most often when left on More4 but not exclusively.
Yep sorry guys, meant HDR - bad day on the keyboard.

It's been slightly better the last couple of days but I have been trying to avoid leaving it on More4.
If these are still crashing after following all of the steps in BH's guide, then install the crashdiag package and reboot.
After the next crash, run the crashdiag diagnostic from the web interface and post the results. That should provide a clue to where it is crashing.
Thanks af123. I was just at the point of giving up on my HDR-Fox-T2, as it passed all the tests in BH's guide, except perhaps the one about the fan, but still crashes.

Couldn't be sure about the fan as it crashes within 30-40 mins of reboot (when watching Live TV or a recording) so I wasn't sure whether the fan would even have kicked in.
OK - should crashdiag appear in the dropdown list on the web interface diagnostics page? Or do I need to go somewhere else?

It's not in the dropdown list, but is in the installed packages list, and appeared to install OK
No, you'll need to type it into the text box on that page. It won't do anything until there has been a crash.
Thanks - this is what I get

>>> Beginning diagnostic crashdiag

Running: crashdiag
No core directory.

>>> Ending diagnostic crashdiag

I've had 1 crash since I installed it, but I'm guessing this means I've made a mistake somewhere
Yep sorry guys, meant HDR - bad day on the keyboard.

It's been slightly better the last couple of days but I have been trying to avoid leaving it on More4.

For what it is worth I think I have resolved my crashing issue. It turns out my network was badly configured, I switched router a couple of weeks ago and, although I have manual IP address configuration the same on both I forgot that the default route is different (I give the routers different IP addresses to avoid confusion with the control panels). I forget that would mean changing the default route on the Humax so, although it thought it had a network and I was able to access it on the LAN including streaming things to other devices it could not connect out to the internet. I noticed when I tried to use iPlayer on the Humax.

As I have seen before there is something on the CH4 channels that crashes if it thinks it has internet but is unable to reach the world outside. I have seen this before when BB is down but that was obviously not the case this time.
Well, to be honest I couldn't find the thread referred to - the search doesn't seem to work. I guess I should have tried harder to find it. I read 'Things Every...' again and googled but didn't spot it.