1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Samba shares

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by m0nk3y, Nov 5, 2011.

  1. m0nk3y

    m0nk3y New Member

    Sorry, I just can't seem to find the answer...
    Been trying to connect to the hummy via the iPad using SMB to enable to copy files off. If I try to connect I get prompted foy a username and password and I've tried all the combinations inc guest. This is to the Samba client as per the web portal and package manager. Sorry if I'm being stupid.

    M
     
  2. Trevor Jasper

    Trevor Jasper Member

    Have you tried the default name of " humax" and password of the box PIN - usually "0000"?

    Worth a punt.
     
  3. m0nk3y

    m0nk3y New Member

    Hi Trevor, yes tried that combination too. Only think I'm missing something though I have searched. Someone else asked the same question without reply....
     
  4. Black Hole

    Black Hole Felonius Gru

    The only other member I know of using an iPad is 4291, and I'm pretty sure he has not got into network file shares. Are you sure iOS is compatible? There are two other network sharing protocols to try (or possibly one - I think one is a development of the other).
     
  5. 4291

    4291 Well-Known Member

    Can't help there I'm afraid. I don't have Samba or Cifs installed or anything else needed for file transfer.

    I don't think I can set up file sharing on the HDFOX T2.
     
  6. Dan

    Dan Member

    Are you using Buzz player? If so - I'm afraid I can't offer you any help other than to say I've been having the same issue so you are not alone!
     
  7. raydon

    raydon Well-Known Member

    The user name for samba is "root" with a zero length password. If that doesn't work then you can change it from the command line by entering "smbpasswd root" You will then be prompted for a new password, and again for confirmation. Enter "smbpasswd -h" for a full usage list.
     
  8. xyz321

    xyz321 Well-Known Member

    I think by default the samba server is setup in 'share' mode so it should not need a password but this mode may not be supported by the iPad app. It might be worth trying 'user' mode by changing the 'security' line in /mod/etc/smb.conf from 'security = share' to 'security = user' and then restarting the box.
     
  9. m0nk3y

    m0nk3y New Member

    Cheers Guys got it sorted - yes Dan I am using the Buzz Player and xyz321 you were correct.
    I was able to download programs to the Buzz player but only via UPNP which seemed to take an age. I'm not sure if the hummy was decoding on the fly but it took so long it wasn't really any good. My daughter likes to watch her kids stuff in the car etc and the Ipad is ideal.
    So yes changing the smb.conf to user now allows my ipad to connect via SMB and it tonks the file down as one would expect. I decrypt the file first via the web portal on the hummy and then transfer to the ipad.
    Now this all works fine for Standard def files but having a few issues playing decrypted HD in Buzz player so i'll keep plugging along and see what i can do. I'll report back.

    Thnaks to all for making this product a great device and the mod firmware and packages is fantastic.

    M
     
  10. tridgley

    tridgley New Member

    Hi guys, same problem as m0nk3y above with Buzz Player, but I'm afraid I'm not savvy enough to understand how to change the samba setup from 'share' mode to 'user' mode with the instructions already given. Can someone perhaps explain how to do this in a bit more detail?

    Will changing mode likely affect my access via my win 7 laptop as everything is working fine on there with whatever current settings are and I don't want to 'break' that in trying to make the iphone work?
     
  11. af123

    af123 Administrator Staff Member

    You can use an FTP client on your computer to connect to the Humax and download the file /mod/etc/smb.conf. Once that's done, then open the file in the editor of your choice and find the line that says security = share and change the word share to user. Then transfer the file back to the same place on the Humax and restart the samba service (easiest way is via the web interface if you have that installed).

    As for interopability with your Windows 7 client, it should be ok in either mode.

    I'll see if I can get Buzz to talk to the Samba server as-is though..
     
  12. 4291

    4291 Well-Known Member

    Identifying your hardware in the signature field is catching on, but slooowly. :)
     
  13. m0nk3y

    m0nk3y New Member

    Tridgley
    Yes I got it all sorted using Samba with the advice above. To change the mode easily just use WINSCP for windows and you will be able to browse to the file and change it. You can always change it back as its a text file. WINSCP is just a free tool to Bowes to the files in a Window in Windows rather than command line. Have a go it is easy
     
  14. Brian

    Brian Administrator Staff Member

    All we need now is for those people to use the Correct model details, they are "HD-FOX T2" and "HDR-FOX T2".;)
     
  15. tridgley

    tridgley New Member

    OK... feeling really technologically useless now, I thought I was doing alright up to this point but it turns out my life has been made easy by nice user interfaces and people far cleverer than I!

    My understanding is that Windows explorer can be used as an FTP client so I've tried to get access via that but to be honest I have no idea how to connect to anything via FTP... I've tried typing ftp://'humax ip address' into the address bar and surprisingly getting nowhere, I found some instructions on how to set up an ftp connection in win explorer so followed that, using the ip address as the server name (again out of ignorance for anything to use) and that failed too using 'humax' and '0000' as username and password. Also downloaded WINSCP and tried with the same details again getting nowhere.

    So, I've come crawling back to ask for even more detailed instructions on how to connect to the humax via ftp... I assume I need 'ftp server' turned 'on' in the humax internet settings menu? I tried searching the forum but I didn't really know what I was looking for even... :(
     
  16. Black Hole

    Black Hole Felonius Gru

    Visit Black Hole's Trail Guide in the HDR-FOX T2 section for get-you-up-to-speed basics. The Glossary of Terms will also be a useful read.
     
  17. tridgley

    tridgley New Member

    Thank you. I did read that when I first found the forum but there was so much to take in that I missed the bit about ftp access :)
     
  18. tridgley

    tridgley New Member

    So I was able to find and change the file using your instructions and FTP commander 8.0 (I couldn't see all the folders for some reason with either WINSCP or Windows Explorer) and Buzz Player can now see the humax via samba although it asks for a username and password which I don't know (I've tried humax/0000, root/empty, user/empty) anything I'm missing anyone?

    Additionally the laptop can no longer see the humax, it was originally listed as a 'computer' in my network. How can I make it find it again and save the correct username and password so it just appears there as 'default'(like it used to before)?

    EDIT: root/empty allows me access to my laptop via samba on buzz player so not sure why the same isn't true of the humax, also I've changed the conf file back to share (so I can see it on my laptop again) and I can still see it on buzz player, just can't log in to it...
     
  19. Black Hole

    Black Hole Felonius Gru

    See post #7.

    Edit: sorry, I see you've already tried that.
     
  20. m0nk3y

    m0nk3y New Member

    Root no password works for me on Buzz Player