1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Serious problem in maintenance

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Ubtree, Dec 3, 2012.

  1. Ubtree

    Ubtree Member

    I've successfully installed the custom firmware, and connected by telnet in order to run Fix Disk. When the menu came up, I elected to go into Maintenance mode. The Humax rebooted in Maintenance mode, but I am now unable to get a telnet connection.
    1. Is it safe just to switch off at this point? And if I do, will the Humax reboot in normal mode?
    2. Is there any reason why I might have failed to connect by telnet when in maintenance mode, when I was able to do so in normal operating mode?
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    If you power cycle the Humax it should reboot into normal mode, It's worth checking that your Humax is still using the same IP address, if it's using DHCP the IP may have changed
     
  3. Ubtree

    Ubtree Member

    Thank you very much for the quick response. I've powered down, and then back up. Everything appears OK. Phew!

    The IP address hasn't changed, and I've been able to Telnet back in.

    The reason why I've installed the custom firmware is in order to run Fix Disk.

    (I'm hoping that this will solve a problem with the Humax freezing intermittently when I access the Media menu. It's just possible that the freeze in Maintenance mode was another instance of this freezing. If Fix Disk doesn't resolve the problem, I'll have to consider the PSU.)

    I've been trying to follow the Wiki instructions, but they do not seem to be consistent with what I see on the telnet screen. My understanding of the Wiki instructions is that I would see a command line on running telnet, and that I should input "humax# fix-disk" and, after asking for confirmation that I wanted to continue, the Humax would reboot. Instead, when I run telnet, I see a "TELNET MENU", the only option on which appears to be at all relevant is "1. Restart in maintenance mode", and this is the option that I selected. I then intended, when in maintenance mode, to enter "fix-disk" at the command prompt. Is this correct?
     
  4. Ubtree

    Ubtree Member

    OK, I've just worked out what I was missing. I've now entered cli to go to the command line, and have input fix-disk. The Humax has re-booted, but the Humax has frozen again in Maintenance mode, and I cannot connect using Telnet.
     
  5. Ezra Pound

    Ezra Pound Well-Known Member

    The new Telnet Menu is in the WiKi HERE however this did need adding to the Maintenance Mode Screen
    EDIT
    WiKi now updated HERE
     
  6. af123

    af123 Administrator Staff Member

    Option 1 on the menu has replaced the old command line method. Both still work but the menu version is better in a number of ways - it warns you of any upcoming recordings, properly stops the Humax software and flushes any disk operations prior to rebooting.

    The most likely reason you can't connect is that the Humax isn't getting an IP address properly in maintenance mode. Is your Humax set up to use DHCP or with a static address? If DHCP, try setting it to a static address (can use the currently assigned DHCP address as a short term measure) and see if that lets you connect in maintenance mode.