1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Setting the system time WITHOUT an aerial

Discussion in 'HD-FOX T2 Freeview Receiver' started by Shantyman, Feb 16, 2012.

  1. Shantyman

    Shantyman New Member

    Hi, great box but no iplayer etc.

    Downloaded ntpclient but I haven't a clue how to make it run before everything else starts!

    I have looked on the Web but no simple example, peeps!

    Shantyman
     
  2. af123

    af123 Administrator Staff Member

    If you've installed the ntpclient package then it should run automatically when the system boots. I'd also install forcetime which sets the date to something current during boot.

    BlackHole was experimenting and didn't have consistent luck with the last version of these packages so let us know how you get on.
     
  3. Black Hole

    Black Hole Felonius Gru

    Shantyman, have a look at the relevant topics:

    http://hummy.tv/forum/threads/hd-fox-t2-no-system-clock-without-aerial-feed-tv-portal-problem.707/
    http://hummy.tv/forum/threads/mod-ntpclient.710/

    af123 has updated the packages recently, I have not played with them yet because I am in an assessment phase. However, I can tell you that once the system clock is corrected it takes a reboot or two before the i-plate is correct (although TV Portal doesn't seem to care about that). I find it is adequate to telnet in and use a date command to set it up, the system time is then retained unless you have a power down or a hard reset.

    You will need the custom firmware even for telnet, and in order to install the custom software on an HD-FOX you will need either an Ext3-formatted USB hard drive connected, or an Ext2-formatted USB stick.
     
  4. Shantyman

    Shantyman New Member

    Pulling my hair out!

    Friday, I got a web page up on my laptop and nothing since!

    Using telnet, how can I make sure the webif is running?

    Just in passing, without the webif, can I install the full custom software?

    Cheers

    Shantyman

    PS going into the garden! look what Humax has driven me to!
     
  5. 4291

    4291 Well-Known Member

    Why do you want to run without an aerial?
     
  6. Shantyman

    Shantyman New Member

    Because we had a lousy signal and we get rid of it.

    Been watching TV on the Web ever since using an old laptop which is OK for standard TV but wanted a remote driven box with HD.

    Cheers

    Shantyman
     
  7. Shantyman

    Shantyman New Member

    I find it is adequate to telnet in and use a date command to set it up.

    Black Hole, what is the text for the date command?

    Cheers

    Shantyman
     
  8. Black Hole

    Black Hole Felonius Gru

    You'll find it all in the references I gave you above.

    Be aware that you will not have much success running the custom software unless you have an Ext3 formatted USB HDD or an Ext2 formatted UPD permanently plugged in to host it. The custom firmware will be enough to make telnet work, which is what you seem to have done.
     
  9. af123

    af123 Administrator Staff Member

    Use the service command and check that the mongoose service is running. Just type service at the humax prompt.
    You can check that the web interface is installed by trying to install it again:
    Code:
    humax# opkg install webif
    You have already installed the full custom firmware from a USB disk. The web interface is just one of the many software packages available for running on top of that firmware. It's an optional install, most other packages will run fine without it, you just need to manage them from the command line.
     
  10. Black Hole

    Black Hole Felonius Gru

    ...but the date command is part of the busybox package, which I think means an external drive to host it (af123 confirm?).
     
  11. af123

    af123 Administrator Staff Member

  12. Shantyman

    Shantyman New Member

    Good news, webif is up and running!

    I found the telnet set date command and it worked!

    No Humax TV Portal!

    My box just says no channels, and gives a no entry sign when I press the TV portal button on the remote or try through the menu.

    As history, I took this box to my brother's and used his aerial two weeks ago. The box found lots of channels and then the TV portal worked fine so I know the box is OK!

    While I was at my brothers, I took it through a quick power-on/off/on cycle without the aerial being connected and the TV portal was there.

    As soon as I got it home (obviously powered off), I then went through loading the custom stuff and the TV portal has not worked since.

    How can I get passed the "no channels" and thus no TV portal stage?

    Cheers

    Shantyman
     
  13. Shantyman

    Shantyman New Member

    Samba works fine and I copied a file across.

    When I tried to add the package "custom portal" the following error script came up:

    >>> opkg install custom-portal
    Installing custom-portal (1.12) to root...
    Downloading http://hummypkg.org.uk/hdrfoxt2/base/custom-portal_1.12_mipsel.opk.
    Configuring custom-portal.
    Collected errors:
    * extract_archive: Cannot create symlink from var/mongoose/html/portal/Scripts to 'js': Operation not permitted.
    * extract_archive: Cannot create symlink from var/mongoose/portal to 'html/portal': Operation not permitted.

    Please ask me for any further information on any of this and I'll run/collect/send asap.

    Cheers

    Shantyman
     
  14. Black Hole

    Black Hole Felonius Gru

    I have not found any way around that, in fact I'm surprised you can do anything at all. I'm not sure how you came to loose the channels you had though, did you do a "restore factory" or initiate a rescan?

    The only way forward is to connect an aerial temporarily and allow it to acquire at least one channel.
     
  15. Shantyman

    Shantyman New Member

    The news so far:

    One cannot upgrade the HD-Fox-T2 from an 8Gb USB ext2 stick!
    One can upgrade the HD-Fox-T2 from a 1 Gb Fat16 stick, copy the folder /mod to the 8Gb stick and restart with the 8Gb stick in and then do the "download from the internet" web page, because the download assumes the USB stick is ext2(linux).

    So I did and it worked! no error messages - telnet up and web pages up.

    I am going to my brother's tomorrow so I will use his aerial to get the channels set.

    I will investigate while I am there as to where on the box the Humax TV saves the channel information (unless somebody already knows?) so I can add a dummy channel if I need to factory reset the box in the future.

    Singing "We're on our way..."

    Cheers

    Shantyman
     
  16. Black Hole

    Black Hole Felonius Gru

    Correct. It expects a FAT stick.

    You didn't need to copy the /mod folder, it would be created when you initiate the download from the minimal web page. The files downloaded don't care whether they go on a FAT stick or an Ext2 stick, all they know is the OS has mounted it, but as I found out they don't work properly on FAT! If you remove the stick and fit one which doesn't have /mod on it, you go back to the minimal web page and can then download again.

    That sounds a good idea. af123 probably already has the info, might need a bit of experimenting to see how to make it take.
     
  17. Shantyman

    Shantyman New Member

    It doesn't work from an 8Gb stick, even with a Fat partition (I tried!)

    I was fed up with switching the box on/off/on/off.. so I copied the file structure just in case...

    Good news, ntpclient is doing the time, but only works if you set the date within a month of the correct date (I have been experimenting and it failed on Jan 1st 2012).

    Expect great things after tomorrow.
     
  18. Black Hole

    Black Hole Felonius Gru

    It must be a stick the Humax doesn't like.

    forcedate should get the clock into the right ball park, but if as you say it needs to be within a month that could explain why I have had problems. With auto-update on packages it should be possible to keep forcedate tracking the actual date (af123 - is it possible to make forcedate update its version on the repository automagically?).
     
  19. 4291

    4291 Well-Known Member

    A job for the Wizard? ;)
     
  20. Black Hole

    Black Hole Felonius Gru

    Precisely (and deliberate).

    "Any sufficiently advanced technology is indistinguishable from magic"