1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Slow Responding Remote

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Scuttlebroom, Oct 22, 2012.

  1. Scuttlebroom

    Scuttlebroom Member

    Hi Guys and Gals

    I am having issues with my HDR in that the remote control buttons , and when I used the ir remote package via WebIf it was instant! Batteries are new.

    I have removed all the extra CF packages I can think of that may be causing this (redring, undelete, ir, unencrypt, auto-unprotect) but it still happens, it is fine as soon as I turn on the box, but after a few mins, it slows down, to the point that if I want to say rewind a video, it takes a second or two to do it, and as such, if I want to stop at a particular point, it involves a lot of toing and froing!

    Also the guide, and schedule are painful as well, due to having to wait until the box responds!

    Short of removing CF altogether (not something I particularly want to do as i find it very useful especially rs and WebIf), is there anything else I could try to rectify this issue, I am not sure of any other packages it could be, and I don't; want to remove something I shouldn't!

    Thanks in advance for any advice/help offered!
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    Removing batteries and then pressing keys on the Remote should 'reset' it.
    cutting out any other source of infra red in the room is worth trying, e.g. no energy saving light bulbs etc.
    making sure the IR sensor isn't obscured, you can find it HERE
     
  3. Scuttlebroom

    Scuttlebroom Member

    Cheers Ezra, Tried the removing the batteries, no improvement, switching off and on seems to work for around 10 mins, then it slows up again!

    No lights on at the moment, and has never been an issue before (interesting to note though as I wasn't aware of that issue!)

    Sensor clear, so looks like I may have to bite the bullet and remove CF completely and see if that works, then I can conform it is CF or not!

    Can't work out why it has suddenly started playing up, but will remove CF and report back findings!
     
  4. af123

    af123 Administrator Staff Member

    Have you tried watching the IR output from the remote on a digital camera?
    It does sound more like the machine than the remote from what you've said but worth checking.
    Otherwise I think you need to remove the customised firmware to confirm that it isn't a factor.
     
    Scuttlebroom likes this.
  5. af123

    af123 Administrator Staff Member

    NB: If you install the ir package and enable diagnostics using the ir3debug_on diagnostic, then remote control input will be logged in the humaxtv.log file - it might be worth doing to see what the Humax is seeing from the remote control, if anything.
     
    Scuttlebroom likes this.
  6. Shaggy

    Shaggy Member

    I had similar symptoms to this a few weeks ago, response times were sometimes >10s; as I had very high network traffic at the time (~80% usage with gig-E), I suspected that may have been the culprit, but it continued for the next couple of days (after traffic levels were normal). In desperation I followed the wiki (in an emergency, read the instructions!) to un-install and then re-install the CF, which seemed to cure it. Someone did suggest I may have installed the latest package (SS) on a part of the disk with bad blocks, which was undone when reinstalling, but I never did conclusively find the cause.

    Original thread here.
     
    Scuttlebroom likes this.
  7. Scuttlebroom

    Scuttlebroom Member

    Hi af, yes that was checked and it is working OK.
    Was afraid you were going to say that!
     
  8. Scuttlebroom

    Scuttlebroom Member

    Hmm, thanks, for that will install again now and see what happens! No doubt will be asking you what the diagnostics say!
     
  9. Scuttlebroom

    Scuttlebroom Member

    Cheers Shaggy, I knew someone else had a similar issue!

    Well if the diagnostics doesn't throw anything up ant least I know that there is a cure, hopefully!
     
  10. af123

    af123 Administrator Staff Member

    You'll see things like this:

    Code:
    Real IR code: 00000000 0xff001000
    Real IR code: 0x000001 0xff001000
    Real IR code: 00000000 0xf30c1000
    Real IR code: 0x000001 0xf30c1000
    
     
  11. Scuttlebroom

    Scuttlebroom Member

    Right ir installed and working, one thing I notice straight away it wont change channels to BBC news (80) or BBC One HD (101) it doesn't seem to like the zero for some reason!

    I can confirm that the ir is faster than the actual remote!

    Also not sure how to get the diagnostic out, what do I put into the run diagnostic box in WebIf?
     
  12. 4291

    4291 Well-Known Member

    What does it say in the History pane when you push 101?
     
  13. Scuttlebroom

    Scuttlebroom Member

    ONE (0x3) ZERO (0xc) ONE (0x3) OK (0x13)

    And it changes to channel 11 (Pick TV)
     
  14. 4291

    4291 Well-Known Member

    Why OK?
     
  15. Scuttlebroom

    Scuttlebroom Member

    No idea, that is what is shown on the history

    Image added!
     

    Attached Files:

  16. Scuttlebroom

    Scuttlebroom Member

    Even stranger, ir now appears to be working OK in that it changes to BBC News (80) and BBC One HD (101)!
     
  17. Black Hole

    Black Hole Felonius Gru

    'Cos if you press OK after entering an LCN it changes immediately instead of waiting to time out further input. I think the preset channel macros automatically put OK on the end.

    There has been some work done to increase the rate at which the ir package can accept commands, so the rate at which the WebIF sends them was also increased. Possibly this is a case of them being sent too fast. What happens if the individual buttons are pressed, at a slow rate, instead of the macro?
     
  18. 4291

    4291 Well-Known Member

    I get the impression that Scuttlebroom didn't press the OK button and that it appeared in the history pane when he had just pressed 101. I don't get it.
     
  19. 4291

    4291 Well-Known Member

    My box changes instantly. Pressing OK just updates the banner sooner.
     
  20. Black Hole

    Black Hole Felonius Gru

    Really? Mine (both) wait a moment to see if I've finished - otherwise it would change to 1 at the first button press.

    (Previous post updated)