"Smart" TV that works well with Humax HDR-FOXT2 DLNA


Currently have a HDR-FOX-T2 in lounge using the very helpful custom firmware and linked to a HD-FOX-T2 on second bedroom TV.... another TV using a little Cyclone media player shows Humax over DLNA fine.....

So, bought a Samsung 32" 5600 series TV with all the normal Smart features and it happily showed all the files on a NAS device through DLNA and picked up the HDR and showed all the folders for DLNA but then only a handful of files in a few of those directories - no obvious reason for which ones though always consistent, i.e. showed SD, HD, and other MPG files etc. so with no help from Samsung and short of firing up Wireshark to see what it was requesting gave up and returned it.

So... what I am after

32" approx. TV
iPlayer etc. if possible.
but mainly to play DLNA from the Humax OK.

So anyone bought a currently available TV that works that they are happy with, or know a source of HD-FOXT2?


As the TV showed (played?) some of the files from your Humax, I think it would be very difficult for anyone to recommend a TV that will do a better job without having the same failing files in the same file structure to try it out.
Thanks, having researched this tv afterwards it appears some other people had problems with only showing the first X files etc. but yes COULD be some issue with a file on the humax it was choking on I suppose, though it did play through DLNA on two other devices OK for all files on the Humax.... was just odd that it showed the entire directory structure but then maybe 10 files in some of the random directories.

If no-one has any suggestions from experience will give a suitable looking one a try, after all they all say DLNA compliant.
I would go for a roll-your-own solution in the form of a Raspberry Pi, or search out a second hand HD-FOX.
Smart tellies seem to be very dumb in my (limited) experience.
I have access to two different Sony Bravias. They both show all folders but only see the SD content. Attempts to play anything results in a box with the correct name/duration etc. but otherwise black/silent and the counter resolutely stuck on 00:00.
Both SD and HD content is decrypted on the T2.
I tried renaming .ts to .m2ts and nothing improved.

DLNA is sh!t anyway - the transport controls are rudimentary to say the least, and designed to drive you barmy.
This is why I haven't bothered any further.
Thanks for your replies too. After third telly I give up and agree so will end up with cheaper telly and HD-FOX T2 if I can find one, or a media player / raspberry PI etc. like I have in the past, just hoped they might actually WORK by now!!!

I know DLNA is a naff standard at best it seems a standard that you have to follow the bits you feel like following, make other bits up and clearly such good programmers working on them that they just crash to the extent of rebooting the system if they get some parameter out of the bounds they could handle!

Spoilt a bit 'cos my main Samsung TV "just works" with DLNA and network to the HDR and everything else and yet to find anything it won't play, as does the little Sumvision Cyclone Micro 4 on another telly too.. A second earlier Samsung 32" model I tried briefly ended up was now the same software as the 5600 model althought the pictures looked different so that went straight back. Tried a Philips Android based model and that will play some of the Humax files ... but then others just sit there twirling around endlessly "please wait" connecting to mediatomb, using the built in DLNA server some just plain crash the telly and it reboots!

So another faulty item to go back.
I'd add my support to a Pi based mediacentre (Kodi).
Always works well (as long as I have set up decryption)
When I checked this out a few years ago I found I couldn't use the wifi in my TV but the Bluray player connected to it
worked a dream - both are LG kit and perhaps 3-4 years old by now. It was just a short term test for curiosity - I can't speak for long term use.
(As BH mentioned above that was file share)
In that case, you don't need to decrypt - only auto-unprotect (for HiDef). If it doesn't work without decryption, you must be using network file share.

Incidentally, with VLC on iPad, I discovered I could access the HDRs using FTP!