• The forum software that supports hummy.tv has been upgraded to XenForo 2.1!

    This upgrade brings a number of improvements including the ability to bookmark posts to come back to later. Please bear with us as we continue to tweak things and open a new thread for any questions, issues or suggestions in Site/Forum Issues.

Solution to Windows/SMB share contents not being visible

everthewatcher

Forum Supporter
Looks like I may have found the solution to Windows/SMB shares being visible from the HDR but not their content - forgive me if this has been posted elsewhere.

The clue was scanmounts.log having this:
mount: mounting //192.168.1.11/SharedMedia on /media/CASTLE failed: Cannot allocate memory

It seems Windows has to be told it's acting a server and needs a couple of registry changes.

Here's a few links to the solution:
It had got to the point of being a daily occurence here, which I now realise was probably down to the increasing number of files in the share, to the extent that I'd started using DLNA. Since I've made the changes on a Win7 machine last week the problem has gone away.
 
Last edited:

Black Hole

May contain traces of nut
My comments are purely cosmetic: how about putting that you are talking about a Windows share in the title?
 

Black Hole

May contain traces of nut
It may well be a common problem, but for an uncommon scenario. How many people use a Windows machine to serve their viewing? Not me, that's for sure.
 
OP
everthewatcher

everthewatcher

Forum Supporter
There's a shared drive on the Win7 machine that's used for non off-air stuff - Youtube and iPlayer downloads etc. - plus some recordings pulled from a long-gone 9200T.

Anything recorded on the HDR gets played on it, although I have started offloading HD films to the shared drive.
 
Top