Some files renamed .ts and some files no longer play

Colinn

New Member
Hi I have tried looking for help on this, but can't find anything. I have upgraded to CFW 2.15, just now, but it has not solved the problem.

On the 'media' menu some previously recorded programmes have "_yyyymmdd_hhmm.ts' added to them, and some haven't.

When I try to play these .ts files I get "cannot support this file format" (even though they were previously playable before renaming)

Some of the unrenamed files which I know played before give "Recording failed: unknown error". These can be HD or SD TV recordings, or even radio recordings. I can't see any connection between the affected files and the error.

Any help much appreciated. I don't know where to start ...
 

Black Hole

May contain traces of nut
The name you are seeing is the real name of the recording file, it is usually hidden by a "media name" which is stored in the .hmt file that is associated with the .ts by having the same name and being stored in the same folder.

The Humax expects to see a .hmt (and .nts) with the .ts, so it is probably that these are missing stopping it from playing.

The question is, where has the .hmt gone. Have you been moving files by FTP?
 
OP
C

Colinn

New Member
Hi Thanks. No, I haven't been moving files or anything, I was just trying to watch programmes that I have recorded.
 

af123

Administrator
Staff member
Did this problem start while running the standard firmware?
All recordings should have the date as part of their filename so it's strange that you have some without that.
Which ones aren't playing properly (those with yyyymm etc. or those without?)
 

Ezra Pound

Well-Known Member
All recordings should have the date as part of their filename so it's strange that you have some without that
Surly you wouldn't expect TS files with a complete set of sidecar files to display the time /date part of the file name on the TV would you?
 

af123

Administrator
Staff member
Good point. So these ones have presumably at least lost their .hmt file.
 

af123

Administrator
Staff member
Ok, so what appears to have happened to these broken recordings is that at least one of their sidecar files is missing or corrupt.
Since you have the custom firmware installed now, can you use the web interface media browser to find one of these recordings and click on it? The window that pops up will have a section for Files - can you post details of what appears there if it works?

 
OP
C

Colinn

New Member
Hi Thanks. The forum won't let me post what I'm trying to post as I am new (10 posts qulaifying limit). I have looked at the files for one of the "renamed" recordings that won't play, and I'm getting two error messages:

/media/My Video/Shadow of a Doubt_20120925_1710.hmt: No such file or directory

and

Runtime Error: file.jim:66: expected integer but got "" at file "file.jim", line 66
 
OP
C

Colinn

New Member
Regarding the recordings that look OK in "Media-Video" list and definitely played before, when I look into the "files" option you explain it shows the filename, a likely looking filesize, but against loading there's just the revolving whirlygig thing for a long time, then this (for example):

libpostproc 52. 0.100 / 52. 0.100 /media/My Video/The Reader_20120725_2100.ts: Operation not permitted
 
OP
C

Colinn

New Member
And on a radio recording:

libpostproc 52. 0.100 / 52. 0.100 /media/My Video/The Unbelievable Truth_20121231_1829.hmt: Invalid data found when processing input
 
Top