Some GUI buttons not working after webif upgrade [Fixed - Clear Browser Cache]

Robobunny

New Member
Hi, have been using the CF for a couple of years - excellent work, thank you.

I've just upgraded my HDR-FOX T2 from 2.22 to 3.03 and noticed in "Diagnostics" that the "Reboot System" button is red (all others yellow) and (after accepting the confirmation prompts) it's calling an invalid URL on the box and getting a "404 - Not Found" error.

The HTML sent is "GET /cgi-bin/restart.jim" and that file doesn't exist in my box's "./mnt/hd2/mod/webif/cgi-bin/" directory. I have a workaround which is to browse to <IP address>/restart and press the button there.

So wondering why that file is missing - the feature worked before I upgraded (haven't downgraded to see what happens). Tried force-reinstall of the webif, no change. Any ideas?
 
OP
R

Robobunny

New Member
Forgot to mention, after the upgrade I ran a maintenance mode " 1 - Check and repair hard disk (fix-disk)" (fix-disk.log showed no errors but wondered if that could've done it - seems unlikely), and I also cleared epg and reset DLNA database. Probably not a cause but thought I better mention all steps done.
 
OP
R

Robobunny

New Member
Also the Diagnostic "Channel Information" link is similarly broken (it's looking for /cgi-bin/channel.jim which also is missing). I removed the webif (
opkg remove webif --force-depends) and let it reinstall it from the basic web page, and no difference. I let the packages update themselves after the CF upgrade, so the problem could be with package updates not the CF update. So the title of this thread is wrong but I can't edit it. I don't know if the problem is that the files are missing or the links are pointing to the wrong location...
 

prpr

Well-Known Member
Have you cleared your browser's cache?
You can edit the thread title by clicking on the option under "Thread Tools" towards the top right of the top of the thread.
 
OP
R

Robobunny

New Member
[FIXED] Thanks prpr, clearing the cache got those items working again. Hadn't occurred to me that the browser itself was causing the problem as only the Humax was altered. So in this case it was definitely the webif upgrade, not the CF upgrade, which led to this (as I upgraded CF, changed IP address [for unrelated reasons], upgraded the webif, and the browser had cached the 'wrong' path for both IPs). I'll edit the title to reflect this. Thanks again.
 
Top