1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Splash Screen of Doom

Discussion in 'HDR-FOX T2 Freeview Recorder' started by oijonesey, Dec 23, 2011.

  1. oijonesey

    oijonesey Hummy.tv SEO Guru

    As much as I like to prove myself right http://hummy.tv/forum/threads/hdr-fox-t2-1tb-freezing.653/#post-9508 in this case it's bitter sweet. :( When I tried to bring the box out of standby this morning it wouldn't wake up. I did the usual IT thing and went for the switch round the back and it just went to the Humax splash screen (with the logo) and saying 'Start System' on the front and stuck there. There's no sound from the box at all - in particular no sound of a hard disk doing anything at all which presents a challenge as I'm not sure I can even try resetting the firmware if the disk won't even spin!! Will try anyway....

    @Black Hole - a new entry for the glossary - SSOD. And yes I'll note the s/n of the box if (looking like when) it has to go back.
     
  2. Black Hole

    Black Hole Felinos Guru

    If the disk really isn't spinning, either the power supply has failed or the disk has died (if the latter, you won't need to worry about what's on it). You should at least wipe the firmware, even if you can't get to the software.

    If it can be done without trace, and if it were me (my HDR is 16 months old now), I would be inclined to open up and see what's what. If the voltages are OK to the hard drive just fit another one myself (which could be done by Christmas).
     
  3. oijonesey

    oijonesey Hummy.tv SEO Guru

    Update: It's working again!! This is what I did in case this enlightens anyone else...
    1. I tried to reset the firmware back to 1.02.20, it copied in OK, but then only got to 30% on the programming phase and reported error E-HC (incorrect header block according to the wiki).
    2. Turned the box off and on at the switch
    3. Got the quick flash of green screen (promising I thought - more than I'd seen so far this morning) but then it just went back to standby
    4. Stabbed the on button on the remote (out of frustration!) and it came back!! Webif working so still on custom firmware.
    So I'm chuffed it's working - but unchuffed there was no apparent reason that it stopped in the first place. The only thing I was worried about was that I have the auto package update running so could something have come down last night? Possible - but I think it's highly unlikely something got into the wild that could do this on my box and not on the boxes of the developers.

    So I'll try another reflash to see if the E-HC error disappears then perhaps remove all the custom firmware, then back up all the recordings!! A case of ho-hum when all I wanted was ho-ho-ho!
     
  4. Black Hole

    Black Hole Felinos Guru

    This sounds very similar to what happens to my HD-FOX from time to time (particularly if I'm trying to reboot because the sound is missing from the HDMI - I've bypassed that by using analogue sound). Basically it goes back into standby after the splash screen, and the limited front panel display says (can't remember - maybe something like "load"). I have found I can break out of this cycle if I press the standby button immediately (but it invariably lost the system time before I had the Internet time source).
     
  5. oijonesey

    oijonesey Hummy.tv SEO Guru

    Checked the Diagnostics on the webif - the rs log has about a dozen of these at the top but I can't tell if the list is oldest at the top?

    >>> Contents of /mod/tmp/rs.log 130.29 KiB Runtime Error: /mod/sbin/rs_process:113: couldn't write file "> Unregistered device.": Read-only file system at file "/mod/sbin/rs_process", line 113 Processing command >>> Unregistered device. ( ) Unknown command ''
     
  6. af123

    af123 Administrator Staff Member

    Yes, it's oldest at the top. That error is probably nothing to worry about although I don't know why it is there.
    The log file is on the disk, so if the disk really had become read-only then there wouldn't be anything in the log about it!
    It's more likely that the script tried to write to the root filesystem for some reason and that is always read-only.
     
  7. oijonesey

    oijonesey Hummy.tv SEO Guru

    Hmmm the plot thickens - I re-connected my USB HDD (disconnected to re-do the firmware refresh) and turned off the box to get it to show on the media menu - and the re-start failed just like before. Disconnected the USB and it booted up again!! So the problem is to do with the HDD it now seems?....
     
  8. ChrisDaniels

    ChrisDaniels Well-Known Member

    I'm getting simalar issues with my HD box at the moment.
    A week or so ago, the HDD went read only.
    I had to boot a live Linux CD to scan and fix the hard disc.
    I put it down to the package auto updater going wrong and thought nothing more of it.
    Then, this past week, it's happened again, but worse.
    Now when the HDD is connected, the broadcast picture freezes after a minute or two but the sound continues as normal.
    The HDD activity light is lit, but not doing anything (it seems) and the box will not respond to anything.
    If I disconnect the HDD and boot the box, it's fine.

    I re-ran a scan and repair last night on the HDD using a live cd again, but it's not fixed.
    I'm going to attempt further fixes to it today, but I'm confused as to why it's doing this...
     
  9. brianmt

    brianmt Member

    I posted this sometime ago

    I have HDR Fox T2 which is just over 1 year old and is a really fine unit but It seems to have a peculiar problem.

    Since day one the unit, sometimes, would be still off in the morning ie refuses to come out of standby. When it does this, the unit has to be switched off and on at the back before the unit could be used again. As this was a rare occurrence it didn’t bother me too much but now I’ve worked out what causes it .

    If you record a program which takes it past it’s standby off time ( ie normal standby off time 1230 am say, recording a film with an end time of 0100am)
    Then the unit will not come out of standby ( 8am on time) next morning.
    In fact what happens is, the unit is totally unresponsive the next morning, you have to switch unit off/on at the back, the unit will come on briefly then switch itself off, you can now switch the unit on with the remote or front panel.

    Were you by any chance doing a late night recording ?

    I did email humax about this 4 times no reply, their customer support really is crap shame !!
     
    Tim Day likes this.
  10. oijonesey

    oijonesey Hummy.tv SEO Guru

    Good question - but I wasn't as far as I can recall. Looking on the rs service view of my recordings the last one was on the 21st and it was working fine all of yesterday and last night
     
  11. brianmt

    brianmt Member

    Maybe there are other factors that make the box lockup. Mine was locked up this morning but I think I was recording something, will check when I get home.
     
  12. Black Hole

    Black Hole Felinos Guru

    This is interesting. I thought I detected a correlation with having a USB stick in my HD-FOX containing the firmware update (even though you have to hold the button in) - but I could be wrong. I have not had an incidence of it failing to boot now the USB stick is Ext2, but that might be coincidence.
     
  13. oijonesey

    oijonesey Hummy.tv SEO Guru

    The question now is, with three months of the standard warranty left do I hang on and it goes phhhttt at 13 months or do I dig my heels in for a replacement (aka refurb) or push 'em for a full refund and go to John Lewis for a new one, or play the SOGA rule book as per the advice on an existing post (sorry on the (cr)apple so can't reference it here) or even wait til after 12 months and play the 'plus1' version of SOGA and claim not suitable?? Well after having typed all this on a phone I'm gonna cross my fingers and wait til after Christmas!!

    Now I'm off to back up all my recordings ;-) :)

    P.S. thanks all for your replies
     
  14. Sam Widges

    Sam Widges Active Member

    Isn't the standard warranty 2 years? Or did you buy a refurbished one?
     
  15. MattC

    MattC Member

    Yeah, it should be 2 years.. plus if you bought it with a certain credit card, you may get an extra 1 year on top, like I did with an Egg Money card.
     
  16. oijonesey

    oijonesey Hummy.tv SEO Guru

    I got it from humax direct so if that means 2 years then happy days and thanks for the nod. Still haven't tried reconnecting the USB disk after switching on, also need to see if I can read it when connected to laptop but since unplugging it I've had no issues at all - cue commentators curse!!
     
  17. Tim Day

    Tim Day Member

    I have also seen the "won't come out of standby" problem several times. When we got the unit (which was itself a warranty replacement for a failing disk) it was doing it very frequently but Humax support said do a factory reset and that knocked it back to maybe once a month or so. I then mainly suspected it was associated it with the box being not power cycled and properly rebooted for a while (even when on standby I assume it's still "on" in some sense) and try and do that once a week or so and that seems to have helped although not completely. Haven't noticed a correlation with late night recording (don't think I have anythink like a standby time set) but haven't really been looking for one. I'm now in the habit of checking the box every morning as it does seem to be an overnight thing rather than daytime.

    (Other stuff in this thread also made me go and check the warranty as we are coming up to the 1 year anniversary sometime in February and I was worrying I was running out of time if the unit is a dud, but pleased to see it's 2 years on the invoice from Humax direct so there's less pressure on).