Struggling with HD Fox T2 upgrade

prpr

Well-Known Member
Got two HD Fox T2 units to upgrade.
Both on firmware 1.02.29, both on loader L7.27, unit A Micom 7.61, unit B Micom 7.66.

On unit A:
Tried 1.03.02_mod_3.13 and failed with two different USB devices. Eventually I remembered I had problems updating mine and had to rename HD_FOX_T2_upgrade.hdf to HD_FOX_T2_UPGRADE.hdf before it would work. So I did so again and it all worked successfully.
Interestingly, Humax's instructions say it has to be called hd_fox_t2_upgrade.hdf, and that is what their file is called, so why is the CF (wrongly?) using mixed case?

On unit B:
Tried the all upper case variation without success on both USB devices. If I plug the USB stick in, it just doesn't detect it - the Data Storage item in the menus is greyed out. If I plug an SSD via SATA-USB adapter in, the Data Storage item is OK, but I still can't load firmware from it.
Haven't yet tried all lower case with the latter (job for tomorrow now), but does anyone have any ideas what to do next if it fails? I guess I could rummage for another USB stick - the ones I have readily accessible are both the same type (but have always worked eventually).
Do I guess correctly that the Micom difference is not significant?
 

free30

Member
sorry prpr didn't see it was you and you mostly know better than me.........I was going to say format to Fat32 but I might not be wrong
 
OP
prpr

prpr

Well-Known Member
So, this morning I tried renaming it to all lower case and switching on. Nothing doing. Whilst pondering what to do next, I got the "Loading USB" type message on screen - strange I thought - why the delay? I switched off and on again whilst barely touching the box to save disturbing anything and it went into download/programming mode. I can only conclude that it's defective hardware somehow - poor connection on the contacts in the USB socket or a dry joint on the board - probably the latter I would suspect.
 
Top