Surround Sound loses channels on copying to PC

Black Hole

May contain traces of nut
If it helps I have a couple of episodes of Doctor Who with 5.1 audio:
Temporarily rename the hmt file and see whether the recording then plays in stereo rather than multichannel (presuming you have the means).

Then perhaps you could restore the hmt but toggle the bit identified by xyz321.
 

Black Hole

May contain traces of nut
What if the multi-channel AAC audio is in a .MP4 file? Maybe the HDR-FOX will output that without downgrading it to stereo?
 
OP
K

Kevin

New Member
Thank you all for your interest. Here are 3 hmt files.

1) King of Thieves_20220605_2236.hmt is the original, generated by the Hummy, which plays in surround.
2) King of Thieves_20220605_2236 (scarpkg).hmt I generated using the sidecar package, from the original ts file. This plays in surround.
3) King of Thieves m2ts.hmt I generated using the sidecar package, from an m2ts file, which I exported from VideoRedo, and then changed the extension to .ts. This only plays in stereo.

I suppose it is possible that the problem lies in my m2ts file? I set VideoRedo to output AAC 5.1. and VideoRedo properties confirm that the file has 6 channel audio, but some may be empty?
 

Attachments

  • King of Thieves_20220605_2236 (scarpkg).hmt
    2 KB · Views: 0
  • King of Thieves m2ts.hmt
    2 KB · Views: 0
  • King of Thieves_20220605_2236.hmt
    2 KB · Views: 0
OP
K

Kevin

New Member
What if the multi-channel AAC audio is in a .MP4 file? Maybe the HDR-FOX will output that without downgrading it to stereo?
I have generally used H264.MP4 output from VideoRedo (I did not know about using M2TS and changing the extension). My first attempt was an MP4 and played stereo, but had no sidecar files, which I now know causes this problem. I will try generated sidecar files, using the package, for my MP4 file.
 
OP
K

Kevin

New Member
Have you tried analyzing the recordings (original and edited) with ffprobe? If you have ffmpeg installed on your HDR-FOX you can use the following from the command line:
Code:
ffprobe -i "Recording Name.ts"
This will tell you exactly which streams are available in each file.

EDIT. To add, first copy the recordings to the "My Video" folder then use the following command to navigate to this directory:
Code:
cd "/media/My Video"
Thanks, but you have lost me here! Is ffmpeg a package which I can install with webif? I will look.
 
OP
K

Kevin

New Member
I have generally used H264.MP4 output from VideoRedo (I did not know about using M2TS and changing the extension). My first attempt was an MP4 and played stereo, but had no sidecar files, which I now know causes this problem. I will try generated sidecar files, using the package, for my MP4 file.
No, the sidecar option is greyed out on my mp4 as for mkv.
 

Black Hole

May contain traces of nut
I will try generated sidecar files, using the package, for my MP4 file.
You can't. sidecar is for recreating the .hmt and .nts helper, or "sidecar", files which are normally generated by the HDR-FOX in the process of making a recording, and therefore only applies to native (or recreated) [M2]TS files.

The reason I asked about MP4 is because the HDR-FOX will play them from USB or if imported, and was curious whether you would get 2.0 or 5.1.

but had no sidecar files, which I now know causes this problem.
That it needs the appropriate flag in the .htm file before it will output 5.1 from a recording is not a prediction of how it will behave with an MP4 file (or any other format). The .htm flag theory is not yet conclusive either.

Is ffmpeg a package which I can install with webif?
It is almost certainly already installed as a dependency of the web-if package, and available to be called from the command line. However, it is also useful to download to your PC (the Windows version, that is), and become familiar with it. Ditto ffprobe.
 
OP
K

Kevin

New Member
I have now managed to open the audio channels of my .mp4 file, from VideoRedo, in Wavepad. This confirms that all six audio channels are present and contain data, so the issue, for this file at least, must be the Hummy choosing not to play it as surround sound.
 
Top